aboutsummaryrefslogtreecommitdiff
path: root/sysutils/pacman
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2014-09-23 18:56:46 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2014-09-23 18:56:46 +0000
commit9c9765eb68deaa52344b06451a5c7142f841b0e7 (patch)
tree83ca2cc38178e0d22dca2d5274faf85677246671 /sysutils/pacman
parent247b017ff7e38260b326afc222a844dab3440771 (diff)
downloadports-9c9765eb68deaa52344b06451a5c7142f841b0e7.tar.gz
ports-9c9765eb68deaa52344b06451a5c7142f841b0e7.zip
- Drop @dirrm* from plist
- Use newer plist practices
Notes
Notes: svn path=/head/; revision=369112
Diffstat (limited to 'sysutils/pacman')
-rw-r--r--sysutils/pacman/Makefile3
-rw-r--r--sysutils/pacman/pkg-deinstall11
-rw-r--r--sysutils/pacman/pkg-install10
-rw-r--r--sysutils/pacman/pkg-plist10
4 files changed, 9 insertions, 25 deletions
diff --git a/sysutils/pacman/Makefile b/sysutils/pacman/Makefile
index 77788605437b..942990806dbf 100644
--- a/sysutils/pacman/Makefile
+++ b/sysutils/pacman/Makefile
@@ -3,7 +3,7 @@
PORTNAME= pacman
PORTVERSION= 4.0.3
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= sysutils
MASTER_SITES= ftp://ftp.archlinux.org/other/pacman/ \
http://mirror.amdmi3.ru/distfiles/
@@ -79,7 +79,6 @@ post-patch:
.endif
post-install:
- @${RM} -rf ${STAGEDIR}/var # handled by pkg-install
.for f in makepkg.conf pacman.conf
${INSTALL_DATA} ${WRKSRC}/etc/${f} ${STAGEDIR}${PREFIX}/etc/${f}.dist
.endfor
diff --git a/sysutils/pacman/pkg-deinstall b/sysutils/pacman/pkg-deinstall
index bff986c1481e..130ef3a9ccb7 100644
--- a/sysutils/pacman/pkg-deinstall
+++ b/sysutils/pacman/pkg-deinstall
@@ -5,16 +5,13 @@
case $2 in
POST-DEINSTALL)
- rmdir /var/cache/pacman/pkg 2>/dev/null || true
- rmdir /var/cache/pacman 2>/dev/null || true
- rmdir /var/lib/pacman 2>/dev/null || true
- rmdir /var/lib 2>/dev/null || true
- if [ -e /var/lib/pacman -o -e /var/cache/pacman ]; then
+ if find /var/lib/pacman /var/cache/pacman -type f 2>/dev/null | grep -q ''; then
echo ""
echo "To completely remove the port, please remove the following"
- echo "directories and the content manualy:"
+ echo "directories and the content manualy if its no longer needed:"
echo ""
- echo " /var/lib/pacman /var/cache/pacman"
+ echo " /var/cache/pacman"
+ echo " /var/lib/pacman"
echo ""
fi
;;
diff --git a/sysutils/pacman/pkg-install b/sysutils/pacman/pkg-install
deleted file mode 100644
index 36a5900a4f4c..000000000000
--- a/sysutils/pacman/pkg-install
+++ /dev/null
@@ -1,10 +0,0 @@
-#!/bin/sh
-#
-# $FreeBSD$
-#
-
-case $2 in
-POST-INSTALL)
- mkdir -p /var/lib/pacman /var/cache/pacman/pkg
- ;;
-esac
diff --git a/sysutils/pacman/pkg-plist b/sysutils/pacman/pkg-plist
index 1ba0044fb86f..b1af43520237 100644
--- a/sysutils/pacman/pkg-plist
+++ b/sysutils/pacman/pkg-plist
@@ -118,13 +118,11 @@ man/man8/vercmp.8.gz
%%NLS%%share/locale/zh_TW/LC_MESSAGES/libalpm.mo
%%NLS%%share/locale/zh_TW/LC_MESSAGES/pacman-scripts.mo
%%NLS%%share/locale/zh_TW/LC_MESSAGES/pacman.mo
-%%NLS%%@dirrm share/locale/sr@latin/LC_MESSAGES
-%%NLS%%@dirrm share/locale/sr@latin
-%%NLS%%@dirrm share/locale/kk/LC_MESSAGES
-%%NLS%%@dirrm share/locale/kk
%%DATADIR%%/ChangeLog.proto
%%DATADIR%%/PKGBUILD-split.proto
%%DATADIR%%/PKGBUILD.proto
%%DATADIR%%/proto.install
-@dirrm %%DATADIR%%
-@dirrmtry %%PACMAN_ROOT%%
+@dir /var/cache/pacman/pkg
+@dir /var/cache/pacman
+@dir /var/lib/pacman
+@dir /var/lib