aboutsummaryrefslogtreecommitdiff
path: root/sysutils/pear-Log
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2018-03-08 19:48:41 +0000
committerMathieu Arnold <mat@FreeBSD.org>2018-03-08 19:48:41 +0000
commita1993564e04f29ecbaa05be740547c8677d423cd (patch)
treea942b9de6ec3ced252f123bf8a905b18d685aa72 /sysutils/pear-Log
parent868fb29f23bfae4d55ab923ea34259adf63b4886 (diff)
downloadports-a1993564e04f29ecbaa05be740547c8677d423cd.tar.gz
ports-a1993564e04f29ecbaa05be740547c8677d423cd.zip
Introduce PHP flavors.
Ports using USES=php:phpize, php:ext, php:zend, and php:pecl are now flavored. They will automatically get flavors (php56, php70, php71, php72) depending of the versions they support (set with IGNORE_WITH_PHP). As a consequence, ports using USES=pear and USES=horde are also flavored. PR: 226242 Submitted by: mat Exp-run by: antoine Approved by: portmgr Sponsored by: Absolight Differential Revision: https://reviews.freebsd.org/D14208
Notes
Notes: svn path=/head/; revision=463917
Diffstat (limited to 'sysutils/pear-Log')
-rw-r--r--sysutils/pear-Log/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/sysutils/pear-Log/Makefile b/sysutils/pear-Log/Makefile
index dcb1b1c979a5..c313a0970877 100644
--- a/sysutils/pear-Log/Makefile
+++ b/sysutils/pear-Log/Makefile
@@ -18,9 +18,9 @@ PEAR_MDB2_DESC= PEAR::MDB2 support
PEAR_MAIL_DESC= PEAR::Mail support
PHP_SQLITE_DESC= PHP sqlite support (php5 only)
-PEAR_DB_BUILD_DEPENDS= ${PEARDIR}/DB.php:databases/pear-DB
-PEAR_MDB2_BUILD_DEPENDS= ${PEARDIR}/MDB2.php:databases/pear-MDB2
-PEAR_MAIL_BUILD_DEPENDS= ${PEARDIR}/Mail.php:mail/pear-Mail
+PEAR_DB_BUILD_DEPENDS= ${PEARDIR}/DB.php:databases/pear-DB@${PHP_FLAVOR}
+PEAR_MDB2_BUILD_DEPENDS= ${PEARDIR}/MDB2.php:databases/pear-MDB2@${PHP_FLAVOR}
+PEAR_MAIL_BUILD_DEPENDS= ${PEARDIR}/Mail.php:mail/pear-Mail@${PHP_FLAVOR}
PHP_SQLITE_USE= PHP=sqlite3
.include <bsd.port.mk>