aboutsummaryrefslogtreecommitdiff
path: root/sysutils/pftop/Makefile
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2018-11-02 13:32:34 +0000
committerRene Ladan <rene@FreeBSD.org>2018-11-02 13:32:34 +0000
commit8a502cb2d43b4059a5678ee4539ca03603104107 (patch)
tree2c2c3d0def8d9d1ad349013f7b532f0065f57789 /sysutils/pftop/Makefile
parentf60d4bacdc58ec061406d72cace1ac1266952e39 (diff)
downloadports-8a502cb2d43b4059a5678ee4539ca03603104107.tar.gz
ports-8a502cb2d43b4059a5678ee4539ca03603104107.zip
Remove compatibility code for FreeBSD < 11.2 from all ports.
Simplify some ports where DragonFlyBSD no longer needs to be special-cased. Submitted by: rene Reviewed by: bapt, jbeich Differential Revision: https://reviews.freebsd.org/D17724
Notes
Notes: svn path=/head/; revision=483807
Diffstat (limited to 'sysutils/pftop/Makefile')
-rw-r--r--sysutils/pftop/Makefile16
1 files changed, 4 insertions, 12 deletions
diff --git a/sysutils/pftop/Makefile b/sysutils/pftop/Makefile
index 6064762f7d9e..abeec6b2c5b6 100644
--- a/sysutils/pftop/Makefile
+++ b/sysutils/pftop/Makefile
@@ -16,15 +16,14 @@ OPTIONS_DEFINE= ALTQ
ALTQ_DESC= ALTQ support for queue statistics
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1100080
EXTRA_PATCHES+= ${FILESDIR}/extra-patch-bpf_dump.c \
${FILESDIR}/extra-patch-sf-gencode.h
-.endif
MAKE_ARGS= LOCALBASE="${PREFIX}" OSLEVEL=45
-CFLAGS+= -DHAVE_SNPRINTF=1 -DHAVE_VSNPRINTF=1
+CFLAGS+= -DHAVE_SNPRINTF=1 -DHAVE_VSNPRINTF=1 \
+ -DHAVE_FINE_GRAINED_LOCKING=1
.if ${PORT_OPTIONS:MALTQ}
CFLAGS+= -DHAVE_ALTQ=1
.endif
@@ -33,9 +32,6 @@ EXTRA_PATCHES+= ${FILESDIR}/extra-patch-cache.c \
${FILESDIR}/extra-patch-config.h \
${FILESDIR}/extra-patch-pftop.c \
${FILESDIR}/extra-patch-sf-gencode.c
-.if ${OPSYS} == FreeBSD
-CFLAGS+= -DHAVE_FINE_GRAINED_LOCKING=1
-.endif
EXTRA_PATCHES+= ${FILESDIR}/extra-patch-engine.c
@@ -45,20 +41,16 @@ MAKE_ENV+= __MAKE_CONF=/dev/null
PLIST_FILES= sbin/pftop man/man8/pftop.8.gz
post-patch:
-.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1100000
@${ECHO_MSG} "===> Applying FairQ/Codel patches to ${PORTNAME}."
@${CAT} ${FILESDIR}/extra-patch-fairq_codel.diff | \
${PATCH} -d ${PATCH_WRKSRC} ${PATCH_ARGS}
-.endif
@${REINPLACE_CMD} -e 's|<sys/queue.h>|"${FILESDIR}/queue.h"|g' \
${WRKSRC}/engine.c
@${REINPLACE_CMD} -e 's|__dead|__dead2|g' ${WRKSRC}/sf-gencode.h
@${REINPLACE_CMD} -e 's|__dead|__dead2|g' ${WRKSRC}/sf-gencode.c
@${REINPLACE_CMD} -e 's|#include <net/if_pflog.h>||g' \
${WRKSRC}/sf-gencode.c
-.if ${OPSYS} == DragonFly || ${OSVERSION} >= 1100070
@${REINPLACE_CMD} -e 's|altq/|net/&|' ${WRKSRC}/pftop.c
-.endif
@${REINPLACE_CMD} -e 's|#include .pcap-int.h.|#include <pcap/pcap.h>|g' \
${WRKSRC}/bpf_image.c \
${WRKSRC}/bpf_optimize.c \
@@ -72,4 +64,4 @@ do-install:
${INSTALL_PROGRAM} ${WRKSRC}/pftop ${STAGEDIR}${PREFIX}/sbin
${INSTALL_MAN} ${WRKSRC}/pftop.8 ${STAGEDIR}${MANPREFIX}/man/man8
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>