aboutsummaryrefslogtreecommitdiff
path: root/sysutils/polkit-qt5
diff options
context:
space:
mode:
authorRaphael Kubo da Costa <rakuco@FreeBSD.org>2015-06-04 11:40:28 +0000
committerRaphael Kubo da Costa <rakuco@FreeBSD.org>2015-06-04 11:40:28 +0000
commite60a524f8765a6350bb531716fdd2baa15fafebd (patch)
treead38fc6316b4e0368511833be90ca8ac2739123b /sysutils/polkit-qt5
parent103d62fa7ae2daead25d97a45aa3419542e9f657 (diff)
downloadports-e60a524f8765a6350bb531716fdd2baa15fafebd.tar.gz
ports-e60a524f8765a6350bb531716fdd2baa15fafebd.zip
Add sysutils/polkit-qt5.
This is the Qt5 version of sysutils/polkit-qt. From pkg-descr: Polkit-Qt is a library that lets developers use the Polkit API through a nice Qt-styled API. It is mainly a wrapper around QAction and QAbstractButton that lets you integrate those two component easily with Polkit. Submitted by: Tobias Berner <tcberner@gmail.com> to the kde@ mailing list
Notes
Notes: svn path=/head/; revision=388527
Diffstat (limited to 'sysutils/polkit-qt5')
-rw-r--r--sysutils/polkit-qt5/Makefile31
-rw-r--r--sysutils/polkit-qt5/distinfo2
-rw-r--r--sysutils/polkit-qt5/pkg-descr6
-rw-r--r--sysutils/polkit-qt5/pkg-plist41
4 files changed, 80 insertions, 0 deletions
diff --git a/sysutils/polkit-qt5/Makefile b/sysutils/polkit-qt5/Makefile
new file mode 100644
index 000000000000..8edd72d9c704
--- /dev/null
+++ b/sysutils/polkit-qt5/Makefile
@@ -0,0 +1,31 @@
+# $FreeBSD$
+
+PORTNAME= polkit-qt5
+DISTNAME= polkit-qt-1-${PORTVERSION}
+PORTVERSION= 0.112.0
+CATEGORIES= sysutils
+MASTER_SITES= KDE/stable/apps/KDE4.x/admin/
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= Qt5 wrapper around Polkit libraries
+
+LICENSE= LGPL21
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+LIB_DEPENDS= libpolkit-agent-1.so:${PORTSDIR}/sysutils/polkit
+
+CMAKE_ARGS= -DBUILD_EXAMPLES:BOOL=OFF \
+ -DBUILD_TEST:BOOL=OFF \
+ -DUSE_QT4:BOOL=OFF \
+ -DUSE_QT5:BOOL=ON
+
+USE_GNOME= glib20
+USE_QT5= core dbus gui widgets buildtools_build qmake_build
+USES= cmake:outsource tar:bzip2
+USE_LDCONFIG= yes
+
+post-patch:
+ ${REINPLACE_CMD} -e 's|$${LIB_DESTINATION}/pkgconfig|libdata/pkgconfig|' \
+ ${WRKSRC}/CMakeLists.txt
+
+.include <bsd.port.mk>
diff --git a/sysutils/polkit-qt5/distinfo b/sysutils/polkit-qt5/distinfo
new file mode 100644
index 000000000000..77ec863cb4c9
--- /dev/null
+++ b/sysutils/polkit-qt5/distinfo
@@ -0,0 +1,2 @@
+SHA256 (polkit-qt-1-0.112.0.tar.bz2) = 67fb03bf6ca3e0bdbd98d374dfb5b1651a07d17ae6c23e11a81b4b084447e7c6
+SIZE (polkit-qt-1-0.112.0.tar.bz2) = 67725
diff --git a/sysutils/polkit-qt5/pkg-descr b/sysutils/polkit-qt5/pkg-descr
new file mode 100644
index 000000000000..8beea7a340b7
--- /dev/null
+++ b/sysutils/polkit-qt5/pkg-descr
@@ -0,0 +1,6 @@
+Polkit-Qt is a library that lets developers use the Polkit API through
+a nice Qt-styled API. It is mainly a wrapper around QAction and
+QAbstractButton that lets you integrate those two component easily
+with Polkit.
+
+WWW: http://projects.kde.org/projects/kdesupport/polkit-qt-1
diff --git a/sysutils/polkit-qt5/pkg-plist b/sysutils/polkit-qt5/pkg-plist
new file mode 100644
index 000000000000..2f4079a8c50f
--- /dev/null
+++ b/sysutils/polkit-qt5/pkg-plist
@@ -0,0 +1,41 @@
+include/polkit-qt5-1/PolkitQt1/ActionDescription
+include/polkit-qt5-1/PolkitQt1/Agent/Listener
+include/polkit-qt5-1/PolkitQt1/Agent/Session
+include/polkit-qt5-1/PolkitQt1/Authority
+include/polkit-qt5-1/PolkitQt1/Details
+include/polkit-qt5-1/PolkitQt1/Gui/Action
+include/polkit-qt5-1/PolkitQt1/Gui/ActionButton
+include/polkit-qt5-1/PolkitQt1/Gui/ActionButtons
+include/polkit-qt5-1/PolkitQt1/Identity
+include/polkit-qt5-1/PolkitQt1/Subject
+include/polkit-qt5-1/PolkitQt1/TemporaryAuthorization
+include/polkit-qt5-1/polkitqt1-actiondescription.h
+include/polkit-qt5-1/polkitqt1-agent-listener.h
+include/polkit-qt5-1/polkitqt1-agent-session.h
+include/polkit-qt5-1/polkitqt1-authority.h
+include/polkit-qt5-1/polkitqt1-details.h
+include/polkit-qt5-1/polkitqt1-export.h
+include/polkit-qt5-1/polkitqt1-gui-action.h
+include/polkit-qt5-1/polkitqt1-gui-actionbutton.h
+include/polkit-qt5-1/polkitqt1-gui-actionbuttons.h
+include/polkit-qt5-1/polkitqt1-identity.h
+include/polkit-qt5-1/polkitqt1-subject.h
+include/polkit-qt5-1/polkitqt1-temporaryauthorization.h
+include/polkit-qt5-1/polkitqt1-version.h
+lib/cmake/PolkitQt5-1/PolkitQt5-1Config.cmake
+lib/cmake/PolkitQt5-1/PolkitQt5-1ConfigVersion.cmake
+lib/cmake/PolkitQt5-1/PolkitQt5-1Targets-%%CMAKE_BUILD_TYPE%%.cmake
+lib/cmake/PolkitQt5-1/PolkitQt5-1Targets.cmake
+lib/libpolkit-qt5-agent-1.so
+lib/libpolkit-qt5-agent-1.so.1
+lib/libpolkit-qt5-agent-1.so.1.112.0
+lib/libpolkit-qt5-core-1.so
+lib/libpolkit-qt5-core-1.so.1
+lib/libpolkit-qt5-core-1.so.1.112.0
+lib/libpolkit-qt5-gui-1.so
+lib/libpolkit-qt5-gui-1.so.1
+lib/libpolkit-qt5-gui-1.so.1.112.0
+libdata/pkgconfig/polkit-qt5-1.pc
+libdata/pkgconfig/polkit-qt5-agent-1.pc
+libdata/pkgconfig/polkit-qt5-core-1.pc
+libdata/pkgconfig/polkit-qt5-gui-1.pc