aboutsummaryrefslogtreecommitdiff
path: root/sysutils/puppet-mode.el
diff options
context:
space:
mode:
authorDmitry Sivachenko <demon@FreeBSD.org>2013-11-20 08:38:37 +0000
committerDmitry Sivachenko <demon@FreeBSD.org>2013-11-20 08:38:37 +0000
commit7cf2c14bb1bba47216c4c1bcddbdde874a19c3e3 (patch)
tree9b2144e65290030ae52665e8676e59ebb5a7419b /sysutils/puppet-mode.el
parent511b66cd9fc8425b83dfcba44d502482774b2ab2 (diff)
downloadports-7cf2c14bb1bba47216c4c1bcddbdde874a19c3e3.tar.gz
ports-7cf2c14bb1bba47216c4c1bcddbdde874a19c3e3.zip
New port: puppet-mode.el: a major Emacs mode for editing puppet manifests.
Notes
Notes: svn path=/head/; revision=334400
Diffstat (limited to 'sysutils/puppet-mode.el')
-rw-r--r--sysutils/puppet-mode.el/Makefile28
-rw-r--r--sysutils/puppet-mode.el/distinfo2
-rw-r--r--sysutils/puppet-mode.el/pkg-descr8
-rw-r--r--sysutils/puppet-mode.el/pkg-message12
4 files changed, 50 insertions, 0 deletions
diff --git a/sysutils/puppet-mode.el/Makefile b/sysutils/puppet-mode.el/Makefile
new file mode 100644
index 000000000000..567f4c6f06c5
--- /dev/null
+++ b/sysutils/puppet-mode.el/Makefile
@@ -0,0 +1,28 @@
+# Created by: Dmitry Sivachenko <demon@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= puppet-mode.el
+PORTVERSION= 0.2
+CATEGORIES= sysutils elisp
+
+MAINTAINER= demon@FreeBSD.org
+COMMENT= Simple mode for editing puppet manifests
+
+USE_GITHUB= yes
+GH_PROJECT= puppet-syntax-emacs
+GH_ACCOUNT= puppetlabs
+GH_COMMIT= be5d708
+GH_TAGNAME= ${GH_COMMIT}
+
+NO_BUILD= yes
+USE_EMACS= yes
+
+PLIST_FILES= %%EMACS_SITE_LISPDIR%%/puppet-mode.el
+
+do-install:
+ ${INSTALL_DATA} ${WRKSRC}/puppet-mode.el ${STAGEDIR}${PREFIX}/${EMACS_SITE_LISPDIR}
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/sysutils/puppet-mode.el/distinfo b/sysutils/puppet-mode.el/distinfo
new file mode 100644
index 000000000000..59a5dcb66328
--- /dev/null
+++ b/sysutils/puppet-mode.el/distinfo
@@ -0,0 +1,2 @@
+SHA256 (puppet-mode.el-0.2.tar.gz) = 11e75ea76c7cbe774217044fa5071c46f7ddb133372725b9800c4f914b5ad86d
+SIZE (puppet-mode.el-0.2.tar.gz) = 8440
diff --git a/sysutils/puppet-mode.el/pkg-descr b/sysutils/puppet-mode.el/pkg-descr
new file mode 100644
index 000000000000..dd13086d5a2d
--- /dev/null
+++ b/sysutils/puppet-mode.el/pkg-descr
@@ -0,0 +1,8 @@
+ParEdit (paredit.el) is a minor Emacs mode for performing structured
+editing of S-expression data. The typical example of this would be
+Lisp, Scheme or Clojure source code.
+
+ParEdit helps keep parentheses balanced and adds many keys for
+moving S-expressions and moving around in S-expressions.
+
+WWW: http://www.emacswiki.org/emacs/ParEdit
diff --git a/sysutils/puppet-mode.el/pkg-message b/sysutils/puppet-mode.el/pkg-message
new file mode 100644
index 000000000000..50fedfb455a3
--- /dev/null
+++ b/sysutils/puppet-mode.el/pkg-message
@@ -0,0 +1,12 @@
+===================================================
+
+You should add the following line to your ~/.emacs:
+
+;;
+;; Setup puppet-mode for autoloading
+;;
+(autoload 'puppet-mode "puppet-mode" "Major mode for editing puppet manifests")
+
+(add-to-list 'auto-mode-alist '("\\.pp$" . puppet-mode))
+
+===================================================