aboutsummaryrefslogtreecommitdiff
path: root/sysutils/py-azure-cli-acr
diff options
context:
space:
mode:
authorDanilo G. Baio <dbaio@FreeBSD.org>2019-01-26 13:28:29 +0000
committerDanilo G. Baio <dbaio@FreeBSD.org>2019-01-26 13:28:29 +0000
commitcca9328bc1be518fc36a4955c04cd15cd4754414 (patch)
tree7d21ecc015d835632f8737f86e1f464949bfaa3e /sysutils/py-azure-cli-acr
parent4db9af1d348f8f6c1cc13905efca91758ee81e44 (diff)
downloadports-cca9328bc1be518fc36a4955c04cd15cd4754414.tar.gz
ports-cca9328bc1be518fc36a4955c04cd15cd4754414.zip
Add py-azure-cli: Microsoft Azure Command-Line Tools
It also adds all azure-cli libraries, modules and commands. The Azure CLI is a command-line tool providing a great experience for managing Azure resources. The CLI is designed to make scripting easy, query data, support long-running operations, and more. Try it today and find out what the CLI has to offer! WWW: https://pypi.org/project/azure-cli/ WWW: https://docs.microsoft.com/en-us/cli/azure/?view=azure-cli-latest
Notes
Notes: svn path=/head/; revision=491291
Diffstat (limited to 'sysutils/py-azure-cli-acr')
-rw-r--r--sysutils/py-azure-cli-acr/Makefile24
-rw-r--r--sysutils/py-azure-cli-acr/distinfo3
-rw-r--r--sysutils/py-azure-cli-acr/pkg-descr8
3 files changed, 35 insertions, 0 deletions
diff --git a/sysutils/py-azure-cli-acr/Makefile b/sysutils/py-azure-cli-acr/Makefile
new file mode 100644
index 000000000000..8a56f8d53990
--- /dev/null
+++ b/sysutils/py-azure-cli-acr/Makefile
@@ -0,0 +1,24 @@
+# $FreeBSD$
+
+PORTNAME= azure-cli-acr
+PORTVERSION= 2.1.11
+CATEGORIES= sysutils python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= dbaio@FreeBSD.org
+COMMENT= Microsoft Azure Command-Line Tools ACR Command Module
+
+LICENSE= MIT
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}azure-mgmt-storage>=3.1.0:devel/py-azure-mgmt-storage@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}azure-mgmt-containerregistry>=2.4.0:devel/py-azure-mgmt-containerregistry@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}azure-storage-blob>=1.3.1:devel/py-azure-storage-blob@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}azure-cli-core>=0:sysutils/py-azure-cli-core@${PY_FLAVOR}
+
+USES= azurepy python
+USE_PYTHON= autoplist concurrent distutils
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/sysutils/py-azure-cli-acr/distinfo b/sysutils/py-azure-cli-acr/distinfo
new file mode 100644
index 000000000000..c583c1a6628f
--- /dev/null
+++ b/sysutils/py-azure-cli-acr/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1546106940
+SHA256 (azure-cli-acr-2.1.11.tar.gz) = 0edef63b7c38b4c8941ea8197b7049b715e68156c4e31fab59b611a235c92f62
+SIZE (azure-cli-acr-2.1.11.tar.gz) = 48508
diff --git a/sysutils/py-azure-cli-acr/pkg-descr b/sysutils/py-azure-cli-acr/pkg-descr
new file mode 100644
index 000000000000..af9385524e85
--- /dev/null
+++ b/sysutils/py-azure-cli-acr/pkg-descr
@@ -0,0 +1,8 @@
+Microsoft Azure CLI 'acr' Command Module
+
+The Azure CLI is a command-line tool providing a great experience for managing
+Azure resources. The CLI is designed to make scripting easy, query data,
+support long-running operations, and more. Try it today and find out what the
+CLI has to offer!
+
+WWW: https://pypi.org/project/azure-cli-acr/