aboutsummaryrefslogtreecommitdiff
path: root/sysutils/py-azure-cli-core
diff options
context:
space:
mode:
authorDanilo G. Baio <dbaio@FreeBSD.org>2019-01-26 13:28:29 +0000
committerDanilo G. Baio <dbaio@FreeBSD.org>2019-01-26 13:28:29 +0000
commitcca9328bc1be518fc36a4955c04cd15cd4754414 (patch)
tree7d21ecc015d835632f8737f86e1f464949bfaa3e /sysutils/py-azure-cli-core
parent4db9af1d348f8f6c1cc13905efca91758ee81e44 (diff)
downloadports-cca9328bc1be518fc36a4955c04cd15cd4754414.tar.gz
ports-cca9328bc1be518fc36a4955c04cd15cd4754414.zip
Add py-azure-cli: Microsoft Azure Command-Line Tools
It also adds all azure-cli libraries, modules and commands. The Azure CLI is a command-line tool providing a great experience for managing Azure resources. The CLI is designed to make scripting easy, query data, support long-running operations, and more. Try it today and find out what the CLI has to offer! WWW: https://pypi.org/project/azure-cli/ WWW: https://docs.microsoft.com/en-us/cli/azure/?view=azure-cli-latest
Notes
Notes: svn path=/head/; revision=491291
Diffstat (limited to 'sysutils/py-azure-cli-core')
-rw-r--r--sysutils/py-azure-cli-core/Makefile49
-rw-r--r--sysutils/py-azure-cli-core/distinfo3
-rw-r--r--sysutils/py-azure-cli-core/pkg-descr6
3 files changed, 58 insertions, 0 deletions
diff --git a/sysutils/py-azure-cli-core/Makefile b/sysutils/py-azure-cli-core/Makefile
new file mode 100644
index 000000000000..8434a53fdadd
--- /dev/null
+++ b/sysutils/py-azure-cli-core/Makefile
@@ -0,0 +1,49 @@
+# $FreeBSD$
+
+PORTNAME= azure-cli-core
+PORTVERSION= 2.0.54
+CATEGORIES= sysutils python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= dbaio@FreeBSD.org
+COMMENT= Microsoft Azure Command-Line Tools Core Module
+
+LICENSE= MIT
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}adal>=1.2.0:net-mgmt/py-adal@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}argcomplete>=1.8.0:devel/py-argcomplete@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}azure-cli-telemetry>=0:sysutils/py-azure-cli-telemetry@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}colorama>=0.3.9:devel/py-colorama@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}humanfriendly>=4.7:textproc/py-humanfriendly@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}jmespath>=0:devel/py-jmespath@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}knack>=0.5.1:devel/py-knack@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}msrest>=0.4.4:net-mgmt/py-msrest@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}msrestazure>=0.4.25:net-mgmt/py-msrestazure@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}paramiko>=2.0.8:security/py-paramiko@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pip>=0:devel/py-pip@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pygments>=0:textproc/py-pygments@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pyjwt>=0:www/py-pyjwt@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}openssl>=17.1.0:security/py-openssl@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}yaml>=3.13:devel/py-yaml@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}requests>=2.18.4:www/py-requests@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}six>=0:devel/py-six@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}tabulate>=0.7.7:devel/py-tabulate@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}wheel>=0.30.0:devel/py-wheel@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}azure-mgmt-resource>=2.0.0:devel/py-azure-mgmt-resource@${PY_FLAVOR} \
+ ${PY_ENUM34}
+
+USES= azurepy python
+USE_PYTHON= autoplist concurrent distutils
+
+NO_ARCH= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${PYTHON_REL} < 3400
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}antlr4-python2-runtime>=0:devel/py-antlr4-python2-runtime@${PY_FLAVOR}
+.else
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}antlr4-python3-runtime>=0:devel/py-antlr4-python3-runtime@${PY_FLAVOR}
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/sysutils/py-azure-cli-core/distinfo b/sysutils/py-azure-cli-core/distinfo
new file mode 100644
index 000000000000..6324ef843ed4
--- /dev/null
+++ b/sysutils/py-azure-cli-core/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1545592271
+SHA256 (azure-cli-core-2.0.54.tar.gz) = bc09f672f5c349644c9edf99bef8fb415ee9b40c4b556aee41a1f25601d69de6
+SIZE (azure-cli-core-2.0.54.tar.gz) = 94461
diff --git a/sysutils/py-azure-cli-core/pkg-descr b/sysutils/py-azure-cli-core/pkg-descr
new file mode 100644
index 000000000000..afd5cf58c66a
--- /dev/null
+++ b/sysutils/py-azure-cli-core/pkg-descr
@@ -0,0 +1,6 @@
+The Azure CLI is a command-line tool providing a great experience for managing
+Azure resources. The CLI is designed to make scripting easy, query data,
+support long-running operations, and more. Try it today and find out what the
+CLI has to offer!
+
+WWW: https://pypi.org/project/azure-cli-core/