aboutsummaryrefslogtreecommitdiff
path: root/sysutils/qdirstat/Makefile
diff options
context:
space:
mode:
authorRaphael Kubo da Costa <rakuco@FreeBSD.org>2018-01-08 21:28:11 +0000
committerRaphael Kubo da Costa <rakuco@FreeBSD.org>2018-01-08 21:28:11 +0000
commit917eef13eab2dde6df4f0b381e432145eacc4446 (patch)
tree8715fc58e058021148bdb0bb2a6ac3ae05a3384d /sysutils/qdirstat/Makefile
parent57eb3deeef85cbc127b7c4bad3326841ba9a6253 (diff)
downloadports-917eef13eab2dde6df4f0b381e432145eacc4446.tar.gz
ports-917eef13eab2dde6df4f0b381e432145eacc4446.zip
New port: sysutils/qdirstat
QDirStat is a graphical application to show where your disk space has gone and to help you to clean it up. Similar KDirStat without KDE dependency, and from the original KDirStat author WWW: https://github.com/shundhammer/qdirstat PR: 224987 Submitted by: kbowling
Notes
Notes: svn path=/head/; revision=458481
Diffstat (limited to 'sysutils/qdirstat/Makefile')
-rw-r--r--sysutils/qdirstat/Makefile37
1 files changed, 37 insertions, 0 deletions
diff --git a/sysutils/qdirstat/Makefile b/sysutils/qdirstat/Makefile
new file mode 100644
index 000000000000..e216dba07628
--- /dev/null
+++ b/sysutils/qdirstat/Makefile
@@ -0,0 +1,37 @@
+# Created by: Kevin Bowling <kbowling@freebsd.org>
+# $FreeBSD$
+
+PORTNAME= qdirstat
+PORTVERSION= 1.4
+CATEGORIES= sysutils
+
+MAINTAINER= kbowling@FreeBSD.org
+COMMENT= Qt utility that sums up disk usage for directory trees
+
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USE_GITHUB= yes
+GH_ACCOUNT= shundhammer
+
+USES= desktop-file-utils qmake shebangfix
+USE_GL= gl
+USE_QT5= buildtools_build core gui widgets
+SHEBANG_FILES= scripts/qdirstat-cache-writer
+
+pre-configure:
+ ${REINPLACE_CMD} -e 's,/usr/,${PREFIX}/,g' \
+ ${WRKSRC}/doc/doc.pro
+ ${REINPLACE_CMD} -e 's,/usr/,${PREFIX}/,g' \
+ ${WRKSRC}/doc/stats/stats.pro
+ ${REINPLACE_CMD} -e 's,/usr/,${PREFIX}/,g' \
+ ${WRKSRC}/scripts/scripts.pro
+ ${REINPLACE_CMD} -e 's,/bin/true,${TRUE},g' \
+ ${WRKSRC}/scripts/scripts.pro
+ ${REINPLACE_CMD} -e 's,/usr/,${PREFIX}/,g' \
+ ${WRKSRC}/src/src.pro
+
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/qdirstat
+
+.include <bsd.port.mk>