aboutsummaryrefslogtreecommitdiff
path: root/sysutils/quickjail
diff options
context:
space:
mode:
authorKyle Evans <kevans@FreeBSD.org>2020-07-29 05:17:07 +0000
committerKyle Evans <kevans@FreeBSD.org>2020-07-29 05:17:07 +0000
commitf52702d06116ae848ccf012e33a2e6d5448a39c0 (patch)
tree14bbfc36421a7fa616dc1686506c7d1f893e4335 /sysutils/quickjail
parent756fe84652321ed57c51cb4ef397524a83c010a0 (diff)
downloadports-f52702d06116ae848ccf012e33a2e6d5448a39c0.tar.gz
ports-f52702d06116ae848ccf012e33a2e6d5448a39c0.zip
[NEW] sysutils/quickjail: Utility to create transient single-command jails
Quickjail is a utility to create transient single-command jails. This utility operates much like jail(8) -c, but the jails it creates are not persistent, unlike with jail(8). This makes quickjail more convenient for cases where the command may need termination, which may prevent jail(8) from cleaning up the jail. WWW: https://git.kevans.dev/kevans/quickjail Reviewed by: koobs (earlier version) Differential Revision: https://reviews.freebsd.org/D24792
Notes
Notes: svn path=/head/; revision=543644
Diffstat (limited to 'sysutils/quickjail')
-rw-r--r--sysutils/quickjail/Makefile23
-rw-r--r--sysutils/quickjail/distinfo3
-rw-r--r--sysutils/quickjail/pkg-descr8
3 files changed, 34 insertions, 0 deletions
diff --git a/sysutils/quickjail/Makefile b/sysutils/quickjail/Makefile
new file mode 100644
index 000000000000..0a78389aea37
--- /dev/null
+++ b/sysutils/quickjail/Makefile
@@ -0,0 +1,23 @@
+# $FreeBSD$
+
+PORTNAME= quickjail
+PORTVERSION= 0.1.2
+CATEGORIES= sysutils
+MASTER_SITES= https://git.kevans.dev/kevans/${PORTNAME}/archive/${PORTVERSION}.tar.gz?dummy=/
+
+MAINTAINER= kevans@FreeBSD.org
+COMMENT= Utility to quickly create transient single-command jails
+
+LICENSE= BSD2CLAUSE
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+PLIST_FILES= bin/${PORTNAME} share/man/man1/${PORTNAME}.1.gz
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1.gz \
+ ${STAGEDIR}${MAN1PREFIX}/share/man/man1
+
+.include <bsd.port.mk>
diff --git a/sysutils/quickjail/distinfo b/sysutils/quickjail/distinfo
new file mode 100644
index 000000000000..6f2d4d42197f
--- /dev/null
+++ b/sysutils/quickjail/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1595998385
+SHA256 (quickjail-0.1.2.tar.gz) = 60435a3642dfd5c5d7597149a3fef827dae11ea6487a01d0eca4cb0dbfdfb32f
+SIZE (quickjail-0.1.2.tar.gz) = 3815
diff --git a/sysutils/quickjail/pkg-descr b/sysutils/quickjail/pkg-descr
new file mode 100644
index 000000000000..755f8a582d84
--- /dev/null
+++ b/sysutils/quickjail/pkg-descr
@@ -0,0 +1,8 @@
+Quickjail is a utility to create transient single-command jails.
+
+This utility operates much like jail(8) -c, but the jails it creates are not
+persistent, unlike with jail(8). This makes quickjail more convenient for
+cases where the command may need termination, which may prevent jail(8) from
+cleaning up the jail.
+
+WWW: https://git.kevans.dev/kevans/quickjail