aboutsummaryrefslogtreecommitdiff
path: root/sysutils/quicksynergy
diff options
context:
space:
mode:
authorRobert Noland <rnoland@FreeBSD.org>2008-12-22 00:54:39 +0000
committerRobert Noland <rnoland@FreeBSD.org>2008-12-22 00:54:39 +0000
commit018f9364029415181a51d88a153accb3fdc2315e (patch)
treee7815b4dad18cbae7a2dddfe487125924153c46b /sysutils/quicksynergy
parentabfbd47ae621c792903708cc4305bf32602c6913 (diff)
downloadports-018f9364029415181a51d88a153accb3fdc2315e.tar.gz
ports-018f9364029415181a51d88a153accb3fdc2315e.zip
- Update to 0.8.1
- Fix build - Take maintainership PR: 129773 Approved by: garga (mentor)
Notes
Notes: svn path=/head/; revision=224546
Diffstat (limited to 'sysutils/quicksynergy')
-rw-r--r--sysutils/quicksynergy/Makefile21
-rw-r--r--sysutils/quicksynergy/distinfo6
-rw-r--r--sysutils/quicksynergy/files/patch-src-callbacks.c15
-rw-r--r--sysutils/quicksynergy/files/patch-src-main.c11
4 files changed, 39 insertions, 14 deletions
diff --git a/sysutils/quicksynergy/Makefile b/sysutils/quicksynergy/Makefile
index 7afdc256947f..2ee400e052cd 100644
--- a/sysutils/quicksynergy/Makefile
+++ b/sysutils/quicksynergy/Makefile
@@ -6,26 +6,25 @@
#
PORTNAME= quicksynergy
-PORTVERSION= 0.7
-PORTREVISION= 1
+PORTVERSION= 0.8.1
+#PORTREVISION= 1
CATEGORIES= sysutils
MASTER_SITES= SF
-MAINTAINER= lme@FreeBSD.org
+MAINTAINER= rnoland@FreeBSD.org
COMMENT= A graphical interface for easily configuring Synergy2
BUILD_DEPENDS= synergys:${PORTSDIR}/sysutils/synergy
GNU_CONFIGURE= yes
-USE_GNOME= gtk20 libglade
+USE_ICONV= yes
+USE_GETTEXT= yes
+USE_GNOME= gnomehack gnomeprefix libglade2
-BROKEN= does not build
-DEPRECATED= has been broken for more than 6 months
-EXPIRATION_DATE=2009-01-19
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
-PLIST_FILES= bin/quicksynergy
-
-pre-configure:
- @${REINPLACE_CMD} 's|ac_default_prefix=/usr/local|ac_default_prefix=${PREFIX}|' ${WRKSRC}/configure
+PLIST_FILES= bin/quicksynergy \
+ share/locale/pt_BR/LC_MESSAGES/quicksynergy.mo
.include <bsd.port.mk>
diff --git a/sysutils/quicksynergy/distinfo b/sysutils/quicksynergy/distinfo
index de1cd7f3532c..e5ae5ca8d8c1 100644
--- a/sysutils/quicksynergy/distinfo
+++ b/sysutils/quicksynergy/distinfo
@@ -1,3 +1,3 @@
-MD5 (quicksynergy-0.7.tar.gz) = e44ef082db09124c01e3bdb92d970b8e
-SHA256 (quicksynergy-0.7.tar.gz) = b5612abec7a65a8236efbe8b34afa8b4ad82d881dacea19a962cdd298f9f6733
-SIZE (quicksynergy-0.7.tar.gz) = 175522
+MD5 (quicksynergy-0.8.1.tar.gz) = 2f8b915dfcce7134eb10444217fb6d8d
+SHA256 (quicksynergy-0.8.1.tar.gz) = 1590c351994f463d0900b9df704429f963f26523e41e740faed06f8eed3284bc
+SIZE (quicksynergy-0.8.1.tar.gz) = 176978
diff --git a/sysutils/quicksynergy/files/patch-src-callbacks.c b/sysutils/quicksynergy/files/patch-src-callbacks.c
new file mode 100644
index 000000000000..a24af6b1a06a
--- /dev/null
+++ b/sysutils/quicksynergy/files/patch-src-callbacks.c
@@ -0,0 +1,15 @@
+--- src/callbacks.c.orig 2008-07-28 17:56:10.000000000 -0400
++++ src/callbacks.c 2008-12-19 18:34:57.000000000 -0500
+@@ -43,9 +43,9 @@
+ "</popup>"
+ "</ui>\n";
+
+-static GtkActionEntry popup_menu_actions[] = {
+- { "ActionSettings", GTK_STOCK_PREFERENCES, N_("Settings"), NULL, NULL, show_main_window },
+- { "ActionQuit", GTK_STOCK_QUIT, N_("Quit"), NULL, NULL, quicksynergy_quit },
++static const GtkActionEntry popup_menu_actions[] = {
++ { "ActionSettings", GTK_STOCK_PREFERENCES, N_("Settings"), NULL, NULL, G_CALLBACK(show_main_window) },
++ { "ActionQuit", GTK_STOCK_QUIT, N_("Quit"), NULL, NULL, G_CALLBACK(quicksynergy_quit) },
+ };
+ #endif
+
diff --git a/sysutils/quicksynergy/files/patch-src-main.c b/sysutils/quicksynergy/files/patch-src-main.c
new file mode 100644
index 000000000000..e7421d8cf637
--- /dev/null
+++ b/sysutils/quicksynergy/files/patch-src-main.c
@@ -0,0 +1,11 @@
+--- src/main.c.orig 2008-12-19 17:40:19.000000000 -0500
++++ src/main.c 2008-12-19 17:49:51.000000000 -0500
+@@ -84,7 +84,7 @@
+ GTK_WIN_POS_CENTER);
+ gtk_window_set_resizable(GTK_WINDOW(main_window), FALSE);
+ gtk_container_set_border_width(GTK_CONTAINER(main_window), 5);
+- gtk_window_set_icon(main_window,gdk_pixbuf_new_from_inline(-1, qslogo,
++ gtk_window_set_icon(GTK_WINDOW(main_window),gdk_pixbuf_new_from_inline(-1, qslogo,
+ FALSE, NULL));
+
+ /* main window events */