aboutsummaryrefslogtreecommitdiff
path: root/sysutils/restic
diff options
context:
space:
mode:
authorJoseph Mingrone <jrm@FreeBSD.org>2018-01-03 19:01:31 +0000
committerJoseph Mingrone <jrm@FreeBSD.org>2018-01-03 19:01:31 +0000
commit573cd232161d522d73c064f1cae1741c26739f4a (patch)
tree5cc773f0a3dab3c3045690d397a054968a76ec09 /sysutils/restic
parent52777f3f56651efd9ec05aede511d07d7da337b5 (diff)
downloadports-573cd232161d522d73c064f1cae1741c26739f4a.tar.gz
ports-573cd232161d522d73c064f1cae1741c26739f4a.zip
sysutils/restic: Update to 0.8.1, add options, new maintainer
- Install man pages - Add options for bash and zsh completions Upstream changes: https://github.com/restic/restic/releases PR: 224806 Submitted by: gregf@hugops.pw (new maintainer) Approved by: wg@FreeBSD.org (old maintainer) Differential Revision: https://reviews.freebsd.org/D13722
Notes
Notes: svn path=/head/; revision=457999
Diffstat (limited to 'sysutils/restic')
-rw-r--r--sysutils/restic/Makefile32
-rw-r--r--sysutils/restic/distinfo6
-rw-r--r--sysutils/restic/files/patch-src_cmds_restic_cmd__autocomplete.go11
-rw-r--r--sysutils/restic/pkg-plist25
4 files changed, 49 insertions, 25 deletions
diff --git a/sysutils/restic/Makefile b/sysutils/restic/Makefile
index c1577a78d265..e3fb295c5e68 100644
--- a/sysutils/restic/Makefile
+++ b/sysutils/restic/Makefile
@@ -1,28 +1,38 @@
# $FreeBSD$
PORTNAME= restic
-PORTVERSION= 0.7.1
DISTVERSIONPREFIX= v
-PORTREVISION= 1
+DISTVERSION= 0.8.1
CATEGORIES= sysutils
-MAINTAINER= wg@FreeBSD.org
-COMMENT= Restic backup program
+MAINTAINER= gregf@hugops.pw
+COMMENT= Fast, secure, efficient backup program
LICENSE= BSD2CLAUSE
USES= go
USE_GITHUB= yes
-PLIST_FILES= bin/restic
+GO_PKGNAME= github.com/${GH_ACCOUNT}/${PORTNAME}
+GO_TARGET= ${GO_PKGNAME}/cmd/${PORTNAME}
-post-patch:
- @${REINPLACE_CMD} -e "s@%%PREFIX%%@${PREFIX}@g" ${WRKSRC}/src/cmds/restic/cmd_autocomplete.go
+OPTIONS_SUB= yes
+PLIST_SUB= PORTNAME=${PORTNAME}
-do-build:
- @(cd ${GO_WRKSRC}; ${SETENV} ${MAKE_ENV} ${GO_ENV} ${GO_CMD} run build.go)
+OPTIONS_DEFINE= BASH ZSH
+OPTIONS_DEFAULT= BASH ZSH
-do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
+post-install:
+ ${INSTALL_MAN} ${WRKSRC}/doc/man/* ${STAGEDIR}${MANPREFIX}/man/man1
+
+post-install-BASH-on:
+ ${INSTALL} -d ${STAGEDIR}${PREFIX}/etc/bash_completion.d/
+ ${INSTALL_SCRIPT} ${WRKSRC}/doc/bash-completion.sh \
+ ${STAGEDIR}${PREFIX}/etc/bash_completion.d/${PORTNAME}.sh
+
+post-install-ZSH-on:
+ ${INSTALL} -d ${STAGEDIR}${PREFIX}/share/zsh/site-functions/
+ ${INSTALL_DATA} ${WRKSRC}/doc/zsh-completion.zsh \
+ ${STAGEDIR}${PREFIX}/share/zsh/site-functions/_${PORTNAME}
.include <bsd.port.mk>
diff --git a/sysutils/restic/distinfo b/sysutils/restic/distinfo
index a35cc7677180..133e5018c701 100644
--- a/sysutils/restic/distinfo
+++ b/sysutils/restic/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1500737632
-SHA256 (restic-restic-v0.7.1_GH0.tar.gz) = 81efde662c34225b5705f3d72daa1f6278455c2b8f786224d7a1ecca0b14efca
-SIZE (restic-restic-v0.7.1_GH0.tar.gz) = 25438170
+TIMESTAMP = 1514775412
+SHA256 (restic-restic-v0.8.1_GH0.tar.gz) = 1e0e0d1e7388beaa2a892c057759fdfe6a4fe915f9518c73068761f8d6d7619d
+SIZE (restic-restic-v0.8.1_GH0.tar.gz) = 40330154
diff --git a/sysutils/restic/files/patch-src_cmds_restic_cmd__autocomplete.go b/sysutils/restic/files/patch-src_cmds_restic_cmd__autocomplete.go
deleted file mode 100644
index 26bac8725559..000000000000
--- a/sysutils/restic/files/patch-src_cmds_restic_cmd__autocomplete.go
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/cmds/restic/cmd_autocomplete.go.orig 2017-07-27 13:03:30 UTC
-+++ src/cmds/restic/cmd_autocomplete.go
-@@ -30,7 +30,7 @@ $ sudo restic autocomplete`,
- func init() {
- cmdRoot.AddCommand(cmdAutocomplete)
-
-- cmdAutocomplete.Flags().StringVarP(&autocompleteTarget, "completionfile", "", "/etc/bash_completion.d/restic.sh", "autocompletion file")
-+ cmdAutocomplete.Flags().StringVarP(&autocompleteTarget, "completionfile", "", "%%PREFIX%%/etc/bash_completion.d/restic.sh", "autocompletion file")
- // For bash-completion
- cmdAutocomplete.Flags().SetAnnotation("completionfile", cobra.BashCompFilenameExt, []string{})
- }
diff --git a/sysutils/restic/pkg-plist b/sysutils/restic/pkg-plist
new file mode 100644
index 000000000000..f893cf340412
--- /dev/null
+++ b/sysutils/restic/pkg-plist
@@ -0,0 +1,25 @@
+bin/restic
+%%BASH%%etc/bash_completion.d/%%PORTNAME%%.sh
+%%ZSH%%share/zsh/site-functions/_%%PORTNAME%%
+man/man1/%%PORTNAME%%-backup.1.gz
+man/man1/%%PORTNAME%%-cat.1.gz
+man/man1/%%PORTNAME%%-check.1.gz
+man/man1/%%PORTNAME%%-diff.1.gz
+man/man1/%%PORTNAME%%-dump.1.gz
+man/man1/%%PORTNAME%%-find.1.gz
+man/man1/%%PORTNAME%%-forget.1.gz
+man/man1/%%PORTNAME%%-generate.1.gz
+man/man1/%%PORTNAME%%-init.1.gz
+man/man1/%%PORTNAME%%-key.1.gz
+man/man1/%%PORTNAME%%-list.1.gz
+man/man1/%%PORTNAME%%-ls.1.gz
+man/man1/%%PORTNAME%%-migrate.1.gz
+man/man1/%%PORTNAME%%-mount.1.gz
+man/man1/%%PORTNAME%%-prune.1.gz
+man/man1/%%PORTNAME%%-rebuild-index.1.gz
+man/man1/%%PORTNAME%%-restore.1.gz
+man/man1/%%PORTNAME%%-snapshots.1.gz
+man/man1/%%PORTNAME%%-tag.1.gz
+man/man1/%%PORTNAME%%-unlock.1.gz
+man/man1/%%PORTNAME%%-version.1.gz
+man/man1/%%PORTNAME%%.1.gz