aboutsummaryrefslogtreecommitdiff
path: root/sysutils/rtty
diff options
context:
space:
mode:
authorSteve Price <steve@FreeBSD.org>2000-01-24 05:56:00 +0000
committerSteve Price <steve@FreeBSD.org>2000-01-24 05:56:00 +0000
commit722512b0c3f5b51cec0e825b52cb8884f75fb415 (patch)
tree0c85e9bbd081a018291c25ddd311c6f022cb6331 /sysutils/rtty
parent46641840662335b088d487c22eb9a763dd79141d (diff)
downloadports-722512b0c3f5b51cec0e825b52cb8884f75fb415.tar.gz
ports-722512b0c3f5b51cec0e825b52cb8884f75fb415.zip
- Support CC/CFLAGS/PREFIX properly
- Strip binary file - Fix pkg/PLIST PR: 16283 Submitted by: KATO Tsuguru <tkato@prontomail.ne.jp>
Notes
Notes: svn path=/head/; revision=25013
Diffstat (limited to 'sysutils/rtty')
-rw-r--r--sysutils/rtty/Makefile16
-rw-r--r--sysutils/rtty/files/patch-aa32
-rw-r--r--sysutils/rtty/pkg-plist25
3 files changed, 53 insertions, 20 deletions
diff --git a/sysutils/rtty/Makefile b/sysutils/rtty/Makefile
index 28efe10cbba1..32bcc3a7375a 100644
--- a/sysutils/rtty/Makefile
+++ b/sysutils/rtty/Makefile
@@ -1,17 +1,19 @@
-# New ports collection makefile for: rtty
-# Version required: 3.2
-# Date created: 24 Aug 1996
-# Whom: jkh
+# New ports collection makefile for: rtty
+# Version required: 3.2
+# Date created: 24 Aug 1996
+# Whom: jkh
#
# Author: Paul Vixie / Internet Software Consortium
#
# $FreeBSD$
#
-DISTNAME= rtty-3.2
+DISTNAME= rtty-3.2
CATEGORIES= sysutils
-MASTER_SITES= ftp://ftp.vix.com/pub/vixie/
+MASTER_SITES= ftp://ftp.vix.com/pub/vixie/
-NO_WRKSUBDIR= yes
+MAINTAINER= ports@FreeBSD.org
+
+NO_WRKSUBDIR= yes
.include <bsd.port.mk>
diff --git a/sysutils/rtty/files/patch-aa b/sysutils/rtty/files/patch-aa
index 79fd83320fcf..6fbb161fcf3b 100644
--- a/sysutils/rtty/files/patch-aa
+++ b/sysutils/rtty/files/patch-aa
@@ -1,13 +1,39 @@
---- Makefile.orig Fri Aug 23 16:46:42 1996
-+++ Makefile Sat Aug 24 02:14:12 1996
+--- Makefile.orig Sat Aug 24 08:46:42 1996
++++ Makefile Fri Jan 21 23:09:45 2000
+@@ -19,12 +19,12 @@
+
+ VPATH = ../src
+
+-DESTROOT =
+-DESTPATH = $(DESTROOT)/usr/local/rtty
++DESTROOT = ${PREFIX}
++DESTPATH = $(DESTROOT)/rtty
+ DESTBIN = $(DESTPATH)/bin
+
+-CC = cc
+-CDEBUG = -O -g
++CC ?= cc
++#CDEBUG = -O -g
+ #
+ # use -U to undefine, -D to define
+ # DEBUG include code to help debug this software
@@ -38,8 +38,8 @@
CDEFS = -DDEBUG -UWANT_TCPIP -UNEED_BITYPES_H -UNEED_STRDUP -UNEED_INET_ATON \
-UNO_SOCKADDR_LEN -UNO_HSTRERROR
#
-CFLAGS = $(CDEBUG) $(CDEFS) -I/usr/local/include
-LIBS =
-+CFLAGS = $(CDEBUG) $(CDEFS)
++CFLAGS += $(CDEBUG) $(CDEFS)
+LIBS = -lcrypt
#(if WANT_TCPIP defined and this isn't in your libc)
# -lresolv
#(if the resolver needs it, which BIND>=4.9's will on BSD>=4.4 systems)
+@@ -63,7 +63,7 @@
+ test -d $(DESTPATH)/$$x || mkdir $(DESTPATH)/$$x; \
+ done
+ set -x; for x in $(BINARY); do \
+- install -c -m 111 $$x $(DESTBIN)/$$x; \
++ install -c -s -m 111 $$x $(DESTBIN)/$$x; \
+ done
+ set -x; for x in $(SCRIPT); do \
+ install -c -m 555 $$x $(DESTBIN)/$$x; \
diff --git a/sysutils/rtty/pkg-plist b/sysutils/rtty/pkg-plist
index 5643dbde8bb5..c02e5e5608a4 100644
--- a/sysutils/rtty/pkg-plist
+++ b/sysutils/rtty/pkg-plist
@@ -1,15 +1,20 @@
-rtty/bin/ttysrv
-rtty/bin/rtty
-rtty/bin/locbrok
rtty/bin/Startup
+rtty/bin/agelog
+rtty/bin/agelogs
rtty/bin/console
+rtty/bin/locbrok
+rtty/bin/rtty
rtty/bin/startsrv
-rtty/bin/agelogs
-rtty/bin/agelog
+rtty/bin/ttysrv
+@exec mkdir -p %D/rtty/dev
+@exec mkdir -p %D/rtty/log
+@exec mkdir -p %D/rtty/opt
+@exec mkdir -p %D/rtty/pid
+@exec mkdir -p %D/rtty/sock
+@unexec rmdir %D/rtty/sock 2>/dev/null || true
+@unexec rmdir %D/rtty/pid 2>/dev/null || true
+@unexec rmdir %D/rtty/opt 2>/dev/null || true
+@unexec rmdir %D/rtty/log 2>/dev/null || true
+@unexec rmdir %D/rtty/dev 2>/dev/null || true
@dirrm rtty/bin
-@dirrm rtty/dev
-@dirrm rtty/log
-@dirrm rtty/opt
-@dirrm rtty/pid
-@dirrm rtty/sock
@dirrm rtty