aboutsummaryrefslogtreecommitdiff
path: root/sysutils/scterc
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2014-01-31 19:48:26 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2014-01-31 19:48:26 +0000
commit385e0d496af4f645f350ed0f51b51a40206fc347 (patch)
tree098187e22055483d944a1110f614f8cfff2a8e48 /sysutils/scterc
parenta92d3f339fd24eb807fe0a1c0c93b2834dc0c36f (diff)
downloadports-385e0d496af4f645f350ed0f51b51a40206fc347.tar.gz
ports-385e0d496af4f645f350ed0f51b51a40206fc347.zip
Modern hard drives allow to set the amount of time a hard disk is
allowed to spend recovering from a read or write error. This feature is called ERC (error recovery control, usually in Seagate), TLER (time-limited error recovery, usually on Western Digital) or CCLT (command completion time limit, usually on Samsung or Hitachi). This rc.d script allows to set these valus on system startup to tune disks for RAID usage. WWW: https://github.com/AMDmi3/scterc-rc.d
Notes
Notes: svn path=/head/; revision=342057
Diffstat (limited to 'sysutils/scterc')
-rw-r--r--sysutils/scterc/Makefile34
-rw-r--r--sysutils/scterc/distinfo2
-rw-r--r--sysutils/scterc/files/pkg-message.in15
-rw-r--r--sysutils/scterc/pkg-descr10
4 files changed, 61 insertions, 0 deletions
diff --git a/sysutils/scterc/Makefile b/sysutils/scterc/Makefile
new file mode 100644
index 000000000000..58c291cdda9c
--- /dev/null
+++ b/sysutils/scterc/Makefile
@@ -0,0 +1,34 @@
+# Created by: Dmitry Marakasov <amdmi3@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= scterc
+PORTVERSION= 0.0.1
+CATEGORIES= sysutils
+
+MAINTAINER= amdmi3@FreeBSD.org
+COMMENT= Configure SCT ERC for hard disks on system startup
+
+RUN_DEPENDS= ${LOCALBASE}/sbin/smartctl:${PORTSDIR}/sysutils/smartmontools
+
+USE_GITHUB= yes
+GH_ACCOUNT= AMDmi3
+GH_PROJECT= ${PORTNAME}-rc.d
+GH_COMMIT= c8dc8c1
+
+NO_BUILD= yes
+SUB_FILES= pkg-message
+
+PLIST_FILES= etc/rc.d/scterc
+PORTDOCS= *
+
+OPTIONS_DEFINE= DOCS
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|' ${WRKSRC}/scterc.sh
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/scterc.sh ${STAGEDIR}${PREFIX}/etc/rc.d/scterc
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README.md ${STAGEDIR}${DOCSDIR}/
+
+.include <bsd.port.mk>
diff --git a/sysutils/scterc/distinfo b/sysutils/scterc/distinfo
new file mode 100644
index 000000000000..7edb9cd15596
--- /dev/null
+++ b/sysutils/scterc/distinfo
@@ -0,0 +1,2 @@
+SHA256 (scterc-0.0.1.tar.gz) = 14edaef5e3ab554f86f0284e771fa1347c9fb7e24c820a84459a4bf78890c9ef
+SIZE (scterc-0.0.1.tar.gz) = 3145
diff --git a/sysutils/scterc/files/pkg-message.in b/sysutils/scterc/files/pkg-message.in
new file mode 100644
index 000000000000..ae193fab9319
--- /dev/null
+++ b/sysutils/scterc/files/pkg-message.in
@@ -0,0 +1,15 @@
+To enable setting hard disk SCT ERC on system boot time, add the
+following to your /etc/rc.conf:
+
+ scterc_enable="YES"
+
+ # specify hard disks to configure
+ scterc_disks="ada0 ada1"
+
+ # specify read and write timeouts in tenths of second
+ # here each is set to 7.0 seconds, which is also the default
+ # for which you may omit these lines
+ scterc_read_timeout="70"
+ scterc_write_timeout="70"
+
+See %%DOCSDIR%%/README.md for more info.
diff --git a/sysutils/scterc/pkg-descr b/sysutils/scterc/pkg-descr
new file mode 100644
index 000000000000..b3927bc29a90
--- /dev/null
+++ b/sysutils/scterc/pkg-descr
@@ -0,0 +1,10 @@
+Modern hard drives allow to set the amount of time a hard disk is
+allowed to spend recovering from a read or write error. This feature
+is called ERC (error recovery control, usually in Seagate), TLER
+(time-limited error recovery, usually on Western Digital) or CCLT
+(command completion time limit, usually on Samsung or Hitachi).
+
+This rc.d script allows to set these valus on system startup to
+tune disks for RAID usage.
+
+WWW: https://github.com/AMDmi3/scterc-rc.d