aboutsummaryrefslogtreecommitdiff
path: root/sysutils/serf
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2019-07-01 17:55:32 +0000
committerSteve Wills <swills@FreeBSD.org>2019-07-01 17:55:32 +0000
commita948a437fefe0224940a7ae3fd55cb43b064f891 (patch)
tree5105ee1588045f1e911cbcbc6d378a3b8b8b2d9e /sysutils/serf
parent418535e00f7613450746bcb36a38f9c0b6bd5b2e (diff)
downloadports-a948a437fefe0224940a7ae3fd55cb43b064f891.tar.gz
ports-a948a437fefe0224940a7ae3fd55cb43b064f891.zip
sysutils/serf: Switch to USES=go:modules, fix build with go1.13beta1
PR: 238927 Submitted by: Dmitri Goutnik <dg@syrec.org>
Notes
Notes: svn path=/head/; revision=505625
Diffstat (limited to 'sysutils/serf')
-rw-r--r--sysutils/serf/Makefile14
1 files changed, 3 insertions, 11 deletions
diff --git a/sysutils/serf/Makefile b/sysutils/serf/Makefile
index 85d37433251f..b8ee7809991f 100644
--- a/sysutils/serf/Makefile
+++ b/sysutils/serf/Makefile
@@ -11,12 +11,12 @@ COMMENT= Service discovery and configuration made easy
LICENSE= MPL20
-USES= go
+USES= go:modules
USE_GITHUB= yes
-
GH_ACCOUNT= hashicorp
-GH_SUBDIR:= src/github.com/${GH_ACCOUNT}/${PORTNAME}
+
+GO_TARGET= ./cmd/${PORTNAME}
USE_RC_SUBR= serf
@@ -25,12 +25,4 @@ GROUPS= serf
PLIST_FILES= bin/serf
-do-build:
- @cd ${WRKSRC}/src/github.com/${GH_ACCOUNT}/${PORTNAME}; \
- ${SETENV} ${MAKE_ENV} GOPATH=${WRKSRC}:${WRKSRC}/vendor/ \
- go build -o bin/${PORTNAME} ./cmd/serf/
-
-do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/src/github.com/${GH_ACCOUNT}/${PORTNAME}/bin/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
-
.include <bsd.port.mk>