aboutsummaryrefslogtreecommitdiff
path: root/sysutils/sleuthkit/Makefile
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2003-09-08 11:24:01 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2003-09-08 11:24:01 +0000
commit0fb001e87b2de2fedc11c2fa8b5879cbebd6aa2c (patch)
tree777e2baf849d047ceba54d0e959a6acf5aeeb284 /sysutils/sleuthkit/Makefile
parentb5c1e8ce4228ccfe1dbf780d1c9a749fd6f878b4 (diff)
downloadports-0fb001e87b2de2fedc11c2fa8b5879cbebd6aa2c.tar.gz
ports-0fb001e87b2de2fedc11c2fa8b5879cbebd6aa2c.zip
[NEW PORT] sysutils/sleuthkit: The @stake Sleuth Kit for
The @stake Sleuth Kit (TASK) is the only open source forensic toolkit for a complete analysis of Microsoft and UNIX file systems. TASK enables investigators to identify and recover evidence from images acquired during incident response or from live systems. WWW: http://www.atstake.com/research/tools/task/ PR: ports/55545 Submitted by: Pieter Danhieux <pieter@securax.be>
Notes
Notes: svn path=/head/; revision=88794
Diffstat (limited to 'sysutils/sleuthkit/Makefile')
-rw-r--r--sysutils/sleuthkit/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/sysutils/sleuthkit/Makefile b/sysutils/sleuthkit/Makefile
new file mode 100644
index 000000000000..bb9773fc08ec
--- /dev/null
+++ b/sysutils/sleuthkit/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: sleuthkit
+# Date created: 2003-08-12
+# Whom: Pieter Danhieux <opr@bsdaemon.be>
+#
+# $FreeBSD$
+#
+
+PORTNAME= sleuthkit
+PORTVERSION= 1.64
+CATEGORIES= sysutils security
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= opr@bsdaemon.be
+COMMENT= The @stake Sleuth Kit for forensic analysis
+
+USE_PERL5= yes
+DOCS= README docs/* tct.docs/*
+MAN1= dcalc.1 dcat.1 dls.1 dstat.1 ffind.1 \
+ fls.1 fsstat.1 hfind.1 icat.1 ifind.1 \
+ ils.1 istat.1 mactime.1 mmls.1 sorter.1
+
+do-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${PREFIX}/share/doc/sleuthkit
+ cd ${WRKSRC} && ${INSTALL_DATA} ${DOCS} ${PREFIX}/share/doc/sleuthkit
+.endif
+ ${INSTALL_SCRIPT} ${WRKSRC}/bin/mactime ${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKSRC}/bin/sorter ${PREFIX}/bin
+ cd ${WRKSRC}/bin && ${INSTALL_PROGRAM} dcalc dcat dls dstat ffind \
+ fls fsstat hfind icat ifind ils \
+ istat sha1 mmls file md5 ${PREFIX}/bin
+ cd ${WRKSRC}/man/man1 && ${INSTALL_MAN} ${MAN1} ${PREFIX}/man/man1
+
+.include <bsd.port.mk>