aboutsummaryrefslogtreecommitdiff
path: root/sysutils/sortu
diff options
context:
space:
mode:
authorJason Helfman <jgh@FreeBSD.org>2012-06-19 16:44:39 +0000
committerJason Helfman <jgh@FreeBSD.org>2012-06-19 16:44:39 +0000
commitbed5423182aea1e643639fd96b09e7039f323b75 (patch)
tree7be39c3beaa98a118ab885e48c92c887955540a9 /sysutils/sortu
parentfbc6ddc152b4b9f7b71db8639f535db538654fbc (diff)
downloadports-bed5423182aea1e643639fd96b09e7039f323b75.tar.gz
ports-bed5423182aea1e643639fd96b09e7039f323b75.zip
- update to 2.1.2, honour CC/CFLAGS and add LICENSE [1]
- while here [2] - use optionsNG for portdocs - use portsdocs and plist files in favor of pkg-plist file - remove unnecessary inclusion of bsd.port.pre.mk in favor of bsd.port.options.mk PR: ports/169141 Submitted by: koobs.freebsd@gmail.com [1], jgh@ [2] Approved by: maintainer, matt@peterson.org
Notes
Notes: svn path=/head/; revision=299645
Diffstat (limited to 'sysutils/sortu')
-rw-r--r--sysutils/sortu/Makefile15
-rw-r--r--sysutils/sortu/distinfo4
-rw-r--r--sysutils/sortu/files/patch-Makefile22
-rw-r--r--sysutils/sortu/pkg-plist3
4 files changed, 34 insertions, 10 deletions
diff --git a/sysutils/sortu/Makefile b/sysutils/sortu/Makefile
index 85cec8c5ab7f..3ad0863b074a 100644
--- a/sysutils/sortu/Makefile
+++ b/sysutils/sortu/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= sortu
-PORTVERSION= 2.1.0
+PORTVERSION= 2.1.2
CATEGORIES= sysutils
MASTER_SITES= http://256.com/sources/sortu/ \
http://matt.peterson.org/FreeBSD/ports/
@@ -15,17 +15,22 @@ EXTRACT_SUFX= .tgz
MAINTAINER= matt@peterson.org
COMMENT= Tool that combines sort and uniq functionality
+LICENSE= ISCL
+
+PORTDOCS= *
+PLIST_FILES= bin/sortu
+
ALL_TARGET= sortu
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/sortu ${PREFIX}/bin
post-install:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README.txt ${DOCSDIR}
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/sysutils/sortu/distinfo b/sysutils/sortu/distinfo
index 260b5d542363..cad4add89d2d 100644
--- a/sysutils/sortu/distinfo
+++ b/sysutils/sortu/distinfo
@@ -1,2 +1,2 @@
-SHA256 (sortu-2.1.0.tgz) = 009aee18702dcf70270d5363254411fab83691a92fcf84055f69e52c7c772a95
-SIZE (sortu-2.1.0.tgz) = 56365
+SHA256 (sortu-2.1.2.tgz) = eb42c4bc314996db27e0db7d7f04432ddf6ce2f34a316b1d3f2c4ba89c165ead
+SIZE (sortu-2.1.2.tgz) = 54396
diff --git a/sysutils/sortu/files/patch-Makefile b/sysutils/sortu/files/patch-Makefile
new file mode 100644
index 000000000000..bb4362d2caff
--- /dev/null
+++ b/sysutils/sortu/files/patch-Makefile
@@ -0,0 +1,22 @@
+--- ./Makefile.orig 2012-06-16 16:54:07.000000000 +1000
++++ ./Makefile 2012-06-16 16:54:52.000000000 +1000
+@@ -2,7 +2,7 @@
+ # $Id: Makefile,v 1.7 2011-11-15 18:55:19 gray Exp $
+ #
+
+-CC = cc
++CC ?= cc
+
+ PROG = sortu
+ OBJS = sortu.o argv.o strsep.o table.o
+@@ -10,8 +10,8 @@
+ PORTFLS = README.txt LICENSE.txt Makefile ChangeLog test_sortu.sh \
+ sortu.c strsep.[ch] argv.[ch] argv_loc.h table.[ch] table_loc.h
+
+-CFLAGS = -g -Wall -O2 $(CCFLS)
+-DESTDIR = /usr/local/sbin
++CFLAGS ?= -g -Wall -O2 $(CCFLS)
++DESTDIR ?= /usr/local/sbin
+
+ all : $(PROG)
+
diff --git a/sysutils/sortu/pkg-plist b/sysutils/sortu/pkg-plist
deleted file mode 100644
index ce3f62a4cde3..000000000000
--- a/sysutils/sortu/pkg-plist
+++ /dev/null
@@ -1,3 +0,0 @@
-bin/sortu
-%%PORTDOCS%%%%DOCSDIR%%/README
-%%PORTDOCS%%@dirrm %%DOCSDIR%%