aboutsummaryrefslogtreecommitdiff
path: root/sysutils/spiped/Makefile
diff options
context:
space:
mode:
authorChris Rees <crees@FreeBSD.org>2011-08-21 11:32:16 +0000
committerChris Rees <crees@FreeBSD.org>2011-08-21 11:32:16 +0000
commit0e39fa3110e19d9d3a6d25bd29607273829e55c6 (patch)
tree595dbbeb37f7a939febc5486c8e25134a13919cc /sysutils/spiped/Makefile
parentbe19bbaab59200bd21b927ff1087a1189d157023 (diff)
downloadports-0e39fa3110e19d9d3a6d25bd29607273829e55c6.tar.gz
ports-0e39fa3110e19d9d3a6d25bd29607273829e55c6.zip
Spiped (pronounced "ess-pipe-dee") is a utility for creating symmetrically
encrypted and authenticated pipes between socket addresses, so that one may connect to one address (e.g., a UNIX socket on localhost) and transparently have a connection established to another address (e.g., a UNIX socket on a different system). This is similar to 'ssh -L' functionality, but does not use SSH and requires a pre-shared symmetric key. WWW: http://www.tarsnap.com/spiped.html - Colin Percival cperciva@tarsnap.com PR: ports/159899 Submitted by: Colin Percival
Notes
Notes: svn path=/head/; revision=280118
Diffstat (limited to 'sysutils/spiped/Makefile')
-rw-r--r--sysutils/spiped/Makefile21
1 files changed, 21 insertions, 0 deletions
diff --git a/sysutils/spiped/Makefile b/sysutils/spiped/Makefile
new file mode 100644
index 000000000000..39f0efafa134
--- /dev/null
+++ b/sysutils/spiped/Makefile
@@ -0,0 +1,21 @@
+# New ports collection makefile for: spiped secure pipe daemon
+# Date created: 2011-08-18
+# Whom: Colin Percival
+#
+# $FreeBSD$
+#
+
+PORTNAME= spiped
+PORTVERSION= 1.0.0
+CATEGORIES= sysutils security
+MASTER_SITES= http://www.tarsnap.com/spiped/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= cperciva@tarsnap.com
+COMMENT= Daemon for creating secure symmetric pipes
+
+PLIST_FILES= bin/spiped
+
+USE_RC_SUBR= spiped
+
+.include <bsd.port.mk>