aboutsummaryrefslogtreecommitdiff
path: root/sysutils/tmux-mem-cpu-load
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2021-08-04 21:48:08 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2021-08-04 21:48:14 +0000
commit8879322c93e2b28c4f270699879eed2ed9a3521b (patch)
tree5c1b8c9a70ff7057a462c93979783e5ac6d45bd2 /sysutils/tmux-mem-cpu-load
parent54b26298c82275501e6dcc6c733d21c0a6bf0d9f (diff)
downloadports-8879322c93e2b28c4f270699879eed2ed9a3521b.tar.gz
ports-8879322c93e2b28c4f270699879eed2ed9a3521b.zip
sysutils/tmux-mem-cpu-load: Update to 3.5.1
Diffstat (limited to 'sysutils/tmux-mem-cpu-load')
-rw-r--r--sysutils/tmux-mem-cpu-load/Makefile3
-rw-r--r--sysutils/tmux-mem-cpu-load/distinfo6
-rw-r--r--sysutils/tmux-mem-cpu-load/files/patch-freebsd_cpu.cc28
3 files changed, 4 insertions, 33 deletions
diff --git a/sysutils/tmux-mem-cpu-load/Makefile b/sysutils/tmux-mem-cpu-load/Makefile
index 5409d447ca8b..4a46b49887ae 100644
--- a/sysutils/tmux-mem-cpu-load/Makefile
+++ b/sysutils/tmux-mem-cpu-load/Makefile
@@ -1,8 +1,7 @@
# Created by: Adam Weinberger <adamw@FreeBSD.org>
PORTNAME= tmux-mem-cpu-load
-PORTVERSION= 3.5.0
-PORTREVISION= 1
+PORTVERSION= 3.5.1
DISTVERSIONPREFIX= v
CATEGORIES= sysutils
diff --git a/sysutils/tmux-mem-cpu-load/distinfo b/sysutils/tmux-mem-cpu-load/distinfo
index 03fb3a3292ac..13c0681b9ea0 100644
--- a/sysutils/tmux-mem-cpu-load/distinfo
+++ b/sysutils/tmux-mem-cpu-load/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1628076750
-SHA256 (thewtex-tmux-mem-cpu-load-v3.5.0_GH0.tar.gz) = 555b8fe2dfbedd496e697c86aa0824a4ed3a4ade7e8c007b5cb11c962084b511
-SIZE (thewtex-tmux-mem-cpu-load-v3.5.0_GH0.tar.gz) = 23022
+TIMESTAMP = 1628113653
+SHA256 (thewtex-tmux-mem-cpu-load-v3.5.1_GH0.tar.gz) = 6b62197ba755eec775b3f494db617b239b5e9d79945e165a3c8bba3b9092d0d1
+SIZE (thewtex-tmux-mem-cpu-load-v3.5.1_GH0.tar.gz) = 23020
diff --git a/sysutils/tmux-mem-cpu-load/files/patch-freebsd_cpu.cc b/sysutils/tmux-mem-cpu-load/files/patch-freebsd_cpu.cc
deleted file mode 100644
index c1bd8c3b9ab0..000000000000
--- a/sysutils/tmux-mem-cpu-load/files/patch-freebsd_cpu.cc
+++ /dev/null
@@ -1,28 +0,0 @@
-From 96ea7dc0507679203b07e673ebd21a0ea8d474e9 Mon Sep 17 00:00:00 2001
-From: Matt McCormick <matt.mccormick@kitware.com>
-Date: Wed, 4 Aug 2021 15:05:19 -0400
-Subject: [PATCH] Consistent get_cpu_count for FreeBSD
-
----
- freebsd/cpu.cc | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/freebsd/cpu.cc b/freebsd/cpu.cc
-index b85d402..4c7dddb 100644
---- freebsd/cpu.cc.orig
-+++ freebsd/cpu.cc
-@@ -26,12 +26,12 @@
- #include "getsysctl.h"
- #include "cpu.h"
-
--uint8_t get_cpu_count()
-+uint32_t get_cpu_count()
- {
- int32_t cpu_count = 0;
- GETSYSCTL( "hw.ncpu", cpu_count );
-
-- return static_cast<uint8_t>( cpu_count );
-+ return static_cast<uint32_t>( cpu_count );
- }
-
- float cpu_percentage( unsigned int cpu_usage_delay )