aboutsummaryrefslogtreecommitdiff
path: root/sysutils/tmux
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2019-04-10 16:01:38 +0000
committerMathieu Arnold <mat@FreeBSD.org>2019-04-10 16:01:38 +0000
commitf52b8e5cc540df7978f17758e1f1eb5a64a14130 (patch)
tree281bccaf6e92f83c7faf83c980e7a1aa92f5fe43 /sysutils/tmux
parent579a33ee337e960e0c3206432a2b88cbe15dc4bb (diff)
downloadports-f52b8e5cc540df7978f17758e1f1eb5a64a14130.tar.gz
ports-f52b8e5cc540df7978f17758e1f1eb5a64a14130.zip
Add a default option to use utf8proc for Unicode normalization,
case-folding, and other operations. It is substantially better and more up-to-date than the libc functions providing the same features. PR: 234822 Submitted by: David O'Rourke
Notes
Notes: svn path=/head/; revision=498577
Diffstat (limited to 'sysutils/tmux')
-rw-r--r--sysutils/tmux/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/sysutils/tmux/Makefile b/sysutils/tmux/Makefile
index 1bbd7c761faa..84a82ca67b5f 100644
--- a/sysutils/tmux/Makefile
+++ b/sysutils/tmux/Makefile
@@ -3,6 +3,7 @@
PORTNAME= tmux
PORTVERSION= 2.8
+PORTREVISION= 1
CATEGORIES= sysutils
MASTER_SITES= https://github.com/tmux/tmux/releases/download/${PORTVERSION}/
DISTFILES= ${DISTNAME}${EXTRACT_SUFX}
@@ -30,10 +31,12 @@ PLIST_FILES= bin/tmux \
PORTDOCS= CHANGES README TODO
PORTEXAMPLES= *
-OPTIONS_DEFINE= DOCS EXAMPLES LIBEVENT_STATIC BACKSPACE
+OPTIONS_DEFINE= DOCS EXAMPLES LIBEVENT_STATIC BACKSPACE UTF8PROC
+OPTIONS_DEFAULT= UTF8PROC
LIBEVENT_STATIC_DESC= Build with static libevent
BACKSPACE_DESC= Build with tty/keys patch
+UTF8PROC_DESC= Build with utf8proc support
BACKSPACE_EXTRA_PATCHES= ${PATCHDIR}/extra-patch-tty-keys.c
@@ -41,6 +44,9 @@ LIBEVENT_STATIC_LIB_DEPENDS_OFF= libevent.so:devel/libevent
LIBEVENT_STATIC_BUILD_DEPENDS= ${LOCALBASE}/lib/libevent.a:devel/libevent
LIBEVENT_STATIC_VARS= LESTATIC=${LOCALBASE}/lib/libevent.a
+UTF8PROC_CONFIGURE_ENABLE= utf8proc
+UTF8PROC_LIB_DEPENDS= libutf8proc.so:textproc/utf8proc
+
post-patch:
@${REINPLACE_CMD} -e 's|/etc/tmux.conf|${PREFIX}/etc/tmux.conf|g' ${WRKSRC}/CHANGES \
${WRKSRC}/tmux.h