aboutsummaryrefslogtreecommitdiff
path: root/sysutils/u-boot-beaglebone
diff options
context:
space:
mode:
authorEmmanuel Vadot <manu@FreeBSD.org>2019-09-16 15:07:44 +0000
committerEmmanuel Vadot <manu@FreeBSD.org>2019-09-16 15:07:44 +0000
commit4c2a4d4dcee779853786e8cd8beecf3f599a1654 (patch)
treefd120d41fbdaa9adebfe995c545221180522f8a9 /sysutils/u-boot-beaglebone
parent648cd7f22bcd37f6b6d5cf53c79952241e87c043 (diff)
downloadports-4c2a4d4dcee779853786e8cd8beecf3f599a1654.tar.gz
ports-4c2a4d4dcee779853786e8cd8beecf3f599a1654.zip
u-boot-beaglebone: Add some fragment data to disable NAND
Since u-boot merged the beaglebone defconfig with the am335x_evm ones eMMC support is seriously broken. Disabling NAND support (which isn't present on BBB) make this works again as they share some pins. Also remove the legacy_mmc targets as it is Linux centric.
Notes
Notes: svn path=/head/; revision=512180
Diffstat (limited to 'sysutils/u-boot-beaglebone')
-rw-r--r--sysutils/u-boot-beaglebone/Makefile2
-rw-r--r--sysutils/u-boot-beaglebone/files/bbb_fragment8
2 files changed, 9 insertions, 1 deletions
diff --git a/sysutils/u-boot-beaglebone/Makefile b/sysutils/u-boot-beaglebone/Makefile
index c1b306a60893..a97c47d24685 100644
--- a/sysutils/u-boot-beaglebone/Makefile
+++ b/sysutils/u-boot-beaglebone/Makefile
@@ -2,6 +2,8 @@
MASTERDIR= ${.CURDIR}/../u-boot-master
+U_BOOT_SLAVE_PORTREVISION_2019.07= 1
+
MODEL= beaglebone
BOARD_CONFIG= am335x_evm_defconfig
FAMILY= omap
diff --git a/sysutils/u-boot-beaglebone/files/bbb_fragment b/sysutils/u-boot-beaglebone/files/bbb_fragment
index 0c43dc883547..99e906a20a89 100644
--- a/sysutils/u-boot-beaglebone/files/bbb_fragment
+++ b/sysutils/u-boot-beaglebone/files/bbb_fragment
@@ -1,4 +1,10 @@
CONFIG_API=y
CONFIG_ARMV7_NONSEC=n
CONFIG_CMD_CACHE=y
-CONFIG_BOOTCOMMAND="if test ${boot_fit} -eq 1; then run update_to_fit; fi; run findfdt; run init_console; run distro_bootcmd"
+CONFIG_BOOTCOMMAND="if test ${boot_fit} -eq 1; then run update_to_fit; fi; run findfdt; run init_console; setenv boot_targets mmc0 mmc1 pxe dhcp; run distro_bootcmd"
+CONFIG_NAND=n
+CONFIG_SPL_NAND_SUPPORT=n
+CONFIG_CMD_NAND=n
+CONFIG_DFU_NAND=n
+CONFIG_ENV_IS_IN_MMC=y
+CONFIG_SYS_EXTRA_OPTIONS="EMMC_BOOT"