aboutsummaryrefslogtreecommitdiff
path: root/sysutils/u-boot-master/Makefile
diff options
context:
space:
mode:
authorEmmanuel Vadot <manu@FreeBSD.org>2019-07-27 14:54:09 +0000
committerEmmanuel Vadot <manu@FreeBSD.org>2019-07-27 14:54:09 +0000
commit0565409a4365e84950b2e8d9da995763354a06bb (patch)
treebd1b9ff08c18082b24c516df5cf9011a9bb62d85 /sysutils/u-boot-master/Makefile
parent181a418ce46fc1eeedfd49b771a1988574ad58f3 (diff)
downloadports-0565409a4365e84950b2e8d9da995763354a06bb.tar.gz
ports-0565409a4365e84950b2e8d9da995763354a06bb.zip
sysutils/u-boot-rock64: Add new port for u-boot for the Pine64 Rock64 board
And add support for building RK3328 u-boot in u-boot-master. This use the rockchip DDR blob + ATF + u-boot-spl and u-boot proper.
Notes
Notes: svn path=/head/; revision=507458
Diffstat (limited to 'sysutils/u-boot-master/Makefile')
-rw-r--r--sysutils/u-boot-master/Makefile14
1 files changed, 14 insertions, 0 deletions
diff --git a/sysutils/u-boot-master/Makefile b/sysutils/u-boot-master/Makefile
index 9357b66bea7b..ed2c5c37365e 100644
--- a/sysutils/u-boot-master/Makefile
+++ b/sysutils/u-boot-master/Makefile
@@ -89,6 +89,10 @@ UBOOT_METADATA_IMX6_METHOD= raw
UBOOT_METADATA_IMX6_RAW_OFFSET= 2
UBOOT_METADATA_IMX6_RAW_BS= 512
+# Override for RK3328 family
+UBOOT_PLIST_RK3328= idbloader.img u-boot.itb
+UBOOT_ARCH_RK3328= aarch64
+
# Override for RK3399 family
UBOOT_PLIST_RK3399= idbspl.img u-boot.itb
UBOOT_ARCH_RK3399= aarch64
@@ -140,6 +144,12 @@ BUILD_DEPENDS+= ${LOCALBASE}/share/atf-sun50i_a64/bl31.bin:sysutils/atf-sun50i_a
MAKE_ENV+= BL31=${LOCALBASE}/share/atf-sun50i_a64/bl31.bin
.endif
+.if defined(FAMILY) && ${FAMILY} == rk3328
+BUILD_DEPENDS+= ${LOCALBASE}/share/atf-rk3328/bl31.elf:sysutils/atf-rk3328 \
+ ${PYTHON_PKGNAMEPREFIX}pyelftools>0:devel/py-pyelftools@${PY_FLAVOR}
+MAKE_ENV+= BL31=${LOCALBASE}/share/atf-rk3328/bl31.elf
+.endif
+
.if defined(FAMILY) && ${FAMILY} == rk3399
BUILD_DEPENDS+= ${LOCALBASE}/share/atf-rk3399/bl31.elf:sysutils/atf-rk3399 \
${PYTHON_PKGNAMEPREFIX}pyelftools>0:devel/py-pyelftools@${PY_FLAVOR}
@@ -204,6 +214,10 @@ post-build:
(cd ${WRKSRC}; ${SETENV} ${CONFIGURE_ENV} ${MAKE_ENV} ${MAKE_CMD} ${MAKE_ARGS} ${i})
.endfor
.endif
+.if defined(FAMILY) && ${FAMILY} == rk3328
+ mkimage -n rk3328 -T rksd -d ${LOCALBASE}/share/linux-rkbin/bin/rk33/rk3328_ddr_333MHz_v1.16.bin ${WRKSRC}/idbloader.img
+ cat ${WRKSRC}/spl/u-boot-spl.bin >> ${WRKSRC}/idbloader.img
+.endif
.if defined(FAMILY) && ${FAMILY} == rk3399
mkimage -n rk3399 -T rksd -d ${WRKSRC}/spl/u-boot-spl.bin ${WRKSRC}/idbspl.img
.endif