aboutsummaryrefslogtreecommitdiff
path: root/sysutils/u-boot-master/Makefile
diff options
context:
space:
mode:
authorEmmanuel Vadot <manu@FreeBSD.org>2018-08-10 15:49:13 +0000
committerEmmanuel Vadot <manu@FreeBSD.org>2018-08-10 15:49:13 +0000
commit3918d7482186a21a7e7d72d0ffa2e0fd191879ac (patch)
tree4b7ce43cfa766afcfd2216deac4b70492a7de477 /sysutils/u-boot-master/Makefile
parent6c4e30ccddab2c3278482a45e6ea7ca14b7dea9d (diff)
downloadports-3918d7482186a21a7e7d72d0ffa2e0fd191879ac.tar.gz
ports-3918d7482186a21a7e7d72d0ffa2e0fd191879ac.zip
sysutils/u-boot-master etc.: u-boot Improvement for 2018.07
- Add metadata for IMX6 family - While here rename the riotboard family to IMX6 as it should have been - Remove the cache patches, they aren't needed anymore. I should have checked that with the 2018.07 update - beaglebone use a custom bootcmd that calls envboot, this command will try to load and source the file boot.scr (u-boot script) from the mmc. For some reason it seems to corrupts some memory or something because loading and executing ubldr.bin after running this command will either hang or cause an exception on undefined instruction. I'll check with upstream but in the meantime use a special fragment that redefine the bootcmd. Note that since u-boot will load the environment from the eMMC, one need to 'env default -f -a; saveenv' to have the bootcmd variable correctly redefined. Reviewed by: imp Approved by: imp Differential Revision: https://reviews.freebsd.org/D16599
Notes
Notes: svn path=/head/; revision=476839
Diffstat (limited to 'sysutils/u-boot-master/Makefile')
-rw-r--r--sysutils/u-boot-master/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/sysutils/u-boot-master/Makefile b/sysutils/u-boot-master/Makefile
index 8cdd2034fe7e..f0b1feb3cf11 100644
--- a/sysutils/u-boot-master/Makefile
+++ b/sysutils/u-boot-master/Makefile
@@ -5,7 +5,7 @@
PORTNAME= u-boot
PORTVERSION= ${UBOOT_VERSION}
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= sysutils
PKGNAMESUFFIX?= -${MODEL}
MASTER_SITES= ftp://ftp.denx.de/pub/u-boot/
@@ -84,6 +84,12 @@ UBOOT_PLIST_RPI= u-boot.bin
UBOOT_METADATA_RPI_FILES= ${UBOOT_PLIST_RPI}
UBOOT_METADATA_RPI_METHOD= file
+# Overrides for IMX6 family
+UBOOT_METADATA_IMX6_FILES= u-boot.imx
+UBOOT_METADATA_IMX6_METHOD= raw
+UBOOT_METADATA_IMX6_RAW_OFFSET= 2
+UBOOT_METADATA_IMX6_RAW_BS= 512
+
# Uboot variables
.if !defined(UBOOT_VERSION) && defined(UBOOT_VERSION_${FAMILY:tu})
UBOOT_VERSION=${UBOOT_VERSION_${FAMILY:tu}}