aboutsummaryrefslogtreecommitdiff
path: root/sysutils/u-boot-rpi2
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2018-07-22 20:31:31 +0000
committerMark Linimon <linimon@FreeBSD.org>2018-07-22 20:31:31 +0000
commitb8623ee004f581aab182bea4b01406b22407d3fa (patch)
treeca21ddc94ca85b3f7308dd257c2cff97de7c122e /sysutils/u-boot-rpi2
parentc2e87ab8b0edba30926eb6f2aa513c0897cda3c4 (diff)
downloadports-b8623ee004f581aab182bea4b01406b22407d3fa.tar.gz
ports-b8623ee004f581aab182bea4b01406b22407d3fa.zip
Add and use patchfiles that are in accordance with accepted Ports
Collection usage.
Notes
Notes: svn path=/head/; revision=475124
Diffstat (limited to 'sysutils/u-boot-rpi2')
-rw-r--r--sysutils/u-boot-rpi2/Makefile8
-rw-r--r--sysutils/u-boot-rpi2/files/patch-include_configs_rpi.h19
2 files changed, 21 insertions, 6 deletions
diff --git a/sysutils/u-boot-rpi2/Makefile b/sysutils/u-boot-rpi2/Makefile
index 57546c91994a..69ef194a206c 100644
--- a/sysutils/u-boot-rpi2/Makefile
+++ b/sysutils/u-boot-rpi2/Makefile
@@ -1,6 +1,5 @@
# $FreeBSD$
-MAINTAINER= manu@FreeBSD.org
MASTERDIR= ${.CURDIR}/../u-boot-master
MODEL= rpi2
@@ -9,10 +8,7 @@ FAMILY= rpi
DEPENDS= ${LOCALBASE}/share/rpi-firmware/bootcode.bin:sysutils/rpi-firmware
-PATCHFILES+= 937869/mbox/? \
- 939129/mbox/?
-
-CONFIG_FRAGMENT= ${.CURDIR}/files/rpi2_fragment
-FRAGMENT_NAME= rpi2_fragment
+FRAGMENT_NAME= rpi2_fragment
+CONFIG_FRAGMENT= ${.CURDIR}/files/${FRAGMENT_NAME}
.include "${MASTERDIR}/Makefile"
diff --git a/sysutils/u-boot-rpi2/files/patch-include_configs_rpi.h b/sysutils/u-boot-rpi2/files/patch-include_configs_rpi.h
new file mode 100644
index 000000000000..e3bd81d3d280
--- /dev/null
+++ b/sysutils/u-boot-rpi2/files/patch-include_configs_rpi.h
@@ -0,0 +1,19 @@
+--- include/configs/rpi.h.orig 2018-07-09 14:24:14 UTC
++++ include/configs/rpi.h
+@@ -69,6 +69,8 @@
+ #define CONFIG_MISC_INIT_R
+ #endif
+
++#define CONFIG_SYS_MMC_MAX_DEVICE 2
++
+ /* Console configuration */
+ #define CONFIG_SYS_CBSIZE 1024
+
+@@ -150,6 +152,7 @@
+
+ #define BOOT_TARGET_DEVICES(func) \
+ func(MMC, mmc, 0) \
++ func(MMC, mmc, 1) \
+ func(USB, usb, 0) \
+ func(PXE, pxe, na) \
+ func(DHCP, dhcp, na)