aboutsummaryrefslogtreecommitdiff
path: root/sysutils/u-boot-rpi
diff options
context:
space:
mode:
authorIan Lepore <ian@FreeBSD.org>2015-08-09 01:38:55 +0000
committerIan Lepore <ian@FreeBSD.org>2015-08-09 01:38:55 +0000
commite8effadcaa0c0e16f0cf836cde1fdfc6b1beccec (patch)
tree81e141b2866f65e4ca57f6afd838b3375a02ab22 /sysutils/u-boot-rpi
parentf93d86dc30a7ef9c0b2fab1ae5ab836abc69e9af (diff)
downloadports-e8effadcaa0c0e16f0cf836cde1fdfc6b1beccec.tar.gz
ports-e8effadcaa0c0e16f0cf836cde1fdfc6b1beccec.zip
Use gcc 4.9.2 to cross-compile u-boot for rpi.
Approved by: rpaulo
Notes
Notes: svn path=/head/; revision=393752
Diffstat (limited to 'sysutils/u-boot-rpi')
-rw-r--r--sysutils/u-boot-rpi/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/sysutils/u-boot-rpi/Makefile b/sysutils/u-boot-rpi/Makefile
index 76ca36161303..7809e727f15d 100644
--- a/sysutils/u-boot-rpi/Makefile
+++ b/sysutils/u-boot-rpi/Makefile
@@ -14,9 +14,11 @@ COMMENT= Cross-build U-Boot loader for Raspberry Pi
LICENSE= GPLv2
-BUILD_DEPENDS= arm-none-eabi-gcc:${PORTSDIR}/devel/arm-none-eabi-gcc \
+BUILD_DEPENDS= ${CROSS_GCC}:${PORTSDIR}/devel/arm-none-eabi-gcc492 \
gsed:${PORTSDIR}/textproc/gsed
+CROSS_GCC= arm-none-eabi-gcc-4.9.2
+
USE_GITHUB= yes
GH_ACCOUNT= gonzoua
GH_PROJECT= u-boot-pi
@@ -43,6 +45,7 @@ PLIST_FILES= ${U_BOOT_DIR}/u-boot.img \
MAKE_ARGS+= ARCH=arm \
CROSS_COMPILE=arm-none-eabi- \
HOSTCC=cc \
+ CC=${CROSS_GCC} \
SED=gsed
do-configure: