aboutsummaryrefslogtreecommitdiff
path: root/sysutils/u-boot-utilite
diff options
context:
space:
mode:
authorRaphael Kubo da Costa <rakuco@FreeBSD.org>2016-02-28 14:32:45 +0000
committerRaphael Kubo da Costa <rakuco@FreeBSD.org>2016-02-28 14:32:45 +0000
commit2f64d774f7f419f6b82de456e3193cb18c320dbe (patch)
tree03f3de4c8949993492dd2c00324a4cd65871f580 /sysutils/u-boot-utilite
parentfc3693b546d2f2c473c1a1858ad427dbd9c4b245 (diff)
downloadports-2f64d774f7f419f6b82de456e3193cb18c320dbe.tar.gz
ports-2f64d774f7f419f6b82de456e3193cb18c320dbe.zip
Apply some small fixes to the port.
- Set correct number (3) for CONFIG_SYS_MMC_MAX_DEVICE - Remove "SSP_UNSAFE= yes" from Makefile. The port builds fine without it. - Add "PORTSCOUT= ignore" to Makefile. New versions only make sense if manufacturer (CompuLab) decides to move to upgraded u-boot version. PR: 207554 Submitted by: Martin Waschbüsch <martin@waschbuesch.de> (maintainer)
Notes
Notes: svn path=/head/; revision=409742
Diffstat (limited to 'sysutils/u-boot-utilite')
-rw-r--r--sysutils/u-boot-utilite/Makefile4
-rw-r--r--sysutils/u-boot-utilite/files/patch-include_configs_cm__fx6.h13
2 files changed, 13 insertions, 4 deletions
diff --git a/sysutils/u-boot-utilite/Makefile b/sysutils/u-boot-utilite/Makefile
index ed48a96c182d..3eba8f99d664 100644
--- a/sysutils/u-boot-utilite/Makefile
+++ b/sysutils/u-boot-utilite/Makefile
@@ -2,6 +2,7 @@
PORTNAME= u-boot
PORTVERSION= 2015.07
+PORTREVISION= 1
CATEGORIES= sysutils
MASTER_SITES= ftp://ftp.denx.de/pub/u-boot/:source1 \
http://www.compulab.co.il/wp-content/uploads/2015/10/:source2
@@ -23,7 +24,8 @@ EXTRA_PATCHES= ${WRKDIR}/cm-fx6-u-boot/u-boot/u-boot-2015.07-cm-fx6-3.patch:-p1
NO_ARCH= yes
USES= gmake
-SSP_UNSAFE= yes # cross-build static linking dies with -fstack-protector
+
+PORTSCOUT= ignore
U_BOOT_DIR= share/u-boot/${PORTNAME}${PKGNAMESUFFIX}
diff --git a/sysutils/u-boot-utilite/files/patch-include_configs_cm__fx6.h b/sysutils/u-boot-utilite/files/patch-include_configs_cm__fx6.h
index 553253d8e3f0..a911587c63fc 100644
--- a/sysutils/u-boot-utilite/files/patch-include_configs_cm__fx6.h
+++ b/sysutils/u-boot-utilite/files/patch-include_configs_cm__fx6.h
@@ -1,11 +1,18 @@
---- include/configs/cm_fx6.h.orig 2016-02-27 13:29:39 UTC
+--- include/configs/cm_fx6.h.orig 2016-02-28 08:48:02 UTC
+++ include/configs/cm_fx6.h
-@@ -174,6 +174,9 @@
+@@ -21,6 +21,7 @@
+ #define CONFIG_CMD_GREPENV
+
+ /* MMC */
++#define CONFIG_SYS_MMC_MAX_DEVICE 3
+ #define CONFIG_SYS_FSL_USDHC_NUM 3
+ #define CONFIG_SYS_FSL_ESDHC_ADDR USDHC2_BASE_ADDR
+
+@@ -174,6 +175,8 @@
/* NAND */
#ifndef CONFIG_SPL_BUILD
+#define CONFIG_CMD_ELF
-+#define CONFIG_SYS_MMC_MAX_DEVICE 4
+#define CONFIG_API
#define CONFIG_CMD_NAND
#define CONFIG_SYS_NAND_BASE 0x40000000