aboutsummaryrefslogtreecommitdiff
path: root/sysutils/u-boot-utilite
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2016-07-24 09:48:39 +0000
committerPawel Pekala <pawel@FreeBSD.org>2016-07-24 09:48:39 +0000
commitd9ed9ba7944b0be27789992d2e53e05affdeca1b (patch)
tree29849d962cc8263423c3d66cdfae19ed5f358e51 /sysutils/u-boot-utilite
parentafe2e12dfa24cc7d7b270d0b569b647072d19705 (diff)
downloadports-d9ed9ba7944b0be27789992d2e53e05affdeca1b.tar.gz
ports-d9ed9ba7944b0be27789992d2e53e05affdeca1b.zip
Fix few style violations in u-boot ports:
- GMAKE -> MAKE_CMD, MAKE_CMD is always set to required make implementation - CP -> INSTALL_DATA, INSTALL_DATA makes sure files are always installed with proper permissions - sysutils/u-boot-rpi: include missed files installed in STAGEDIR in PLIST_FILES PR: 210982 Submitted by: myself Approved by: maintainers timeout
Notes
Notes: svn path=/head/; revision=418996
Diffstat (limited to 'sysutils/u-boot-utilite')
-rw-r--r--sysutils/u-boot-utilite/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/sysutils/u-boot-utilite/Makefile b/sysutils/u-boot-utilite/Makefile
index 0fcf07974f03..0304fe1e3b43 100644
--- a/sysutils/u-boot-utilite/Makefile
+++ b/sysutils/u-boot-utilite/Makefile
@@ -35,7 +35,7 @@ MAKE_ARGS+= ARCH=arm \
HOSTCC=cc
do-configure:
- cd ${WRKSRC}; ${GMAKE} ${MAKE_ARGS} cm_fx6_config
+ cd ${WRKSRC}; ${MAKE_CMD} ${MAKE_ARGS} cm_fx6_config
# The build results in two output files: SPL, and u-boot.img.
# Combine them into a single u-boot.imx so that there is only one file to be
@@ -46,6 +46,7 @@ do-install:
${MKDIR} ${STAGEDIR}/${PREFIX}/${U_BOOT_DIR}
dd if=/dev/zero count=500 bs=1K | ${TR} '\000' '\377' > ${CM_FX6_FIRMWARE}
dd if=${WRKSRC}/spl.img of=${CM_FX6_FIRMWARE} bs=1K seek=1 conv=notrunc && dd if=${WRKSRC}/u-boot.img of=${CM_FX6_FIRMWARE} bs=1K seek=64 conv=notrunc
- ${CP} ${.CURDIR}/pkg-descr ${STAGEDIR}/${PREFIX}/${U_BOOT_DIR}/README
+ ${INSTALL_DATA} ${.CURDIR}/pkg-descr \
+ ${STAGEDIR}/${PREFIX}/${U_BOOT_DIR}/README
.include <bsd.port.mk>