aboutsummaryrefslogtreecommitdiff
path: root/sysutils/ucspi-proxy
diff options
context:
space:
mode:
authorBryan Drewery <bdrewery@FreeBSD.org>2014-04-17 06:17:33 +0000
committerBryan Drewery <bdrewery@FreeBSD.org>2014-04-17 06:17:33 +0000
commit3ce2dbd185800272c89c33b37802fd53db32a146 (patch)
tree1dfbe6bafc95536dcdfa1dfbd240cf54cd12aad1 /sysutils/ucspi-proxy
parent84b55b3d3d312a0f0b7d05eca247783e09d6fcb5 (diff)
downloadports-3ce2dbd185800272c89c33b37802fd53db32a146.tar.gz
ports-3ce2dbd185800272c89c33b37802fd53db32a146.zip
- Stage
- Add missing run-time dependency on bglibs ====>> Checking shared library dependencies /lib/libc.so.7 /usr/local/lib/bglibs/libbg-sysdeps.so.2 /usr/local/lib/bglibs/libbg.so.2
Notes
Notes: svn path=/head/; revision=351454
Diffstat (limited to 'sysutils/ucspi-proxy')
-rw-r--r--sysutils/ucspi-proxy/Makefile13
1 files changed, 6 insertions, 7 deletions
diff --git a/sysutils/ucspi-proxy/Makefile b/sysutils/ucspi-proxy/Makefile
index cd8148f6292b..9e650f920971 100644
--- a/sysutils/ucspi-proxy/Makefile
+++ b/sysutils/ucspi-proxy/Makefile
@@ -9,22 +9,21 @@ MASTER_SITES= http://untroubled.org/ucspi-proxy/
MAINTAINER= dale.woolridge@gmail.com
COMMENT= A proxy program for UCSPI servers and clients
-BUILD_DEPENDS= ${BGLIBS_LIB}/libbg-unix.a:${PORTSDIR}/devel/bglibs
+LIB_DEPENDS= libbg.so:${PORTSDIR}/devel/bglibs
CFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
BGLIBS_LIB= ${LOCALBASE}/lib/bglibs
BGLIBS_INCLUDE= ${LOCALBASE}/include/bglibs
-MAN1= ucspi-proxy-http-xlate.1 ucspi-proxy.1
-
PLIST_FILES= bin/ucspi-proxy bin/ucspi-proxy-log bin/ucspi-proxy-pop3 \
- bin/ucspi-proxy-imap bin/ucspi-proxy-http-xlate
+ bin/ucspi-proxy-imap bin/ucspi-proxy-http-xlate \
+ man/man1/ucspi-proxy-http-xlate.1.gz \
+ man/man1/ucspi-proxy.1.gz
-NO_STAGE= yes
do-configure:
- ${ECHO_CMD} "${PREFIX}/bin" > ${WRKSRC}/conf-bin
- ${ECHO_CMD} "${MANPREFIX}/man" > ${WRKSRC}/conf-man
+ ${ECHO_CMD} "${STAGEDIR}${PREFIX}/bin" > ${WRKSRC}/conf-bin
+ ${ECHO_CMD} "${STAGEDIR}${MANPREFIX}/man" > ${WRKSRC}/conf-man
${ECHO_CMD} "${CC} ${CFLAGS}" > ${WRKSRC}/conf-cc
${ECHO_CMD} "${CC} ${STRIP} ${LDFLAGS}" > ${WRKSRC}/conf-ld
${ECHO_CMD} "${BGLIBS_INCLUDE}" > ${WRKSRC}/conf-bgincs