aboutsummaryrefslogtreecommitdiff
path: root/sysutils/unetbootin
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2017-10-31 10:30:04 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2017-10-31 10:30:04 +0000
commit9869822d7a51e9845c2468903e77f5e456e9529e (patch)
tree6707dec56f50cc1f5e0b1a77d2c56e40a3c32121 /sysutils/unetbootin
parent5169616a3b1c0975a8216889d936f56e9330397f (diff)
downloadports-9869822d7a51e9845c2468903e77f5e456e9529e.tar.gz
ports-9869822d7a51e9845c2468903e77f5e456e9529e.zip
- Update `sysutils/unetbootin' to version 657, which had added
support for Ubuntu 17.10 (Artful Aardvark) [*] - Once again, reword the comment about using getvfsbyname(3) - TIMESTAMP (unetbootin-source-657.tar.gz) = 1508836950 Found out via: repology.org [*]
Notes
Notes: svn path=/head/; revision=453225
Diffstat (limited to 'sysutils/unetbootin')
-rw-r--r--sysutils/unetbootin/Makefile3
-rw-r--r--sysutils/unetbootin/distinfo6
-rw-r--r--sysutils/unetbootin/files/patch-unetbootin.cpp8
3 files changed, 8 insertions, 9 deletions
diff --git a/sysutils/unetbootin/Makefile b/sysutils/unetbootin/Makefile
index 1408c7e20b70..f879a63bfba5 100644
--- a/sysutils/unetbootin/Makefile
+++ b/sysutils/unetbootin/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= unetbootin
-PORTVERSION= 655
-PORTREVISION= 1
+PORTVERSION= 657
CATEGORIES= sysutils
MASTER_SITES= SF/${PORTNAME}/UNetbootin/${PORTVERSION}
DISTNAME= ${PORTNAME}-source-${PORTVERSION}
diff --git a/sysutils/unetbootin/distinfo b/sysutils/unetbootin/distinfo
index 20b9e3d04184..ce4bd819491c 100644
--- a/sysutils/unetbootin/distinfo
+++ b/sysutils/unetbootin/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1500449397
-SHA256 (unetbootin-source-655.tar.gz) = 700125b0ea45805a22f729986c59377b1ff0c0a66ea6f01b29cd3cf60bfbaa79
-SIZE (unetbootin-source-655.tar.gz) = 749246
+TIMESTAMP = 1508836950
+SHA256 (unetbootin-source-657.tar.gz) = eacf0d8e7d712a34ae41f01c9a4c03cf01dd9a36284cd67475670c0ab5787690
+SIZE (unetbootin-source-657.tar.gz) = 749244
diff --git a/sysutils/unetbootin/files/patch-unetbootin.cpp b/sysutils/unetbootin/files/patch-unetbootin.cpp
index 7d64a05b9ac3..7420ee7bb1c3 100644
--- a/sysutils/unetbootin/files/patch-unetbootin.cpp
+++ b/sysutils/unetbootin/files/patch-unetbootin.cpp
@@ -24,10 +24,10 @@
+ struct statfs *fslist;
+
+ /*
-+ * Find out VFS number assigned by kernel for MSDOSFS.
-+ * This helps to ensure that it is configured with the
-+ * kernel. As a nice side effect, this also allows to
-+ * compare a number instead of "msdosfs" string later.
++ * Make sure that MSDOSFS is configured with the kernel.
++ * As a nice side effect, this would allow to compare a
++ * number (assigned by VFS) instead of "msdosfs" string
++ * when iterating over mounted filesystems.
+ */
+ if (getvfsbyname("msdosfs", &fsconf) == -1)
+ goto out;