aboutsummaryrefslogtreecommitdiff
path: root/sysutils/vobcopy
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2006-01-07 02:23:03 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2006-01-07 02:23:03 +0000
commite66043107000916954f44c9f4731f2b61d74dd1b (patch)
tree193834936045e8e30bf54a33cf611b01b28b8896 /sysutils/vobcopy
parent0c9250bacc4df19719f269dcaa04982eb10f04e1 (diff)
downloadports-e66043107000916954f44c9f4731f2b61d74dd1b.tar.gz
ports-e66043107000916954f44c9f4731f2b61d74dd1b.zip
Update to 0.5.16
Notes
Notes: svn path=/head/; revision=152942
Diffstat (limited to 'sysutils/vobcopy')
-rw-r--r--sysutils/vobcopy/Makefile11
-rw-r--r--sysutils/vobcopy/distinfo6
-rw-r--r--sysutils/vobcopy/files/patch-vobcopy.c11
-rw-r--r--sysutils/vobcopy/files/patch-vobcopy.h43
4 files changed, 66 insertions, 5 deletions
diff --git a/sysutils/vobcopy/Makefile b/sysutils/vobcopy/Makefile
index 8ffa1e0d454f..247eb260dfa5 100644
--- a/sysutils/vobcopy/Makefile
+++ b/sysutils/vobcopy/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= vobcopy
-PORTVERSION= 0.5.14
-PORTREVISION= 1
+PORTVERSION= 0.5.16
CATEGORIES= sysutils
MASTER_SITES= http://lpn.rnbhq.org/download/
@@ -20,6 +19,7 @@ USE_BZIP2= yes
USE_GETOPT_LONG= yes
HAS_CONFIGURE= yes
CONFIGURE_SCRIPT= configure.sh
+CONFIGURE_ARGS= --with-lfs
USE_REINPLACE= yes
ALL_TARGET= ${PORTNAME}
@@ -32,6 +32,9 @@ PORTDOCS= COPYING Changelog README Release-Notes TODO \
.include <bsd.port.pre.mk>
+post-extract:
+ @${CHMOD} a+x ${WRKSRC}/${CONFIGURE_SCRIPT}
+
post-patch:
@${REINPLACE_CMD} -E -e 's|(fopen\("/etc/)mtab|\1fstab|; \
s|iso9660|cd9660|' ${WRKSRC}/dvd.c
@@ -53,6 +56,10 @@ post-patch:
@${REINPLACE_CMD} -E \
-e 's|FreeBSD_Version|FreeBSD_version|' \
${WRKSRC}/dvd.c
+# no such flag under FreeBSD
+ @${REINPLACE_CMD} -E \
+ -e 's|O_LARGEFILE|0|' \
+ ${WRKSRC}/vobcopy.c
post-configure:
@${REINPLACE_CMD} -E -e 's|^CC.+||; s|^PREFIX.+||; \
diff --git a/sysutils/vobcopy/distinfo b/sysutils/vobcopy/distinfo
index 6874c5d7d93d..324b29e532ba 100644
--- a/sysutils/vobcopy/distinfo
+++ b/sysutils/vobcopy/distinfo
@@ -1,3 +1,3 @@
-MD5 (vobcopy-0.5.14.tar.bz2) = 840f3380376f553666b0d959defe0b6c
-SHA256 (vobcopy-0.5.14.tar.bz2) = b6e2da6ff974280438b9bf5cf8ee88290859705b731d99e68bfd94d6ea92765e
-SIZE (vobcopy-0.5.14.tar.bz2) = 41327
+MD5 (vobcopy-0.5.16.tar.bz2) = d23bcd74b0a5dceb80be7bf169478c5e
+SHA256 (vobcopy-0.5.16.tar.bz2) = b764daf6e637e11dff9f5cdadaa31f6c533844e6d71ae6fa20c70665e25daa95
+SIZE (vobcopy-0.5.16.tar.bz2) = 39117
diff --git a/sysutils/vobcopy/files/patch-vobcopy.c b/sysutils/vobcopy/files/patch-vobcopy.c
new file mode 100644
index 000000000000..92b844b15974
--- /dev/null
+++ b/sysutils/vobcopy/files/patch-vobcopy.c
@@ -0,0 +1,11 @@
+--- vobcopy.c.orig Fri Jan 6 23:49:40 2006
++++ vobcopy.c Fri Jan 6 23:50:03 2006
+@@ -146,6 +146,8 @@
+ #endif
+
+
++ /* initialize string */
++ dvd_path[0] = '\0';
+
+ /*
+ * the getopt part (getting the options from command line)
diff --git a/sysutils/vobcopy/files/patch-vobcopy.h b/sysutils/vobcopy/files/patch-vobcopy.h
new file mode 100644
index 000000000000..18bb1717c93d
--- /dev/null
+++ b/sysutils/vobcopy/files/patch-vobcopy.h
@@ -0,0 +1,43 @@
+--- vobcopy.h.orig Fri Jan 6 23:22:11 2006
++++ vobcopy.h Fri Jan 6 23:34:11 2006
+@@ -67,24 +67,33 @@
+ /* ////////// *BSD ////////// */
+ #if ( defined( BSD ) && ( BSD >= 199306 ) )
+
+-# if !defined( __NetBSD__ ) ) || \
+- ( defined( __NetBSD__) && ( __NetBSD_Version__ < 200040000 ) )
+-#include <sys/mount.h>
+-#define USE_STATFS 1
++# if ( defined( __NetBSD__) && ( __NetBSD_Version__ < 200040000 ) ) || \
++ ( defined( __FreeBSD__) && \
++ ( ((__FreeBSD_version >= 460102 ) && (__FreeBSD_version < 500000)) || \
++ ( __FreeBSD_version >= 500040) \
++ ) \
++ )
++#include <sys/statvfs.h>
+
+ # else
+
+-#include <sys/statvfs.h>
++#include <sys/mount.h>
++#define USE_STATFS 1
+
+ # endif
+
+-# if defined(NetBSD)
++# if defined(__NetBSD__) || defined(__FreeBSD__)
+
+ #include <sys/param.h>
+
+ #define USE_GETMNTINFO
+
+-# if ( __NetBSD_Version__ < 200040000 )
++# if (defined( __NetBSD__ ) && ( __NetBSD_Version__ < 200040000 )) || \
++ ( defined( __FreeBSD__) && \
++ ( ((__FreeBSD_version >= 460102 ) && (__FreeBSD_version < 500000)) || \
++ ( __FreeBSD_version >= 500040) \
++ ) \
++ )
+
+ #include <sys/mount.h>
+ #define USE_STATFS_FOR_DEV