aboutsummaryrefslogtreecommitdiff
path: root/sysutils/whatpix
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2003-02-05 11:36:13 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2003-02-05 11:36:13 +0000
commite6ef3a7589e3cd0116237aac21548402d885fc9a (patch)
treebf5d2593f40291a3c8ffa21586a2136327863aac /sysutils/whatpix
parent75151ef0f9e4ed9fe982b3e0943e6445b3c7104f (diff)
downloadports-e6ef3a7589e3cd0116237aac21548402d885fc9a.tar.gz
ports-e6ef3a7589e3cd0116237aac21548402d885fc9a.zip
New port: whatpix
a perl apps to find, moves or deletes duplicate files. PR: ports/41480 Submitted by: Philippe CASIDY <pcasidy@casidy.com>
Notes
Notes: svn path=/head/; revision=74842
Diffstat (limited to 'sysutils/whatpix')
-rw-r--r--sysutils/whatpix/Makefile24
-rw-r--r--sysutils/whatpix/distinfo1
-rw-r--r--sysutils/whatpix/files/patch-whatpix53
-rw-r--r--sysutils/whatpix/pkg-comment1
-rw-r--r--sysutils/whatpix/pkg-descr11
-rw-r--r--sysutils/whatpix/pkg-plist1
6 files changed, 91 insertions, 0 deletions
diff --git a/sysutils/whatpix/Makefile b/sysutils/whatpix/Makefile
new file mode 100644
index 000000000000..9abb71825606
--- /dev/null
+++ b/sysutils/whatpix/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: mtf
+# Date created: 02 June 2002
+# Whom: Philippe Casidy <pcasidy@casidy.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= whatpix
+PORTVERSION= 1.2
+CATEGORIES= sysutils
+MASTER_SITES= http://whatpix.sourceforge.net/download/
+
+MAINTAINER= pcasidy@casidy.com
+
+RUN_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5 \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/Digest/SHA1.pm:${PORTSDIR}/security/p5-Digest-SHA1
+
+NO_BUILD= yes
+USE_PERL5_RUN= yes
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/whatpix ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/sysutils/whatpix/distinfo b/sysutils/whatpix/distinfo
new file mode 100644
index 000000000000..aa07645e1f0a
--- /dev/null
+++ b/sysutils/whatpix/distinfo
@@ -0,0 +1 @@
+MD5 (whatpix-1.2.tar.gz) = 541bf06404dee568ade0e4a63dbc1d30
diff --git a/sysutils/whatpix/files/patch-whatpix b/sysutils/whatpix/files/patch-whatpix
new file mode 100644
index 000000000000..1e154e812370
--- /dev/null
+++ b/sysutils/whatpix/files/patch-whatpix
@@ -0,0 +1,53 @@
+*** whatpix.ori Fri Aug 9 13:43:49 2002
+--- whatpix Fri Aug 9 13:44:49 2002
+***************
+*** 236,242 ****
+ print " ", $dir, "\n";
+
+ # Get list of subdirectories.
+! opendir(DIR, $dir) or die "Error: opendir() failed on $dir\n";
+ my @dirs = grep { -d "$dir/$_" } readdir(DIR);
+ closedir(DIR);
+
+--- 236,242 ----
+ print " ", $dir, "\n";
+
+ # Get list of subdirectories.
+! opendir(DIR, "$dir\0") or die "Error: opendir() failed on $dir\n";
+ my @dirs = grep { -d "$dir/$_" } readdir(DIR);
+ closedir(DIR);
+
+***************
+*** 246,252 ****
+ }
+
+ # Now do the files in this directory.
+! opendir(DIR, $dir) || die "Error: failed to open $dir: $!";
+ my @files = grep { -r "$dir/$_" && -s "$dir/$_" } readdir(DIR);
+ closedir(DIR);
+ my $digester = $usemd5 ? Digest::MD5->new() : Digest::SHA1->new();
+--- 246,252 ----
+ }
+
+ # Now do the files in this directory.
+! opendir(DIR, "$dir\0") || die "Error: failed to open $dir: $!";
+ my @files = grep { -r "$dir/$_" && -s "$dir/$_" } readdir(DIR);
+ closedir(DIR);
+ my $digester = $usemd5 ? Digest::MD5->new() : Digest::SHA1->new();
+***************
+*** 256,262 ****
+ my @vars = stat($filename) or die "Error: could not stat $filename\n";
+ my $size = $vars[7];
+ if ($size) {
+! open(FILE, $filename) or die "Error: could not open $filename\n";
+ binmode(FILE);
+ $digester->reset;
+ $digester->addfile(*FILE);
+--- 256,262 ----
+ my @vars = stat($filename) or die "Error: could not stat $filename\n";
+ my $size = $vars[7];
+ if ($size) {
+! open(FILE, "$filename\0") or die "Error: could not open $filename\n";
+ binmode(FILE);
+ $digester->reset;
+ $digester->addfile(*FILE);
diff --git a/sysutils/whatpix/pkg-comment b/sysutils/whatpix/pkg-comment
new file mode 100644
index 000000000000..899efa493bc4
--- /dev/null
+++ b/sysutils/whatpix/pkg-comment
@@ -0,0 +1 @@
+Perl console application which finds, moves or deletes duplicate files
diff --git a/sysutils/whatpix/pkg-descr b/sysutils/whatpix/pkg-descr
new file mode 100644
index 000000000000..7e0ea866b177
--- /dev/null
+++ b/sysutils/whatpix/pkg-descr
@@ -0,0 +1,11 @@
+whatpix is a GPL Perl console application which finds and optionally moves or
+deletes duplicate files.
+
+whatpix was originally written by codex@bogus.net. The original web site for
+whatpix is http://www.bogus.net/~codex/ You can find versions prior to 1.0
+there.
+
+whatpix is currently being developed and maintained by 3Jane Tessier-Ashpool
+and Gerard Lanois.
+
+WWW: http://whatpix.sourceforge.net/
diff --git a/sysutils/whatpix/pkg-plist b/sysutils/whatpix/pkg-plist
new file mode 100644
index 000000000000..a7359f6544cb
--- /dev/null
+++ b/sysutils/whatpix/pkg-plist
@@ -0,0 +1 @@
+bin/whatpix