aboutsummaryrefslogtreecommitdiff
path: root/sysutils/wuzzah
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2005-09-08 11:14:39 +0000
committerRenato Botelho <garga@FreeBSD.org>2005-09-08 11:14:39 +0000
commit0f31031a54e8ff2224a6afd2b2fa28629483e558 (patch)
treef58a0072561ad6ba00424c11ff0b555f358f0d50 /sysutils/wuzzah
parent7b64bbe33007cbbcfcc619022ecf966bb3ef26ab (diff)
downloadports-0f31031a54e8ff2224a6afd2b2fa28629483e558.tar.gz
ports-0f31031a54e8ff2224a6afd2b2fa28629483e558.zip
Add wuzzah 0.53, a command line utility for stalking users.
PR: ports/85860 Submitted by: Emanuel Haupt <ehaupt@critical.ch>
Notes
Notes: svn path=/head/; revision=142213
Diffstat (limited to 'sysutils/wuzzah')
-rw-r--r--sysutils/wuzzah/Makefile31
-rw-r--r--sysutils/wuzzah/distinfo2
-rw-r--r--sysutils/wuzzah/pkg-descr8
3 files changed, 41 insertions, 0 deletions
diff --git a/sysutils/wuzzah/Makefile b/sysutils/wuzzah/Makefile
new file mode 100644
index 000000000000..675ece1bf27f
--- /dev/null
+++ b/sysutils/wuzzah/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: wuzzah
+# Date created: 8 Sep 2005
+# Whom: Emanuel Haupt <ehaupt@critical.ch>
+#
+# $FreeBSD$
+#
+
+PORTNAME= wuzzah
+PORTVERSION= 0.53
+CATEGORIES= sysutils
+MASTER_SITES= http://critical.ch/distfiles/
+
+MAINTAINER= ehaupt@critical.ch
+COMMENT= A command line utility for stalking users
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_REINPLACE= yes
+
+PLIST_FILES= bin/wuzzah
+MAN1= wuzzah.1
+
+post-patch:
+ @${REINPLACE_CMD} -e '/^CFLAGS/d' \
+ ${WRKSRC}/Makefile.in
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/man/${PORTNAME}.1 ${MANPREFIX}/man/man1
+
+.include <bsd.port.mk>
diff --git a/sysutils/wuzzah/distinfo b/sysutils/wuzzah/distinfo
new file mode 100644
index 000000000000..126fa2e0a110
--- /dev/null
+++ b/sysutils/wuzzah/distinfo
@@ -0,0 +1,2 @@
+MD5 (wuzzah-0.53.tar.gz) = 47436e575bc637a8af816a0af3fb1e54
+SIZE (wuzzah-0.53.tar.gz) = 88128
diff --git a/sysutils/wuzzah/pkg-descr b/sysutils/wuzzah/pkg-descr
new file mode 100644
index 000000000000..d96dc0098adc
--- /dev/null
+++ b/sysutils/wuzzah/pkg-descr
@@ -0,0 +1,8 @@
+Wuzzah is a command-line utility that selectively scans a systems utmpx records
+keeping an eye out for your friends logging in and out. Wuzzah is small, fast,
+efficient and written in C.
+
+WWW: http://www.cs.swarthmore.edu/~finney/proj/wuzzah/
+
+- ehaupt
+ehaupt@critical.ch