aboutsummaryrefslogtreecommitdiff
path: root/sysutils/xcpustate
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-06-28 11:51:05 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-06-28 11:51:05 +0000
commit932db7c46c9a269808dfa67ea02746b350c194d8 (patch)
tree5182ef394eeef9bff78abf27f4a3a05f7fb8ff43 /sysutils/xcpustate
parentb9b5e71f19dfde1a969d42e0660cc786432b3500 (diff)
downloadports-932db7c46c9a269808dfa67ea02746b350c194d8.tar.gz
ports-932db7c46c9a269808dfa67ea02746b350c194d8.zip
New USES imake to handle the dependency on imake.
This uses accept 'env' as an argument for ports that do use their own or a different do-configure target. Modify xmkmf so it accept IMAKECPPFLAGS as default flags for imake and pass it to the called imake. Modify xorg-cf-files (the FreeBSD.cf configuration file) to allow CppCmd to be overwritten. Pass CppCmd CcCmd and CplusplusCmd via command line to each call of imake via IMAKECPPFLAGS Pass IMAKE_DEFINE with the above arguments to MAKE_ARGS so that imake spawned from Makefile generated by a previous imake also inherit the defined CppCmd CcCmd and CplusplusCmd. Make imake use devel/tradcpp all the time, so that when buidling with clang we do not depend on gcc's cpp. Make imake respect CC and CXX Make imake respect USE_GCC (if set imake will use gcc's cpp). While here: - Remove a couple of indefinite articles from comments - Trim headers - Fix a couple of ports to build with clang or use: USE_GCC=any - Fix a now useless redefinition of the extraction chain - Fix a typo in japanese/Wnn7-lib bundled imake template definitions - Fix some XMKMF execution with no env specified - Use options helper in x11/xautolock to simplify the port
Notes
Notes: svn path=/head/; revision=321957
Diffstat (limited to 'sysutils/xcpustate')
-rw-r--r--sysutils/xcpustate/Makefile13
1 files changed, 4 insertions, 9 deletions
diff --git a/sysutils/xcpustate/Makefile b/sysutils/xcpustate/Makefile
index 51289426f974..d61be323f66a 100644
--- a/sysutils/xcpustate/Makefile
+++ b/sysutils/xcpustate/Makefile
@@ -1,10 +1,5 @@
-# ex:ts=8
-# Ports collection makefile for: xcpustate
-# Date created: 31-Dec-1995
-# Whom: David O'Brien <obrien@cs.ucdavis.edu>
-#
+# Created by: David O'Brien <obrien@cs.ucdavis.edu>
# $FreeBSD$
-#
PORTNAME= xcpustate
PORTVERSION= 2.9
@@ -16,14 +11,14 @@ EXTRACT_SUFX= .shar
MAINTAINER= ports@FreeBSD.org
COMMENT= System monitoring utility graphically showing cpu load and status
-EXTRACT_CMD= ${CAT}
+EXTRACT_CMD= ${SH}
EXTRACT_BEFORE_ARGS= # none
-EXTRACT_AFTER_ARGS= | ${SH}
+EXTRACT_AFTER_ARGS= # none
NO_WRKSUBDIR= yes
+USES= imake
USE_XORG= ice sm x11 xaw xext xmu xt
-USE_IMAKE= yes
MAN1= ${PORTNAME}.1
PLIST_FILES= bin/${PORTNAME}