aboutsummaryrefslogtreecommitdiff
path: root/sysutils/xfce4-bsdcpufreq-plugin
diff options
context:
space:
mode:
authorThomas Zander <riggs@FreeBSD.org>2014-07-28 17:26:23 +0000
committerThomas Zander <riggs@FreeBSD.org>2014-07-28 17:26:23 +0000
commitc102937c0af1404c9ca0cc7df98d858b93538aef (patch)
treebc2f9ab1f4f77216582aace813b9752ebb86b4e9 /sysutils/xfce4-bsdcpufreq-plugin
parent66b39c4b56ce4559aed8be66a4953bd8ce2bb3de (diff)
downloadports-c102937c0af1404c9ca0cc7df98d858b93538aef.tar.gz
ports-c102937c0af1404c9ca0cc7df98d858b93538aef.zip
Import xfce4-bsdcpufreq-plugin,
a tiny panel plugin for the XFCE desktop to monitor the CPU clock frequency Approved by: mentors (implicit)
Notes
Notes: svn path=/head/; revision=363201
Diffstat (limited to 'sysutils/xfce4-bsdcpufreq-plugin')
-rw-r--r--sysutils/xfce4-bsdcpufreq-plugin/Makefile37
-rw-r--r--sysutils/xfce4-bsdcpufreq-plugin/distinfo2
-rw-r--r--sysutils/xfce4-bsdcpufreq-plugin/pkg-descr3
3 files changed, 42 insertions, 0 deletions
diff --git a/sysutils/xfce4-bsdcpufreq-plugin/Makefile b/sysutils/xfce4-bsdcpufreq-plugin/Makefile
new file mode 100644
index 000000000000..39f6cbdc7707
--- /dev/null
+++ b/sysutils/xfce4-bsdcpufreq-plugin/Makefile
@@ -0,0 +1,37 @@
+# Created by: Thomas Zander <riggs@FreeBSD.org>
+# $FreeBSD$
+#
+
+PORTNAME= xfce4-bsdcpufreq-plugin
+PORTVERSION= 0.1.1
+CATEGORIES= sysutils xfce
+
+MAINTAINER= riggs@FreeBSD.org
+COMMENT= Displays the current CPU clock frequency in the panel
+
+LICENSE= BSD2CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USE_GITHUB= yes
+GH_ACCOUNT= riggs-
+GH_COMMIT= 66ef781
+GH_TAGNAME= ${GH_COMMIT}
+
+USE_GNOME= gtk20
+
+USES= pkgconfig
+
+LIB_DEPENDS+= libxfce4util.so:${PORTSDIR}/x11/libxfce4util \
+ libxfce4panel-1.0.so:${PORTSDIR}/x11-wm/xfce4-panel \
+ libxfce4ui-1.so:${PORTSDIR}/x11/libxfce4menu
+
+PLIST_FILES= lib/xfce4/panel/plugins/libbsdcpufreq.so \
+ share/xfce4/panel/plugins/bsdcpufreq.desktop
+
+do-install:
+ ${MKDIR} ${STAGEDIR}${PREFIX}/lib/xfce4/panel/plugins
+ ${MKDIR} ${STAGEDIR}${PREFIX}/share/xfce4/panel/plugins
+ ${INSTALL_LIB} ${WRKSRC}/libbsdcpufreq.so ${STAGEDIR}${PREFIX}/lib/xfce4/panel/plugins
+ ${INSTALL_DATA} ${WRKSRC}/bsdcpufreq.desktop ${STAGEDIR}${PREFIX}/share/xfce4/panel/plugins
+
+.include <bsd.port.mk>
diff --git a/sysutils/xfce4-bsdcpufreq-plugin/distinfo b/sysutils/xfce4-bsdcpufreq-plugin/distinfo
new file mode 100644
index 000000000000..c0504d0f0e7f
--- /dev/null
+++ b/sysutils/xfce4-bsdcpufreq-plugin/distinfo
@@ -0,0 +1,2 @@
+SHA256 (xfce4-bsdcpufreq-plugin-0.1.1.tar.gz) = 3f992c56167de1173aacc3a3812b6a1dc233bbd403bd9acc351862998d1eff3a
+SIZE (xfce4-bsdcpufreq-plugin-0.1.1.tar.gz) = 5737
diff --git a/sysutils/xfce4-bsdcpufreq-plugin/pkg-descr b/sysutils/xfce4-bsdcpufreq-plugin/pkg-descr
new file mode 100644
index 000000000000..98389e336697
--- /dev/null
+++ b/sysutils/xfce4-bsdcpufreq-plugin/pkg-descr
@@ -0,0 +1,3 @@
+xfce4-bsdcpufreq-plugin uses the FreeBSD sysctl
+interface to the cpufreq(4) driver to display the
+current CPU frequency in an XFCE panel.