aboutsummaryrefslogtreecommitdiff
path: root/sysutils/xfce4-diskperf-plugin/Makefile
diff options
context:
space:
mode:
authorGuido Falsi <madpilot@FreeBSD.org>2023-10-02 15:53:42 +0000
committerGuido Falsi <madpilot@FreeBSD.org>2023-10-02 15:53:42 +0000
commit0afc8661e4a56c97828d88575c4bf3e7f7d3a768 (patch)
tree8f8ff61729ff38aa7528ad430a49ae43d9872cd0 /sysutils/xfce4-diskperf-plugin/Makefile
parentaf63ff37c2457920d55e79b3a612d1dc21174e43 (diff)
downloadports-0afc8661e4a56c97828d88575c4bf3e7f7d3a768.tar.gz
ports-0afc8661e4a56c97828d88575c4bf3e7f7d3a768.zip
XFCE: Cleanup dependencies
- Update xfce.mk to avid forcing too many dependencies on consumers - Change dependency on garcon to reference libgarcon-1.so (main library) - Explicitly add USE_XFCE components to the ports actually needing them. - Cleanup dependencies, adding/removing missing/extra dependencies - Change the referenced library in some LIB_DEPENDS to the actually linked one (avoids false positives in poudriere Q/A tests) - Bump PORTREVISION on all touched ports, even indirectly due to the effect of removing forced dependencies on certain components - Remove USES=fuse from gigolo. I could not find any kind f reference to fuse in the code. - xfce4-bsdcpufreq-plugin: Also remove empty comment at the top of the Makefile
Diffstat (limited to 'sysutils/xfce4-diskperf-plugin/Makefile')
-rw-r--r--sysutils/xfce4-diskperf-plugin/Makefile8
1 files changed, 5 insertions, 3 deletions
diff --git a/sysutils/xfce4-diskperf-plugin/Makefile b/sysutils/xfce4-diskperf-plugin/Makefile
index 3a3149f337ab..d4914264f77c 100644
--- a/sysutils/xfce4-diskperf-plugin/Makefile
+++ b/sysutils/xfce4-diskperf-plugin/Makefile
@@ -1,6 +1,6 @@
PORTNAME= xfce4-diskperf-plugin
PORTVERSION= 2.7.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= sysutils xfce
MASTER_SITES= XFCE/panel-plugins
DIST_SUBDIR= xfce4
@@ -12,10 +12,12 @@ WWW= https://goodies.xfce.org/projects/panel-plugins/xfce4-diskperf-plugin
LICENSE= BSD2CLAUSE
LICENSE_FILE= ${WRKSRC}/COPYING
+LIB_DEPENDS= libharfbuzz.so:print/harfbuzz
+
USES= compiler:c11 gettext-tools gnome gmake libtool pkgconfig \
tar:bzip2 xfce
-USE_GNOME= cairo gtk30 intltool
-USE_XFCE= panel
+USE_GNOME= cairo gdkpixbuf2 gtk30 intltool
+USE_XFCE= libmenu panel
GNU_CONFIGURE= yes
INSTALL_TARGET= install-strip