aboutsummaryrefslogtreecommitdiff
path: root/sysutils/xfce4-fsguard-plugin/Makefile
diff options
context:
space:
mode:
authorOlivier Duchateau <olivierd@FreeBSD.org>2012-08-12 09:13:44 +0000
committerOlivier Duchateau <olivierd@FreeBSD.org>2012-08-12 09:13:44 +0000
commit3c39b8edb5ba2f8edaa9069ae8c9908a9f1ade1d (patch)
treed37f2e262f4449d496780cc7f918bcf691fd2805 /sysutils/xfce4-fsguard-plugin/Makefile
parent11d227f84c070e3585bdf925620198d3ba08a967 (diff)
downloadports-3c39b8edb5ba2f8edaa9069ae8c9908a9f1ade1d.tar.gz
ports-3c39b8edb5ba2f8edaa9069ae8c9908a9f1ade1d.zip
- Update to 1.0.1
- Use USE_PKGCONFIG macro - Convert to new framework OptionsNG Submitted by: myself Approved by: rene, miwi (mentors)
Notes
Notes: svn path=/head/; revision=302429
Diffstat (limited to 'sysutils/xfce4-fsguard-plugin/Makefile')
-rw-r--r--sysutils/xfce4-fsguard-plugin/Makefile23
1 files changed, 13 insertions, 10 deletions
diff --git a/sysutils/xfce4-fsguard-plugin/Makefile b/sysutils/xfce4-fsguard-plugin/Makefile
index bdc99a639fe1..90e6f32b4234 100644
--- a/sysutils/xfce4-fsguard-plugin/Makefile
+++ b/sysutils/xfce4-fsguard-plugin/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= xfce4-fsguard-plugin
-PORTVERSION= 1.0.0
-PORTREVISION= 3
+PORTVERSION= 1.0.1
CATEGORIES= sysutils xfce
MASTER_SITES= ${MASTER_SITE_XFCE}
MASTER_SITE_SUBDIR= src/panel-plugins/${PORTNAME}/${PORTVERSION:R}
@@ -20,17 +19,16 @@ GNU_CONFIGURE= yes
USE_BZIP2= yes
INSTALLS_ICONS= yes
USE_GMAKE= yes
-USE_GNOME= gnomehack gtk20 intltool intlhack pkgconfig
-USE_XFCE= configenv libgui libutil panel
+USE_GNOME= gnomehack gtk20 intltool intlhack
+USE_XFCE= configenv libmenu libutil panel
USE_XORG= x11
+USE_PKGCONFIG= build
-CONFIGURE_ARGS= --disable-debug
+OPTIONS_DEFINE= NLS
-OPTIONS= NLS "Enable Native Language Support" on
+.include <bsd.port.options.mk>
-.include <bsd.port.pre.mk>
-
-.if !defined(WITHOUT_NLS)
+.if ${PORT_OPTIONS:MNLS}
USE_GETTEXT= yes
CONFIGURE_ARGS+=--enable-nls
PLIST_SUB+= NLS=""
@@ -39,4 +37,9 @@ CONFIGURE_ARGS+=--disable-nls
PLIST_SUB+= NLS="@comment "
.endif
-.include <bsd.port.post.mk>
+post-patch:
+.if empty(PORT_OPTIONS:MNLS)
+ @${REINPLACE_CMD} -e 's| po||' ${WRKSRC}/Makefile.in
+.endif
+
+.include <bsd.port.mk>