aboutsummaryrefslogtreecommitdiff
path: root/sysutils/xfce4-fsguard-plugin/Makefile
diff options
context:
space:
mode:
authorGuido Falsi <madpilot@FreeBSD.org>2019-01-22 14:44:38 +0000
committerGuido Falsi <madpilot@FreeBSD.org>2019-01-22 14:44:38 +0000
commit41ff4e536e680bc94d0949bc7708ddfe6f5646a7 (patch)
tree0b87a1825693d30844e1b681ab080746ab147896 /sysutils/xfce4-fsguard-plugin/Makefile
parentec5f7eb8bb72b6cf44e7b35905514df560d5f22b (diff)
downloadports-41ff4e536e680bc94d0949bc7708ddfe6f5646a7.tar.gz
ports-41ff4e536e680bc94d0949bc7708ddfe6f5646a7.zip
Clenup xfce ports:
- Add missing dependencies - Remove unneeded patches - Regenerate and rename legacy patches - Add NLS option to ports providing such a knob, and missing the option - Add INSTALL_TARGET=install-strip where missing - Sort things - Remove unneeded += - Cosmetic changes to OPTION related variables to improve readability - Update WWW - Silence portlint warnings about variables order - Bump PORTREVISION where changing dependencies and/or adding install-strip
Notes
Notes: svn path=/head/; revision=490953
Diffstat (limited to 'sysutils/xfce4-fsguard-plugin/Makefile')
-rw-r--r--sysutils/xfce4-fsguard-plugin/Makefile19
1 files changed, 9 insertions, 10 deletions
diff --git a/sysutils/xfce4-fsguard-plugin/Makefile b/sysutils/xfce4-fsguard-plugin/Makefile
index 0d5fe87a0914..4b6aa4550eba 100644
--- a/sysutils/xfce4-fsguard-plugin/Makefile
+++ b/sysutils/xfce4-fsguard-plugin/Makefile
@@ -13,20 +13,19 @@ COMMENT= Panel plugin which displays free space of mountpoint
# COPYING file is wrong compared to license header
LICENSE= BSD2CLAUSE
+USES= gettext-tools gmake gnome libtool pkgconfig tar:bzip2 xfce:gtk3
+USE_GNOME= cairo gtk30 intltool
+USE_XFCE= panel
+USE_XORG= x11
+
GNU_CONFIGURE= yes
INSTALLS_ICONS= yes
INSTALL_TARGET= install-strip
-USES= gettext-tools gmake libtool pkgconfig tar:bzip2 xfce:gtk3
-USE_GNOME= gtk30 intltool cairo
-USE_XFCE= panel
-USE_XORG= x11
-OPTIONS_DEFINE= NLS
-NLS_USES= gettext-runtime
-NLS_CONFIGURE_ENABLE= nls
-OPTIONS_SUB= yes
+OPTIONS_DEFINE= NLS
+OPTIONS_SUB= yes
-post-patch-NLS-off:
- @${REINPLACE_CMD} -e 's| po||' ${WRKSRC}/Makefile.in
+NLS_CONFIGURE_ENABLE= nls
+NLS_USES= gettext-runtime
.include <bsd.port.mk>