aboutsummaryrefslogtreecommitdiff
path: root/sysutils/zeitgeist
diff options
context:
space:
mode:
authorDon Lewis <truckman@FreeBSD.org>2018-01-24 07:20:10 +0000
committerDon Lewis <truckman@FreeBSD.org>2018-01-24 07:20:10 +0000
commit62b124f601e3f722738d37c55daa88bf921c527d (patch)
tree6e9b8bfd4cf7e228bd72f08e4a797e40ce0a30a8 /sysutils/zeitgeist
parent92dfcf9c2e44583164857cbea5c396f16fd1dfbb (diff)
downloadports-62b124f601e3f722738d37c55daa88bf921c527d.tar.gz
ports-62b124f601e3f722738d37c55daa88bf921c527d.zip
Add USE_LDCONFIG
Add TIMESTAMP Fix build with vala 0.36 Update WWW in pkg-descr Pet portlint PR: 222033, 221941 Submitted by: cpm Approved by: maintainer timeout (13 weeks)
Notes
Notes: svn path=/head/; revision=459819
Diffstat (limited to 'sysutils/zeitgeist')
-rw-r--r--sysutils/zeitgeist/Makefile4
-rw-r--r--sysutils/zeitgeist/distinfo1
-rw-r--r--sysutils/zeitgeist/files/patch-libzeitgeist_timestamp.vala12
-rw-r--r--sysutils/zeitgeist/files/patch-libzeitgeist_where-clause.vala11
-rw-r--r--sysutils/zeitgeist/pkg-descr2
5 files changed, 28 insertions, 2 deletions
diff --git a/sysutils/zeitgeist/Makefile b/sysutils/zeitgeist/Makefile
index fcc803ebdd9a..7a4ce54d6b5c 100644
--- a/sysutils/zeitgeist/Makefile
+++ b/sysutils/zeitgeist/Makefile
@@ -4,6 +4,7 @@
PORTNAME= zeitgeist
PORTVERSION= 0.9.16
+PORTREVISION= 1
CATEGORIES= sysutils
MASTER_SITES= https://launchpad.net/${PORTNAME}/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/}/${PORTVERSION}/+download/
@@ -20,9 +21,10 @@ BUILD_DEPENDS= valac:lang/vala \
RUN_DEPENDS= ${PYTHON_SITELIBDIR}/xdg/__init__.py:devel/py-xdg@${PY_FLAVOR} \
${PYTHON_SITELIBDIR}/dbus/__init__.py:devel/py-dbus@${PY_FLAVOR}
+USES= gmake gettext pathfix python:2 pkgconfig libtool sqlite tar:xz
USE_GNOME= intlhack glib20 introspection:build
+USE_LDCONFIG= yes
GNU_CONFIGURE= yes
-USES= gmake gettext pathfix python:2 pkgconfig libtool sqlite tar:xz
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
INSTALL_TARGET= install-strip
diff --git a/sysutils/zeitgeist/distinfo b/sysutils/zeitgeist/distinfo
index 21e840bcd54f..150ccca507e5 100644
--- a/sysutils/zeitgeist/distinfo
+++ b/sysutils/zeitgeist/distinfo
@@ -1,2 +1,3 @@
+TIMESTAMP = 1509207424
SHA256 (zeitgeist-0.9.16.tar.xz) = 6ed3e60d0cd82ea58ee134c19beccafac10eb0f71977f3848755dacbf0927d3a
SIZE (zeitgeist-0.9.16.tar.xz) = 807092
diff --git a/sysutils/zeitgeist/files/patch-libzeitgeist_timestamp.vala b/sysutils/zeitgeist/files/patch-libzeitgeist_timestamp.vala
new file mode 100644
index 000000000000..fca0b79a5324
--- /dev/null
+++ b/sysutils/zeitgeist/files/patch-libzeitgeist_timestamp.vala
@@ -0,0 +1,12 @@
+--- libzeitgeist/timestamp.vala.orig 2014-07-03 07:46:47 UTC
++++ libzeitgeist/timestamp.vala
+@@ -76,8 +76,7 @@ namespace Zeitgeist.Timestamp
+ */
+ public int64 from_timeval (TimeVal timeval)
+ {
+- var m_seconds = (int64) (timeval.tv_sec) * 1000;
+- return m_seconds + ((int64) timeval.tv_usec / 1000);
++ return timeval.tv_sec * 1000 + timeval.tv_usec / 1000;
+ }
+
+ /**
diff --git a/sysutils/zeitgeist/files/patch-libzeitgeist_where-clause.vala b/sysutils/zeitgeist/files/patch-libzeitgeist_where-clause.vala
new file mode 100644
index 000000000000..8cce98b9c50a
--- /dev/null
+++ b/sysutils/zeitgeist/files/patch-libzeitgeist_where-clause.vala
@@ -0,0 +1,11 @@
+--- libzeitgeist/where-clause.vala.orig 2017-09-03 19:29:23 UTC
++++ libzeitgeist/where-clause.vala
+@@ -217,7 +217,7 @@ namespace Zeitgeist
+ long[] pointers = new long[gptrarr.length + 1];
+ #endif
+ Memory.copy(pointers, ((PtrArray *) gptrarr)->pdata,
+- (gptrarr.length) * sizeof (void *));
++ gptrarr.length * sizeof (void *));
+ return (T[]) pointers;
+ }
+
diff --git a/sysutils/zeitgeist/pkg-descr b/sysutils/zeitgeist/pkg-descr
index f55fa36c4613..4447186f1e1f 100644
--- a/sysutils/zeitgeist/pkg-descr
+++ b/sysutils/zeitgeist/pkg-descr
@@ -3,4 +3,4 @@ Zeitgeist is a service which logs the users's activities and events
and makes relevant information available to other applications. It is able to
establish relationships between items based on similarity and usage patterns.
-WWW: http://zeitgeist-project.com
+WWW: https://wiki.gnome.org/Projects/Zeitgeist