aboutsummaryrefslogtreecommitdiff
path: root/sysutils
diff options
context:
space:
mode:
authorTorsten Blum <torstenb@FreeBSD.org>2022-06-21 20:58:58 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-06-21 20:58:58 +0000
commit030111b816ead69e62d5243b845450bc9cce3457 (patch)
treeee0046a27d7dc61784d6cd25dfd15c10643c139b /sysutils
parent81d2af56be29daa64a3d29c79b76136a25f33394 (diff)
downloadports-030111b816ead69e62d5243b845450bc9cce3457.tar.gz
ports-030111b816ead69e62d5243b845450bc9cce3457.zip
sysutils/py-psutil: Fix failing __FreeBSD_version check
- Bump PORTREVISION for package change psutil 5.9.1 does not include <sys/param.h> in arch/freebsd/mem.c, causing the __FreeBSD_version check there not not work properly and thus breaking the port on systems without COMPAT_FREEBSD7. PR: 264807 Reference: https://github.com/giampaolo/psutil/issues/2113
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/py-psutil/Makefile1
-rw-r--r--sysutils/py-psutil/files/patch-psutil_arch_freebsd_mem.c10
2 files changed, 11 insertions, 0 deletions
diff --git a/sysutils/py-psutil/Makefile b/sysutils/py-psutil/Makefile
index a17f74b073d1..8722ee5280e3 100644
--- a/sysutils/py-psutil/Makefile
+++ b/sysutils/py-psutil/Makefile
@@ -2,6 +2,7 @@
PORTNAME= psutil
PORTVERSION= 5.9.1
+PORTREVISION= 1
CATEGORIES= sysutils python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
diff --git a/sysutils/py-psutil/files/patch-psutil_arch_freebsd_mem.c b/sysutils/py-psutil/files/patch-psutil_arch_freebsd_mem.c
new file mode 100644
index 000000000000..cbe44517b448
--- /dev/null
+++ b/sysutils/py-psutil/files/patch-psutil_arch_freebsd_mem.c
@@ -0,0 +1,10 @@
+--- psutil/arch/freebsd/mem.c.orig 2022-01-17 12:10:50 UTC
++++ psutil/arch/freebsd/mem.c
+@@ -6,6 +6,7 @@
+
+
+ #include <Python.h>
++#include <sys/param.h>
+ #include <sys/sysctl.h>
+ #include <sys/vmmeter.h>
+ #include <vm/vm_param.h>