aboutsummaryrefslogtreecommitdiff
path: root/sysutils
diff options
context:
space:
mode:
authorEmmanuel Vadot <manu@FreeBSD.org>2019-10-09 19:54:30 +0000
committerEmmanuel Vadot <manu@FreeBSD.org>2019-10-09 19:54:30 +0000
commit0ddcadab211273ad3474a88d9183eaa5e74e8c38 (patch)
treec8c7a22bdd3c985402b2a53ed2bffa5236e7c2b0 /sysutils
parent6fdc84fe2253dd389faed3e161ac4271f9c4433e (diff)
downloadports-0ddcadab211273ad3474a88d9183eaa5e74e8c38.tar.gz
ports-0ddcadab211273ad3474a88d9183eaa5e74e8c38.zip
sysutils/u-boot-rock64: Add two DRAM related patches
Add two new patches related to DRAM controller initialization. This allow us to use SPL+TPL from mainline u-boot and not relying on RockChip miniloader anymore. Thanks to jmcneill@NetBSD.Org for the tip.
Notes
Notes: svn path=/head/; revision=514189
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/u-boot-master/Makefile5
-rw-r--r--sysutils/u-boot-master/distinfo6
-rw-r--r--sysutils/u-boot-rock64/Makefile6
3 files changed, 10 insertions, 7 deletions
diff --git a/sysutils/u-boot-master/Makefile b/sysutils/u-boot-master/Makefile
index 322e084c1004..bdbd633ada22 100644
--- a/sysutils/u-boot-master/Makefile
+++ b/sysutils/u-boot-master/Makefile
@@ -151,7 +151,6 @@ MAKE_ENV+= BL31=${LOCALBASE}/share/atf-sun50i_a64/bl31.bin
.if defined(FAMILY) && ${FAMILY} == rk3328
BUILD_DEPENDS+= ${LOCALBASE}/share/atf-rk3328/bl31.elf:sysutils/atf-rk3328 \
- ${LOCALBASE}/share/linux-rkbin/bin/rk33/rk3328_ddr_333MHz_v1.16.bin:sysutils/linux-rkbin \
${PYTHON_PKGNAMEPREFIX}pyelftools>0:devel/py-pyelftools@${PY_FLAVOR}
MAKE_ENV+= BL31=${LOCALBASE}/share/atf-rk3328/bl31.elf
.endif
@@ -220,10 +219,6 @@ post-build:
(cd ${WRKSRC}; ${SETENV} ${CONFIGURE_ENV} ${MAKE_ENV} ${MAKE_CMD} ${MAKE_ARGS} ${i})
.endfor
.endif
-.if defined(FAMILY) && ${FAMILY} == rk3328
- mkimage -n rk3328 -T rksd -d ${LOCALBASE}/share/linux-rkbin/bin/rk33/rk3328_ddr_333MHz_v1.16.bin ${WRKSRC}/idbloader.img
- cat ${WRKSRC}/spl/u-boot-spl.bin >> ${WRKSRC}/idbloader.img
-.endif
# If we need to put anything into WRKSRC, do so now so we can build the PLIST
# in do-install
.if defined(UBOOT_MOVE)
diff --git a/sysutils/u-boot-master/distinfo b/sysutils/u-boot-master/distinfo
index 5b55fa1aaa91..4e60b392ae61 100644
--- a/sysutils/u-boot-master/distinfo
+++ b/sysutils/u-boot-master/distinfo
@@ -1,4 +1,4 @@
-TIMESTAMP = 1570557780
+TIMESTAMP = 1570649997
SHA256 (u-boot/u-boot-2019.10.tar.bz2) = 8d6d6070739522dd236cba7055b8736bfe92b4fac0ea18ad809829ca79667014
SIZE (u-boot/u-boot-2019.10.tar.bz2) = 14214608
SHA256 (u-boot/939129/raw) = 2a4ebf283aec8e74ec77b3cb071c6883f73807454ca94fea78361c7391187b97
@@ -7,3 +7,7 @@ SHA256 (u-boot/1036621/raw) = 28dbd66d14fab9dc782ce091d3c132a226b8425f6503c329ee
SIZE (u-boot/1036621/raw) = 480
SHA256 (u-boot/1173473/raw) = 4f182d6f99b1d868237607200d64a1d8a2d57ea44fc25ca49bce929ad6457228
SIZE (u-boot/1173473/raw) = 433
+SHA256 (u-boot/1172554/raw) = d1a39d7d6487cfb481392e7ea4f0bf0d209c08e0c3426c29d7eeaeb9b806cf42
+SIZE (u-boot/1172554/raw) = 640
+SHA256 (u-boot/1172555/raw) = 09d17a62fb6bc7c7ab73bfc7061fc5da2b5a32e7deb098c9f76aed8ff8991751
+SIZE (u-boot/1172555/raw) = 568
diff --git a/sysutils/u-boot-rock64/Makefile b/sysutils/u-boot-rock64/Makefile
index 65e623f23410..d3f2a3954568 100644
--- a/sysutils/u-boot-rock64/Makefile
+++ b/sysutils/u-boot-rock64/Makefile
@@ -2,7 +2,11 @@
MASTERDIR= ${.CURDIR}/../u-boot-master
-PATCHFILES+= 1173473/raw
+U_BOOT_SLAVE_PORTREVISION_2019.10= 1
+
+PATCHFILES+= 1173473/raw \
+ 1172554/raw \
+ 1172555/raw
MODEL= rock64
BOARD_CONFIG= rock64-rk3328_defconfig