aboutsummaryrefslogtreecommitdiff
path: root/sysutils
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-04-09 23:39:22 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-04-09 23:39:22 +0000
commit1296bd805b7dcab36aee74cc4213e1397a26bae4 (patch)
tree8d1222fe06b8e645de1a752a4d8bf8afd2fee756 /sysutils
parentdefa2e0c1c834a9818b1a35681c3e28d37f3b05c (diff)
downloadports-1296bd805b7dcab36aee74cc4213e1397a26bae4.tar.gz
ports-1296bd805b7dcab36aee74cc4213e1397a26bae4.zip
- Update to 0.8.3
PR: ports/79487 Submitted by: Kay Lehmann <kay_lehmann@web.de> (maintainer)
Notes
Notes: svn path=/head/; revision=132846
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/lineakd/Makefile3
-rw-r--r--sysutils/lineakd/distinfo4
-rw-r--r--sysutils/lineakd/files/patch-Makefile.in11
-rw-r--r--sysutils/lineakd/files/patch-lineak__defloader.cpp27
-rw-r--r--sysutils/lineakd/files/patch-lineakd__lineakd_core_functions.cpp31
-rw-r--r--sysutils/lineakd/files/patch-lineakd__main.cpp97
6 files changed, 119 insertions, 54 deletions
diff --git a/sysutils/lineakd/Makefile b/sysutils/lineakd/Makefile
index bb7cd39400b7..7e49ca8d59be 100644
--- a/sysutils/lineakd/Makefile
+++ b/sysutils/lineakd/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= lineakd
-PORTVERSION= 0.8.2
-PORTREVISION= 1
+PORTVERSION= 0.8.3
CATEGORIES= sysutils
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR=lineak
diff --git a/sysutils/lineakd/distinfo b/sysutils/lineakd/distinfo
index c998ea0740dd..391c1bca90c6 100644
--- a/sysutils/lineakd/distinfo
+++ b/sysutils/lineakd/distinfo
@@ -1,2 +1,2 @@
-MD5 (lineak/lineakd-0.8.2.tar.gz) = 86bae5018d5fcf349bb665779b1f068d
-SIZE (lineak/lineakd-0.8.2.tar.gz) = 830455
+MD5 (lineak/lineakd-0.8.3.tar.gz) = fc1d3add18afbb8e61b8277b89c525c6
+SIZE (lineak/lineakd-0.8.3.tar.gz) = 852158
diff --git a/sysutils/lineakd/files/patch-Makefile.in b/sysutils/lineakd/files/patch-Makefile.in
new file mode 100644
index 000000000000..d0e3b07785f4
--- /dev/null
+++ b/sysutils/lineakd/files/patch-Makefile.in
@@ -0,0 +1,11 @@
+--- Makefile.in.orig Sat Apr 2 18:31:49 2005
++++ Makefile.in Sat Apr 2 18:32:05 2005
+@@ -267,7 +267,7 @@
+ COMPILE_LAST = lineakd
+
+ ####### kdevelop will overwrite this part!!! (begin)##########
+-SUBDIRS = lineak lineakd utils
++SUBDIRS = lineak lineakd
+
+ EXTRA_DIST = lineakd.kdevprj admin AUTHORS COPYING ChangeLog INSTALL README TODO lineakd.lsm lineakd.spec lineakd-noarch.spec README_LINEAK_LIBRARY DIRECTIVES
+
diff --git a/sysutils/lineakd/files/patch-lineak__defloader.cpp b/sysutils/lineakd/files/patch-lineak__defloader.cpp
deleted file mode 100644
index 3523df58115e..000000000000
--- a/sysutils/lineakd/files/patch-lineak__defloader.cpp
+++ /dev/null
@@ -1,27 +0,0 @@
---- lineak/defloader.cpp.orig Tue Feb 15 18:28:46 2005
-+++ lineak/defloader.cpp Tue Feb 15 18:28:49 2005
-@@ -129,7 +129,7 @@
- // Handle empty lines.
- loc = tmp.find('=');
- // empty line
-- if (loc == string::npos)
-+ if (loc == (unsigned int)string::npos)
- continue;
-
- // key == the name of the key.
-@@ -157,13 +157,13 @@
- //cout << akey;
- /** Now determine if this is a toggleable key. We will have to parse
- the name format name1|name2 if indeed it is a toggleable key. */
-- if ((unsigned int)key.find('|') != string::npos) {
-+ if ((unsigned int)key.find('|') != (unsigned int)string::npos) {
- key+='|';
- akey->setToggle(true);
- int index;
- string tmp;
- //vector<string>names;
-- while (((unsigned int)(index = key.find('|'))) != string::npos) {
-+ while (((unsigned int)(index = key.find('|'))) != (unsigned int)string::npos) {
- tmp = key.substr(0,index);
- //cout << "adding toggle name: " << tmp << " to " << akey->getName() << endl;
- akey->addToggleName(tmp);
diff --git a/sysutils/lineakd/files/patch-lineakd__lineakd_core_functions.cpp b/sysutils/lineakd/files/patch-lineakd__lineakd_core_functions.cpp
index 57075468a18b..e3c6adef4bb2 100644
--- a/sysutils/lineakd/files/patch-lineakd__lineakd_core_functions.cpp
+++ b/sysutils/lineakd/files/patch-lineakd__lineakd_core_functions.cpp
@@ -1,5 +1,5 @@
---- lineakd/lineakd_core_functions.cpp.orig Wed Dec 29 11:49:55 2004
-+++ lineakd/lineakd_core_functions.cpp Wed Dec 29 11:54:02 2004
+--- lineakd/lineakd_core_functions.cpp.orig Wed Mar 2 13:15:38 2005
++++ lineakd/lineakd_core_functions.cpp Sat Apr 2 18:13:06 2005
@@ -46,6 +46,7 @@
#include <sys/wait.h>
}
@@ -17,8 +17,15 @@
/* Clean up X */
if (X != 0) {
X->cleanup(myKbd);
-@@ -275,7 +276,7 @@
- //msg("Unloading All Plugins DONE!");
+@@ -270,12 +271,12 @@
+ if (!plugincleanup) {
+ plugincleanup = true;
+ if ( plugins != NULL) {
+- msg("Unloading All Plugins!");
++ lineak_core_functions::msg("Unloading All Plugins!");
+ plugins->unloadAllPlugins();
+- msg("Unloading All Plugins DONE!");
++ lineak_core_functions::msg("Unloading All Plugins DONE!");
delete(plugins);
plugins = NULL;
- msg("Plugins all taken care of!");
@@ -42,7 +49,7 @@
lockCtrl lock("lineakd");
lock.unlock();
// exit(true);
-@@ -321,8 +322,8 @@
+@@ -321,16 +322,16 @@
sigprocmask(SIG_SETMASK, &mask_set, &old_set);
//bool verbose = cmdprefs.getVerbose();
@@ -52,8 +59,18 @@
+ lineak_core_functions::msg("Unmapping keys");
X->cleanup(myKbd);
- //msg("Unloading all plugins");
-@@ -366,34 +367,34 @@
+- msg("Unloading all plugins");
++ lineak_core_functions::msg("Unloading all plugins");
+ plugins->unloadAllPlugins();
+
+ /** Get a list of the potential plugins in the plugin directory */
+ vector<string> pluginlist = plugins->scanForPlugins();
+- msg("Scaning for and loading plugins");
++ lineak_core_functions::msg("Scaning for and loading plugins");
+ /** Load the plugins */
+ plugins->loadPlugins(pluginlist);
+ /** Define the list of macros we support */
+@@ -370,34 +371,34 @@
cmdprefs.setDefaults(dnd);
/* reload .conf and .def file */
diff --git a/sysutils/lineakd/files/patch-lineakd__main.cpp b/sysutils/lineakd/files/patch-lineakd__main.cpp
index 246f0bccbf8b..b90c9bb74524 100644
--- a/sysutils/lineakd/files/patch-lineakd__main.cpp
+++ b/sysutils/lineakd/files/patch-lineakd__main.cpp
@@ -1,6 +1,32 @@
---- lineakd/main.cpp.orig Wed Dec 29 11:55:13 2004
-+++ lineakd/main.cpp Wed Dec 29 11:55:15 2004
-@@ -288,7 +288,7 @@
+--- lineakd/main.cpp.orig Mon Feb 21 20:26:38 2005
++++ lineakd/main.cpp Sat Apr 2 18:20:50 2005
+@@ -134,19 +134,19 @@
+ /** Load the plugins */
+ plugins->loadPlugins(pluginlist);
+ if (verbose) {
+- msg("");
+- msg("Listing Plugins");
++ lineak_core_functions::msg("");
++ lineak_core_functions::msg("Listing Plugins");
+ plugins->listPlugins();
+ }
+
+- msg("");
+- msg("Defining Macro Lists");
++ lineak_core_functions::msg("");
++ lineak_core_functions::msg("Defining Macro Lists");
+ /** Define the list of macros we support */
+ plugins->defineMacroLists();
+ //if (verbose) plugins->listPlugins();
+ /** Define the configurate directives we support */
+- msg("");
+- msg("Defining Directives Lists");
++ lineak_core_functions::msg("");
++ lineak_core_functions::msg("Defining Directives Lists");
+ plugins->defineDirectivesLists();
+ //if (verbose) plugins->listPlugins();
+ /** Get a list of macros we support so that we can inform other classes */
+@@ -307,7 +307,7 @@
watch_messages();
/* init X/Xkb with our EAK keycodes/keysyms */
@@ -9,16 +35,64 @@
if (!X->initialize(myKbd)) {
cerr << "Could not initialize all keys. Retrying.\n";
-@@ -345,7 +345,7 @@
+@@ -329,7 +329,7 @@
+ myDisplay = new displayCtrl(myConfig);
+ myDisplay->init();
+ }
+- msg("Initializing Plugin Display");
++ lineak_core_functions::msg("Initializing Plugin Display");
+ plugins->initializePluginsDisplay(*myDisplay);
+
+ /* alright, we're going to loop forever now. only signals can interrupt us. */
+@@ -362,23 +362,23 @@
+ // like VMWare.
+ if (xev.type == MappingNotify) {
+ // if (!X->xkbRemapped()) {
+- msg("Setting xkbRemapped flag");
++ lineak_core_functions::msg("Setting xkbRemapped flag");
+ X->xkbRemapped(true); // =1;
+- msg("Cleaning up key mappings from MappingNotify event");
++ lineak_core_functions::msg("Cleaning up key mappings from MappingNotify event");
+ X->cleanup(myKbd);
+- msg("Cleaning up the on screen display.");
++ lineak_core_functions::msg("Cleaning up the on screen display.");
+ myDisplay->cleanup();
+ // }
+ // If we are getting the display back.
+ // Get out modifiers and grab our keys again.
+ // Reinitialize the OSD.
+ // else {
+- msg("Clearing xkbRemapped flag");
++ lineak_core_functions::msg("Clearing xkbRemapped flag");
+ X->xkbRemapped(false);
+ //X->getModifiers();
+- msg("Reclaiming keyboard map from MappingNotify event");
++ lineak_core_functions::msg("Reclaiming keyboard map from MappingNotify event");
+ X->initialize(myKbd);
+- msg("Restarting the OSD.");
++ lineak_core_functions::msg("Restarting the OSD.");
+ myDisplay = plugins->getDisplay(myConfig);
+ if (myDisplay != NULL) {
+ if (very_verbose) cout << "Reiniting plugin provided On Screen Display" << endl;
+@@ -390,7 +390,7 @@
+ myDisplay->init();
+ }
+ // Initialize the plugin displays again.
+- msg("Initializing Plugin Display");
++ lineak_core_functions::msg("Initializing Plugin Display");
+ plugins->initializePluginsDisplay(*myDisplay);
+ // set exec.setDisplayCtrl(myDisplay) again.
+ exec.setDisplayCtrl(myDisplay);
+@@ -414,7 +414,7 @@
}
if (obj != NULL) {
- msg("Got an object!");
+ lineak_core_functions::msg("Got an object!");
if (obj->getType() == SYM && obj->getEventType() == PRESS) {
- if (xev.xkey.keycode == XKeysymToKeycode (display, obj->getKeySym())
- && obj->hasModifier(xev.xkey.state))
-@@ -366,21 +366,21 @@
+ cout << "xev.xkey.keycode = " << xev.xkey.keycode << endl;
+ cout << "obj->getKeyCode() = " << obj->getKeyCode() << endl;
+@@ -435,21 +435,21 @@
}
}
else {
@@ -44,12 +118,3 @@
execute = plugins->exec(obj,xev);
if (execute != NULL)
execute(obj,xev);
-@@ -515,7 +515,7 @@
- if (!X->xkbRemapped())
- X->xkbRemapped(true); // =1;
- else {
-- msg("Reclaiming keyboard map from MappingNotify event");
-+ lineak_core_functions::msg("Reclaiming keyboard map from MappingNotify event");
- X->xkbRemapped(false);
- //X->getModifiers();
- X->initialize(myKbd);