aboutsummaryrefslogtreecommitdiff
path: root/sysutils
diff options
context:
space:
mode:
authorOleksii Samorukov <samm@FreeBSD.org>2019-10-17 08:31:07 +0000
committerOleksii Samorukov <samm@FreeBSD.org>2019-10-17 08:31:07 +0000
commit18d48aac8b0ff0f2a8a03057c846c8b322bca941 (patch)
tree4837bb085ba23de208b2fc7fed11d6956a777047 /sysutils
parent205268f65c8ae63088362f2e50cb2eccd3ab432d (diff)
downloadports-18d48aac8b0ff0f2a8a03057c846c8b322bca941.tar.gz
ports-18d48aac8b0ff0f2a8a03057c846c8b322bca941.zip
sysutils/busybox: fix broken build
Approved by: araujo (mentor) Differential Revision: https://reviews.freebsd.org/D22066
Notes
Notes: svn path=/head/; revision=514650
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/busybox/Makefile1
-rw-r--r--sysutils/busybox/files/patch-shell_shell__common.c12
2 files changed, 13 insertions, 0 deletions
diff --git a/sysutils/busybox/Makefile b/sysutils/busybox/Makefile
index ffb2caa3f5cd..7c043302407c 100644
--- a/sysutils/busybox/Makefile
+++ b/sysutils/busybox/Makefile
@@ -3,6 +3,7 @@
PORTNAME= busybox
PORTVERSION= 1.31.0
+PORTREVISION= 1
CATEGORIES= sysutils misc shells
MASTER_SITES= https://busybox.net/downloads/
diff --git a/sysutils/busybox/files/patch-shell_shell__common.c b/sysutils/busybox/files/patch-shell_shell__common.c
new file mode 100644
index 000000000000..70883a3a8e08
--- /dev/null
+++ b/sysutils/busybox/files/patch-shell_shell__common.c
@@ -0,0 +1,12 @@
+--- shell/shell_common.c.orig 2019-06-10 09:09:31 UTC
++++ shell/shell_common.c
+@@ -328,7 +328,9 @@ struct limits {
+ static const struct limits limits_tbl[] = {
+ { RLIMIT_CORE, 9, "core file size (blocks)" }, // -c
+ { RLIMIT_DATA, 10, "data seg size (kb)" }, // -d
++#ifdef RLIMIT_NICE
+ { RLIMIT_NICE, 0, "scheduling priority" }, // -e
++#endif
+ { RLIMIT_FSIZE, 9, "file size (blocks)" }, // -f
+ #define LIMIT_F_IDX 3
+ #ifdef RLIMIT_SIGPENDING