aboutsummaryrefslogtreecommitdiff
path: root/sysutils
diff options
context:
space:
mode:
authorCy Schubert <cy@FreeBSD.org>2020-08-20 18:53:58 +0000
committerCy Schubert <cy@FreeBSD.org>2020-08-20 18:53:58 +0000
commit1916f0228d1f01161015cc156c2bd84aae44f671 (patch)
treefb835c96a18406ea117788af295958cedb31ddb3 /sysutils
parent71386cf73ae678816921ea73149a4a08b9271586 (diff)
downloadports-1916f0228d1f01161015cc156c2bd84aae44f671.tar.gz
ports-1916f0228d1f01161015cc156c2bd84aae44f671.zip
Fix build after llvm 11 import into 13-current.
Notes
Notes: svn path=/head/; revision=545548
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/heirloom/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/sysutils/heirloom/Makefile b/sysutils/heirloom/Makefile
index 3255993508dd..dff137310641 100644
--- a/sysutils/heirloom/Makefile
+++ b/sysutils/heirloom/Makefile
@@ -14,8 +14,9 @@ BUILD_DEPENDS= ksh:shells/pdksh
RUN_DEPENDS:= ${BUILD_DEPENDS}
USES= gmake ncurses tar:bzip2
-MAKE_ARGS= CC=${CC} CFLAGS="${CFLAGS}" ROOT="${STAGEDIR}" \
- LCURS="-L${LOCALBASE}/lib -lncurses"
+LDFLAGS+= -Wl,--allow-multiple-definition
+MAKE_ARGS= CC=${CC} CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" \
+ ROOT="${STAGEDIR}" LCURS="-L${LOCALBASE}/lib -lncurses"
MAKEFILE= makefile
ALL_TARGET= #
DATADIR= ${PREFIX}/${PORTNAME}