aboutsummaryrefslogtreecommitdiff
path: root/sysutils
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2014-08-26 14:06:08 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2014-08-26 14:06:08 +0000
commit216b5a285fdcc1456a307fcc60f3507c20d613eb (patch)
treed0c8617b772b8f0a175d436d938b8d844590b41f /sysutils
parentb829518a7d432b7cc2546fde7f032238d1db13dc (diff)
downloadports-216b5a285fdcc1456a307fcc60f3507c20d613eb.tar.gz
ports-216b5a285fdcc1456a307fcc60f3507c20d613eb.zip
- Fix missing library problems when the linker enforces explicit linking
PR: 192062 Exp-run by: antoine Approved by: portmgr (antoine)
Notes
Notes: svn path=/head/; revision=366215
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/battfink/Makefile4
-rw-r--r--sysutils/battfink/files/patch-configure11
-rw-r--r--sysutils/fusefs-encfs/Makefile2
-rw-r--r--sysutils/fusefs-rar2fs/Makefile8
-rw-r--r--sysutils/gapcmon/Makefile2
-rw-r--r--sysutils/gnome-system-tools/Makefile11
-rw-r--r--sysutils/gnome-system-tools/pkg-plist2
-rw-r--r--sysutils/gtk-imonc/Makefile16
-rw-r--r--sysutils/ldapvi/Makefile5
-rw-r--r--sysutils/libgksu/Makefile15
-rw-r--r--sysutils/libgksu/files/patch-libgksu_Makefile.in20
-rw-r--r--sysutils/nitrogen/Makefile21
-rw-r--r--sysutils/nvclock/Makefile2
-rw-r--r--sysutils/pcbsd-utils-qt4/Makefile8
-rw-r--r--sysutils/tracker-client/files/patch-src_tracker-applet_Makefile.in7
-rw-r--r--sysutils/xvidcap/Makefile4
16 files changed, 55 insertions, 83 deletions
diff --git a/sysutils/battfink/Makefile b/sysutils/battfink/Makefile
index 875652572a3f..b3f5dcee8eaa 100644
--- a/sysutils/battfink/Makefile
+++ b/sysutils/battfink/Makefile
@@ -11,13 +11,13 @@ DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
COMMENT= Energy saving preferences app for GNOME
-USE_XORG= x11
INSTALLS_OMF= yes
USE_GNOME= gnomeprefix libgnomeui
USES= gettext gmake pathfix pkgconfig tar:bzip2
+USE_XORG= x11 xext
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
+LIBS+= -L${LOCALBASE}/lib -lX11 -lXext
INSTALL_TARGET= install-strip
GCONF_SCHEMAS= battfink.schemas
diff --git a/sysutils/battfink/files/patch-configure b/sysutils/battfink/files/patch-configure
deleted file mode 100644
index 6e7783f3e9ba..000000000000
--- a/sysutils/battfink/files/patch-configure
+++ /dev/null
@@ -1,11 +0,0 @@
---- configure.orig Sat Apr 12 01:31:11 2003
-+++ configure Sat Apr 12 01:31:27 2003
-@@ -7481,7 +7481,7 @@
-
-
- cat >>confdefs.h <<_ACEOF
--#define GNOME_ICONDIR "${prefix}/share/pixmaps"
-+#define GNOME_ICONDIR "${datadir}/pixmaps"
- _ACEOF
-
-
diff --git a/sysutils/fusefs-encfs/Makefile b/sysutils/fusefs-encfs/Makefile
index 491d3ed4b68d..fa7375138b75 100644
--- a/sysutils/fusefs-encfs/Makefile
+++ b/sysutils/fusefs-encfs/Makefile
@@ -33,6 +33,8 @@ NLS_USES= gettext
NLS_CONFIGURE_ENABLE= nls
post-patch:
+ @${REINPLACE_CMD} '/OPENSSL_LIBS=/s/-lssl/& -lcrypto/' \
+ ${WRKSRC}/configure
@${FIND} ${WRKSRC}/encfs -type f | ${XARGS} ${REINPLACE_CMD} -E \
's/(^|[[:space:]])(shared_ptr)/\1boost::\2/g'
diff --git a/sysutils/fusefs-rar2fs/Makefile b/sysutils/fusefs-rar2fs/Makefile
index 1231844094a8..3986aa0fdd31 100644
--- a/sysutils/fusefs-rar2fs/Makefile
+++ b/sysutils/fusefs-rar2fs/Makefile
@@ -14,8 +14,7 @@ COMMENT= Mount rar archives as filesystem
LICENSE= GPLv3
-LIB_DEPENDS= libexecinfo.so:${PORTSDIR}/devel/libexecinfo \
- libunrar.so:${PORTSDIR}/archivers/libunrar4
+LIB_DEPENDS= libunrar.so:${PORTSDIR}/archivers/libunrar4
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-fuse-lib=${LOCALBASE}/lib \
@@ -24,10 +23,11 @@ CONFIGURE_ARGS= --with-fuse-lib=${LOCALBASE}/lib \
--with-unrar-lib=${LOCALBASE}/lib
PLIST_FILES= bin/${PORTNAME} man/man1/rar2fs.1.gz
-USES= fuse gmake
+USES= execinfo fuse gmake
post-patch:
- @${REINPLACE_CMD} 's/-lstdc++/-lexecinfo/' ${WRKSRC}/Makefile.in
+ @${REINPLACE_CMD} -e 's/-lstdc++/-lexecinfo/' -e '/_LINK =/s/CC/CXX/' \
+ ${WRKSRC}/Makefile.in
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
diff --git a/sysutils/gapcmon/Makefile b/sysutils/gapcmon/Makefile
index d8782ea2059d..9600fcb0777f 100644
--- a/sysutils/gapcmon/Makefile
+++ b/sysutils/gapcmon/Makefile
@@ -14,7 +14,9 @@ LICENSE= GPLv2
SUB_FILES= pkg-message
USE_GNOME= gconf2
USES= pkgconfig gmake tar:bzip2
+USE_XORG= x11
GNU_CONFIGURE= yes
+LIBS+= -L${LOCALBASE}/lib -lX11
OPTIONS_DEFINE= DOCS
diff --git a/sysutils/gnome-system-tools/Makefile b/sysutils/gnome-system-tools/Makefile
index 2b8e0384df8d..b5c018342a42 100644
--- a/sysutils/gnome-system-tools/Makefile
+++ b/sysutils/gnome-system-tools/Makefile
@@ -4,7 +4,7 @@
PORTNAME= gnome-system-tools
PORTVERSION= 2.32.0
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= sysutils gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome2
@@ -16,19 +16,20 @@ LIB_DEPENDS= liboobs-1.so:${PORTSDIR}/devel/liboobs \
libpolkit-gtk-1.so:${PORTSDIR}/sysutils/polkit-gnome
INSTALLS_ICONS= yes
-USES= gettext gmake pathfix pkgconfig tar:bzip2
+USES= gettext gmake libtool pathfix pkgconfig tar:bzip2
USE_LDCONFIG= yes
USE_GNOME= gnomeprefix intlhack nautilus2
-USE_AUTOTOOLS= libtool
INSTALLS_OMF= yes
-CONFIGURE_ARGS= --enable-services
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --disable-static --enable-services
CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
+LIBS+= -L${LOCALBASE}/lib
GLIB_SCHEMAS= org.gnome.system-tools.gschema.xml
post-patch:
@${REINPLACE_CMD} -e 's|gmodule-export-2.0|gmodule-export-2.0 gthread-2.0|g' \
${WRKSRC}/configure
+ @${REINPLACE_CMD} '/^time_admin_LDADD =/s/$$/ -lm/' ${WRKSRC}/src/time/Makefile.in
.include <bsd.port.mk>
diff --git a/sysutils/gnome-system-tools/pkg-plist b/sysutils/gnome-system-tools/pkg-plist
index 254a48735ef2..97bb39d9663b 100644
--- a/sysutils/gnome-system-tools/pkg-plist
+++ b/sysutils/gnome-system-tools/pkg-plist
@@ -4,8 +4,6 @@ bin/shares-admin
bin/time-admin
bin/users-admin
etc/gnome-system-tools/user-profiles.conf
-lib/nautilus/extensions-2.0/libnautilus-gst-shares.a
-lib/nautilus/extensions-2.0/libnautilus-gst-shares.la
lib/nautilus/extensions-2.0/libnautilus-gst-shares.so
libdata/pkgconfig/gnome-system-tools.pc
share/applications/network.desktop
diff --git a/sysutils/gtk-imonc/Makefile b/sysutils/gtk-imonc/Makefile
index 2ebac168b41e..0649549926da 100644
--- a/sysutils/gtk-imonc/Makefile
+++ b/sysutils/gtk-imonc/Makefile
@@ -12,22 +12,12 @@ COMMENT= GTK2-based imond-client to control an on(e) disc fli4l router
LICENSE= GPLv2 # (or later)
-LIB_DEPENDS= libpthread-stubs.so:${PORTSDIR}/devel/libpthread-stubs \
- libpcre.so:${PORTSDIR}/devel/pcre \
- libcairo.so:${PORTSDIR}/graphics/cairo \
- libpng15.so:${PORTSDIR}/graphics/png \
- libfreetype.so:${PORTSDIR}/print/freetype2 \
- libexpat.so:${PORTSDIR}/textproc/expat2 \
- libfontconfig.so:${PORTSDIR}/x11-fonts/fontconfig
-
GNU_CONFIGURE= yes
USES= pkgconfig gettext iconv
-USE_GNOME= gdkpixbuf2 gtk20
-USE_XORG= pixman x11 xau xcb xcomposite xcursor xdamage xdmcp xext \
- xfixes xi xinerama xrandr xrender
-
+USE_GNOME= gtk20
+USE_XORG= x11
CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
+LIBS+= -L${LOCALBASE}/lib -lX11
post-patch:
@${REINPLACE_CMD} -e \
diff --git a/sysutils/ldapvi/Makefile b/sysutils/ldapvi/Makefile
index 0b3e0d5a6de8..1fdfe8ae97c9 100644
--- a/sysutils/ldapvi/Makefile
+++ b/sysutils/ldapvi/Makefile
@@ -22,7 +22,7 @@ GNU_CONFIGURE= yes
MAKEFILE= GNUmakefile
CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
+LIBS+= -L${LOCALBASE}/lib
PLIST_FILES= bin/${PORTNAME} man/man1/${PORTNAME}.1.gz \
${DOCSDIR_REL}/manual.css ${DOCSDIR_REL}/manual.xml \
@@ -34,4 +34,7 @@ PLIST_DIRS= ${DOCSDIR_REL}
CONFIGURE_ARGS= --without-sasl
.endif
+post-patch:
+ @${REINPLACE_CMD} -e 's/-lssl/-lcrypto/' ${WRKSRC}/configure
+
.include <bsd.port.mk>
diff --git a/sysutils/libgksu/Makefile b/sysutils/libgksu/Makefile
index 772afa198aaa..ee7cd8e655c9 100644
--- a/sysutils/libgksu/Makefile
+++ b/sysutils/libgksu/Makefile
@@ -17,12 +17,23 @@ LIB_DEPENDS= libgtop-2.0.so:${PORTSDIR}/devel/libgtop \
RUN_DEPENDS= xauth:${PORTSDIR}/x11/xauth \
sudo:${PORTSDIR}/security/sudo
-USES= desktop-file-utils gmake libtool pkgconfig
+USES= gmake libtool pathfix pkgconfig
USE_GNOME= glib20 gconf2
USE_LDCONFIG= yes
+USE_XORG= x11
CONFIGURE_ARGS= --enable-gtk-doc=no
GNU_CONFIGURE= yes
GCONF_SCHEMAS= gksu.schemas
-LIBS+= `pkg-config --libs gtk+-x11-2.0`
+INSTALL_TARGET= install-strip
+
+post-patch:
+ @${REINPLACE_CMD} '/AM_CFLAGS/s/-g -O2//' \
+ ${WRKSRC}/gksu-properties/Makefile.in \
+ ${WRKSRC}/libgksu/Makefile.in \
+ ${WRKSRC}/libgksuui/Makefile.in
+ @${REINPLACE_CMD} '/^test_gksu_LDFLAGS =/s/glib-2.0/gtk+-2.0/' \
+ ${WRKSRC}/libgksu/Makefile.in
+ @${REINPLACE_CMD} '/^libgksuui1_0_la_LIBADD =/s/$$/ -lX11/' \
+ ${WRKSRC}/libgksuui/Makefile.in
.include <bsd.port.mk>
diff --git a/sysutils/libgksu/files/patch-libgksu_Makefile.in b/sysutils/libgksu/files/patch-libgksu_Makefile.in
deleted file mode 100644
index 6d0a436a03f6..000000000000
--- a/sysutils/libgksu/files/patch-libgksu_Makefile.in
+++ /dev/null
@@ -1,20 +0,0 @@
---- libgksu/Makefile.in.o 2011-04-11 13:45:10.938246716 -0400
-+++ libgksu/Makefile.in 2011-04-11 13:46:36.384246142 -0400
-@@ -266,7 +266,7 @@
- top_build_prefix = @top_build_prefix@
- top_builddir = @top_builddir@
- top_srcdir = @top_srcdir@
--AM_CFLAGS = -g -O2 -Wall
-+AM_CFLAGS = $(CFLAGS)
- INCLUDES = ${LIBGKSU_CFLAGS}
- AM_CPPFLAGS = -DLOCALEDIR=\"$(datadir)/locale\" -DDATA_DIR=\"$(datadir)\" -DPREFIX=\"$(prefix)\"
- lib_LTLIBRARIES = libgksu2.la
-@@ -280,7 +280,7 @@
- ${LIBGKSU_LIBS} $(am__append_1)
- noinst_HEADERS = defines.h
- include_HEADERS = gksu.h libgksu.h
--pkgconfigdir = ${libdir}/pkgconfig
-+pkgconfigdir = ${prefix}/libdata/pkgconfig
- pkgconfig_DATA = libgksu2.pc
- gksu_run_helper_LDFLAGS = `pkg-config --libs glib-2.0`
- gksu_run_helper_SOURCES = gksu-run-helper.c
diff --git a/sysutils/nitrogen/Makefile b/sysutils/nitrogen/Makefile
index ac2e49444b40..cb111f0f1ca4 100644
--- a/sysutils/nitrogen/Makefile
+++ b/sysutils/nitrogen/Makefile
@@ -13,19 +13,6 @@ COMMENT= Background browser and setter for X windows
LICENSE= GPLv2 # (or later)
BUILD_DEPENDS= bash:${PORTSDIR}/shells/bash
-LIB_DEPENDS= libatkmm-1.6.so:${PORTSDIR}/accessibility/atkmm \
- libglibmm-2.4.so:${PORTSDIR}/devel/glibmm \
- libpthread-stubs.so:${PORTSDIR}/devel/libpthread-stubs \
- libsigc-2.0.so:${PORTSDIR}/devel/libsigc++20 \
- libpcre.so:${PORTSDIR}/devel/pcre \
- libcairo.so:${PORTSDIR}/graphics/cairo \
- libcairomm-1.0.so:${PORTSDIR}/graphics/cairomm \
- libpng15.so:${PORTSDIR}/graphics/png \
- libfreetype.so:${PORTSDIR}/print/freetype2 \
- libexpat.so:${PORTSDIR}/textproc/expat2 \
- libfontconfig.so:${PORTSDIR}/x11-fonts/fontconfig \
- libgtkmm-2.4.so:${PORTSDIR}/x11-toolkits/gtkmm24 \
- libpangomm-1.4.so:${PORTSDIR}/x11-toolkits/pangomm
RUN_DEPENDS= gnome-icon-theme>0:${PORTSDIR}/misc/gnome-icon-theme \
hicolor-icon-theme>0:${PORTSDIR}/misc/hicolor-icon-theme
@@ -33,15 +20,14 @@ OPTIONS_DEFINE= XINERAMA
OPTIONS_DEFAULT=XINERAMA
USES= gettext iconv pkgconfig
-USE_GNOME= gtk20
-USE_XORG= pixman x11 xau xcb xcomposite xcursor xdamage xdmcp xext xfixes \
- xrandr xrender
+USE_GNOME= gtkmm24
+USE_XORG= x11
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-inotify
INSTALLS_ICONS= yes
CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
+LIBS+= -L${LOCALBASE}/lib -lX11
DESKTOP_ENTRIES="Nitrogen" "${COMMENT}" "${PORTNAME}" "${PORTNAME}" \
"Graphics;Viewer;" true
@@ -58,5 +44,6 @@ CONFIGURE_ARGS+=--disable-xinerama
post-patch:
@${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|' \
${WRKSRC}/data/icon-theme-installer
+ @${REINPLACE_CMD} '/^LIBS =/s/$$/ @LIBS@/' ${WRKSRC}/src/Makefile.in
.include <bsd.port.mk>
diff --git a/sysutils/nvclock/Makefile b/sysutils/nvclock/Makefile
index c2ca40e5fef4..09d7e153dea9 100644
--- a/sysutils/nvclock/Makefile
+++ b/sysutils/nvclock/Makefile
@@ -50,5 +50,7 @@ post-patch:
@${REINPLACE_CMD} -E '/exec_prefix|bindir/s|\$$\(DESTDIR\)||' \
${WRKSRC}/src/gtk/Makefile.in \
${WRKSRC}/src/qt/Makefile.in
+ @${REINPLACE_CMD} 's/-lnvcontrol/& @X11_LIBS@/' \
+ ${WRKSRC}/src/gtk/Makefile.in
.include <bsd.port.mk>
diff --git a/sysutils/pcbsd-utils-qt4/Makefile b/sysutils/pcbsd-utils-qt4/Makefile
index d8b8c4c4df7c..573eac7a3027 100644
--- a/sysutils/pcbsd-utils-qt4/Makefile
+++ b/sysutils/pcbsd-utils-qt4/Makefile
@@ -26,10 +26,14 @@ WRKSRC= ${WRKDIR}/src-qt4
QMAKE_ARGS= CONFIG+="configure"
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
.if ${OSVERSION} < 1000000
IGNORE= requires FreeBSD 10 or later
.endif
-.include <bsd.port.post.mk>
+post-patch:
+ @${REINPLACE_CMD} '/^LIBS/s/$$/ -lQtSolutions_SingleApplication-head/' \
+ ${WRKSRC}/pc-netmanager/src/NetworkManager/NetworkManager.pro
+
+.include <bsd.port.mk>
diff --git a/sysutils/tracker-client/files/patch-src_tracker-applet_Makefile.in b/sysutils/tracker-client/files/patch-src_tracker-applet_Makefile.in
index e00d83cf4e40..c4aa666359d6 100644
--- a/sysutils/tracker-client/files/patch-src_tracker-applet_Makefile.in
+++ b/sysutils/tracker-client/files/patch-src_tracker-applet_Makefile.in
@@ -9,14 +9,15 @@
$(am__DEPENDENCIES_1) $(am__DEPENDENCIES_1) \
$(am__DEPENDENCIES_1)
DEFAULT_INCLUDES = -I.@am__isrc@ -I$(top_builddir)
-@@ -345,8 +343,8 @@
+@@ -345,8 +343,9 @@
$(GCOV_CFLAGS)
tracker_applet_LDADD = \
- $(top_builddir)/src/libtracker/libtrackerclient.la \
- $(top_builddir)/src/libtracker-common/libtracker-common.la \
-+ -ltrackerclient \
-+ -ltracker-common \
++ -ltrackerclient \
++ -ltracker-common \
++ -lX11 \
$(TRACKER_APPLET_LIBS) \
$(LIBGLADE_LIBS) \
$(GCOV_LIBS)
diff --git a/sysutils/xvidcap/Makefile b/sysutils/xvidcap/Makefile
index 3ac7b2de4650..23197bdba157 100644
--- a/sysutils/xvidcap/Makefile
+++ b/sysutils/xvidcap/Makefile
@@ -43,12 +43,14 @@ OPTIONS_DEFINE= DOCS
.include <bsd.port.options.mk>
-pre-configure:
+post-patch:
.if empty(PORT_OPTIONS:MDOCS)
${REINPLACE_CMD} -e 's|pkgdataDATA install-xvidcapdocDATA|pkgdataDATA|' \
${WRKSRC}/Makefile.in
.endif
${REINPLACE_CMD} -e 's|/bin/bash | /bin/sh|' ${WRKSRC}/ppm2mpeg.sh
+ @${REINPLACE_CMD} '/^xvidcap_LDADD =/s/$$/ -lXext -lX11/' \
+ ${WRKSRC}/src/Makefile.in
post-install:
.if ${PORT_OPTIONS:MDOCS}