aboutsummaryrefslogtreecommitdiff
path: root/sysutils
diff options
context:
space:
mode:
authorDave Cottlehuber <dch@FreeBSD.org>2018-10-23 22:41:12 +0000
committerDave Cottlehuber <dch@FreeBSD.org>2018-10-23 22:41:12 +0000
commit321e5c4d1b231f1b647a4c7cd0dbf3e6e7518578 (patch)
tree054fcd81c7350da5620692cc82d9a9641a579c2b /sysutils
parentf56a628d4668715be033fc65fd013f9a2483238c (diff)
downloadports-321e5c4d1b231f1b647a4c7cd0dbf3e6e7518578.tar.gz
ports-321e5c4d1b231f1b647a4c7cd0dbf3e6e7518578.zip
new port: sysutils/py-packet-python: provides packet.net API wrapper
packet.net is a "bare metal as a service" infrastructure provider, with a python-enabled API. This module plays nicely with ansible, see upstream module docs for that integration. Approved by: jrm (mentor) Differential Revision: https://reviews.freebsd.org/D17517
Notes
Notes: svn path=/head/; revision=482876
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/py-packet-python/Makefile21
-rw-r--r--sysutils/py-packet-python/distinfo3
-rw-r--r--sysutils/py-packet-python/files/patch-setup.py29
-rw-r--r--sysutils/py-packet-python/pkg-descr4
5 files changed, 58 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index 5062404410d8..23e3dda3da4d 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -859,6 +859,7 @@
SUBDIR += p5-arclog
SUBDIR += p5-reslog
SUBDIR += packer
+ SUBDIR += packet-python
SUBDIR += pacman
SUBDIR += paicc
SUBDIR += paladin
diff --git a/sysutils/py-packet-python/Makefile b/sysutils/py-packet-python/Makefile
new file mode 100644
index 000000000000..938d5a51987e
--- /dev/null
+++ b/sysutils/py-packet-python/Makefile
@@ -0,0 +1,21 @@
+# $FreeBSD$
+
+PORTNAME= packet-python
+DISTVERSION= 1.37.1
+CATEGORIES= sysutils python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= dch@FreeBSD.org
+COMMENT= Python client for Packet.net API
+
+LICENSE= LGPL3+
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}requests>2.18.0:www/py-requests@${PY_FLAVOR}
+
+USES= python
+USE_PYTHON= distutils autoplist concurrent
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/sysutils/py-packet-python/distinfo b/sysutils/py-packet-python/distinfo
new file mode 100644
index 000000000000..3c179561a39e
--- /dev/null
+++ b/sysutils/py-packet-python/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1539263425
+SHA256 (packet-python-1.37.1.tar.gz) = 316941d2473c0f42ac17ac89e9aa63a023bb96f35cf8eafe9e091ea424892778
+SIZE (packet-python-1.37.1.tar.gz) = 9607
diff --git a/sysutils/py-packet-python/files/patch-setup.py b/sysutils/py-packet-python/files/patch-setup.py
new file mode 100644
index 000000000000..c92c3da61128
--- /dev/null
+++ b/sysutils/py-packet-python/files/patch-setup.py
@@ -0,0 +1,29 @@
+--- setup.py.orig 2018-01-08 17:58:49 UTC
++++ setup.py
+@@ -1,7 +1,6 @@
+ #!/usr/bin/env python
+
+ import os
+-import pypandoc
+
+ # Notes for the not-an-everyday-python-dev for package distribution on pypi
+ #
+@@ -45,10 +44,6 @@ except ImportError:
+ from setuptools import setup
+
+ long_description = 'This library provides the python client for the Packet API.'
+-if os.path.isfile('README.md') and os.path.isfile('CHANGELOG.md'):
+- readme = pypandoc.convert_file('README.md', 'rst')
+- changelog = pypandoc.convert_file('CHANGELOG.md', 'rst')
+- long_description = readme + '\n' + changelog
+
+ setup(
+ name='packet-python',
+@@ -61,7 +56,6 @@ setup(
+ keywords='packet api client',
+ packages=['packet'],
+ install_requires='requests',
+- setup_requires='pypandoc',
+ classifiers=[
+ 'Development Status :: 5 - Production/Stable',
+ 'Intended Audience :: Developers',
diff --git a/sysutils/py-packet-python/pkg-descr b/sysutils/py-packet-python/pkg-descr
new file mode 100644
index 000000000000..9821d140c78a
--- /dev/null
+++ b/sysutils/py-packet-python/pkg-descr
@@ -0,0 +1,4 @@
+Python client for the packet.net API. Full Packet API documentation is available
+at https://www.packet.net/developers/api
+
+WWW: https://pypi.python.org/pypi/packet-python