aboutsummaryrefslogtreecommitdiff
path: root/sysutils
diff options
context:
space:
mode:
authorCorvin Köhne <corvink@FreeBSD.org>2023-09-15 09:55:18 +0000
committerCorvin Köhne <corvink@FreeBSD.org>2023-09-15 14:59:37 +0000
commit46375fd002931ec59e73f02f78a0c228c3a85e36 (patch)
treec4330e2fe93db8fd3be18a3dfefb4f21e64fdb96 /sysutils
parente662f3927a40023074fb2868916474ed71ea0e2d (diff)
downloadports-46375fd002931ec59e73f02f78a0c228c3a85e36.tar.gz
ports-46375fd002931ec59e73f02f78a0c228c3a85e36.zip
sysutils/edk2: enable secure boot on bhyve
Everything is ready in edk2 for secure boot. To make use of secure boot you have to boot into an EFI shell and install your keys. Booting an EFI shell can be done by starting bhyve without any image attached to it. More information on how to generate and install keys can be found in the ACRN documentation [1]. Note that that secure boot capable UEFI implementation is required to meet the Windows 11 requirements. [1] https://projectacrn.github.io/3.2/tutorials/waag-secure-boot.html Reviewed by: manu Approved by: manu Sponsored by: Beckhoff Automation GmbH & Co. KG Differential Revision: https://reviews.freebsd.org/D41869
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/edk2/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/sysutils/edk2/Makefile b/sysutils/edk2/Makefile
index a6131c3127c8..d68e296d2242 100644
--- a/sysutils/edk2/Makefile
+++ b/sysutils/edk2/Makefile
@@ -1,6 +1,6 @@
PORTNAME= edk2
PORTVERSION= g202308
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= sysutils
PATCH_SITES= https://github.com/${GH_ACCOUNT}/${GH_PROJECT}/commit/
@@ -115,6 +115,7 @@ ONLY_FOR_ARCHS= amd64
ONLY_FOR_ARCHS_REASON= Bhyve only runs on x64
PLAT= bhyve
PLAT_ARCH= X64
+PLAT_ARGS+= -D SECURE_BOOT_ENABLE=TRUE
PLAT_TARGET= RELEASE
PLATFILE= OvmfPkg/Bhyve/BhyveX64.dsc
PLAT_RESULT= BhyveX64/${PLAT_TARGET}_GCC5/FV/BHYVE.fd