aboutsummaryrefslogtreecommitdiff
path: root/sysutils
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2016-09-02 20:33:30 +0000
committerSteve Wills <swills@FreeBSD.org>2016-09-02 20:33:30 +0000
commit548b34bef1bfc80ae84aa9238e75780e5207ed50 (patch)
tree2c6f275d59f9c5e3011787b7de7682b7ce23ac1d /sysutils
parent21ef95514f900637af4522444ee9fcbe6da5d275 (diff)
downloadports-548b34bef1bfc80ae84aa9238e75780e5207ed50.tar.gz
ports-548b34bef1bfc80ae84aa9238e75780e5207ed50.zip
sysutils/serf: convert to GH_SUBDIR and GH_TUPLE
While here, remove unneeded patch. Resulting binary should be the same.
Notes
Notes: svn path=/head/; revision=421275
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/serf/Makefile72
-rw-r--r--sysutils/serf/distinfo1
-rw-r--r--sysutils/serf/files/patch-deps_v0-6-4.json67
3 files changed, 18 insertions, 122 deletions
diff --git a/sysutils/serf/Makefile b/sysutils/serf/Makefile
index 5f26e589955f..fe927494bff8 100644
--- a/sysutils/serf/Makefile
+++ b/sysutils/serf/Makefile
@@ -14,18 +14,23 @@ LICENSE= MPL
BUILD_DEPENDS= go14>=1.4:lang/go14
USE_GITHUB= yes
-GH_ACCOUNT= hashicorp:DEFAULT,go_msgpack,go_syslog,go_net,logutils,mdns,memberlist \
- armon:circbuf,go_metrics miekg:dns mitchellh:cli,mapstructure \
- ryanuber:columnize golang:crypto
-GH_PROJECT= circbuf:circbuf cli:cli columnize:columnize dns:dns \
- go-metrics:go_metrics go-msgpack:go_msgpack \
- go-syslog:go_syslog go.net:go_net logutils:logutils \
- mapstructure:mapstructure mdns:mdns memberlist:memberlist \
- crypto:crypto
-GH_TAGNAME= 0dc08b1:logutils 281073e:mapstructure 983d3a5:columnize \
- fa3f638:go_msgpack 9888dc5:memberlist 42a2b57:go_syslog \
- 75e6e86:dns 104dcad:go_net 8102d0e:cli 06b6099:go_metrics \
- 9d85cf2:mdns bbbad09:circbuf f18420e:crypto
+
+GH_ACCOUNT= hashicorp
+GH_SUBDIR:= src/github.com/${GH_ACCOUNT}/${PORTNAME}
+
+GH_TUPLE= hashicorp:go-msgpack:fa3f638:msgpack/src/github.com/hashicorp/go-msgpack \
+ hashicorp:go-syslog:42a2b57:syslog/src/github.com/hashicorp/go-syslog \
+ hashicorp:go.net:104dcad:net/src/github.com/hashicorp/go.net \
+ hashicorp:logutils:0dc08b1:logutil/src/github.com/hashicorp/logutils \
+ hashicorp:mdns:9d85cf2:mdns/src/github.com/hashicorp/mdns \
+ hashicorp:memberlist:9888dc5:memberlist/src/github.com/hashicorp/memberlist \
+ armon:circbuf:bbbad09:circbuf/src/github.com/armon/circbuf \
+ armon:go-metrics:06b6099:metrics/src/github.com/armon/go-metrics \
+ miekg:dns:75e6e86:dns/src/github.com/miekg/dns \
+ mitchellh:cli:8102d0e:cli/src/github.com/mitchellh/cli \
+ mitchellh:mapstructure:281073e:mapstructure/src/github.com/mitchellh/mapstructure \
+ ryanuber:columnize:983d3a5:columnize/src/github.com/ryanuber/columnize \
+ golang:crypto:f18420e:crypto/src/golang.org/x/crypto
USE_RC_SUBR= serf
@@ -36,49 +41,6 @@ PLIST_FILES= bin/serf
STRIP= # stripping can break go binaries
-post-patch:
- @${MKDIR} ${WRKSRC}/src/github.com/${GH_ACCOUNT}/${PORTNAME}
-.for src in .gitignore .travis.yml CHANGELOG.md LICENSE Makefile README.md \
- client coordinate command commands.go demo deps main.go main_test.go \
- ops-misc scripts serf testutil version.go website
- @${MV} ${WRKSRC}/${src} \
- ${WRKSRC}/src/github.com/hashicorp/${PORTNAME}
-.endfor
- @${MKDIR} ${WRKSRC}/src/github.com/armon
- @${MKDIR} ${WRKSRC}/src/github.com/mitchellh
- @${MKDIR} ${WRKSRC}/src/github.com/miekg
- @${MKDIR} ${WRKSRC}/src/github.com/ryanuber
- @${MKDIR} ${WRKSRC}/src/golang.org/x
- @${MKDIR} ${WRKSRC}/src/code.google.com/p/go.net
- @${MV} ${WRKSRC_circbuf} \
- ${WRKSRC}/src/github.com/armon/circbuf
- @${MV} ${WRKSRC_go_metrics} \
- ${WRKSRC}/src/github.com/armon/go-metrics
- @${MV} ${WRKSRC_go_msgpack} \
- ${WRKSRC}/src/github.com/hashicorp/go-msgpack
- @${MV} ${WRKSRC_go_syslog} \
- ${WRKSRC}/src/github.com/hashicorp/go-syslog
- @${MV} ${WRKSRC_logutils} \
- ${WRKSRC}/src/github.com/hashicorp/logutils
- @${MV} ${WRKSRC_memberlist} \
- ${WRKSRC}/src/github.com/hashicorp/memberlist
- @${MV} ${WRKSRC_mapstructure} \
- ${WRKSRC}/src/github.com/mitchellh/mapstructure
- @${MV} ${WRKSRC_mdns} \
- ${WRKSRC}/src/github.com/hashicorp/mdns
- @${MV} ${WRKSRC_cli} \
- ${WRKSRC}/src/github.com/mitchellh/cli
- @${MV} ${WRKSRC_columnize} \
- ${WRKSRC}/src/github.com/ryanuber/columnize
- @${MV} ${WRKSRC_dns} \
- ${WRKSRC}/src/github.com/miekg/dns
- @${MV} ${WRKSRC_go_net} \
- ${WRKSRC}/src/github.com/hashicorp/go.net
- @${MV} ${WRKSRC_crypto} \
- ${WRKSRC}/src/golang.org/x/crypto
- @${CP} -r ${WRKSRC}/src/github.com/hashicorp/go.net/internal \
- ${WRKSRC}/src/code.google.com/p/go.net
-
do-build:
@cd ${WRKSRC}/src/github.com/${GH_ACCOUNT}/${PORTNAME}; \
${SETENV} CGO_ENABLED=0 PATH=${PATH}:${LOCALBASE}/go14/bin ${BUILD_ENV} GOPATH=${WRKSRC} \
diff --git a/sysutils/serf/distinfo b/sysutils/serf/distinfo
index 3bdb00f194af..a9f0207da30e 100644
--- a/sysutils/serf/distinfo
+++ b/sysutils/serf/distinfo
@@ -1,3 +1,4 @@
+TIMESTAMP = 1472766963
SHA256 (hashicorp-serf-v0.7.0_GH0.tar.gz) = 2699dbbc616e4b76fb158d8ea3291b0ae43bb0499ab263907ef38de61f75d652
SIZE (hashicorp-serf-v0.7.0_GH0.tar.gz) = 597426
SHA256 (hashicorp-go-msgpack-fa3f638_GH0.tar.gz) = 6353c623d5d58c7ca03e2bdac63f9da7da8848fb1f5f7f239b33e3ce6fe6c6bd
diff --git a/sysutils/serf/files/patch-deps_v0-6-4.json b/sysutils/serf/files/patch-deps_v0-6-4.json
deleted file mode 100644
index 58a51512f6dc..000000000000
--- a/sysutils/serf/files/patch-deps_v0-6-4.json
+++ /dev/null
@@ -1,67 +0,0 @@
---- deps/v0-6-4.json.orig 2015-04-26 02:07:13.280072000 +0000
-+++ deps/v0-6-4.json 2015-04-26 02:07:13.280625000 +0000
-@@ -0,0 +1,64 @@
-+{
-+ "ImportPath": "github.com/hashicorp/serf",
-+ "GoVersion": "go1.4.1",
-+ "Deps": [
-+ {
-+ "ImportPath": "code.google.com/p/go.net/internal/iana",
-+ "Comment": "null-240",
-+ "Rev": "937a34c9de13c766c814510f76bca091dee06028"
-+ },
-+ {
-+ "ImportPath": "github.com/armon/circbuf",
-+ "Rev": "f092b4f207b6e5cce0569056fba9e1a2735cb6cf"
-+ },
-+ {
-+ "ImportPath": "github.com/armon/go-metrics",
-+ "Rev": "eb0af217e5e9747e41dd5303755356b62d28e3ec"
-+ },
-+ {
-+ "ImportPath": "github.com/hashicorp/go-msgpack/codec",
-+ "Rev": "71c2886f5a673a35f909803f38ece5810165097b"
-+ },
-+ {
-+ "ImportPath": "github.com/hashicorp/go-syslog",
-+ "Rev": "ac3963b72ac367e48b1e68a831e62b93fb69091c"
-+ },
-+ {
-+ "ImportPath": "github.com/hashicorp/go.net/ipv4",
-+ "Rev": "cbad13bf000d0cbdbc71506b26e94bcc72bbe74d"
-+ },
-+ {
-+ "ImportPath": "github.com/hashicorp/go.net/ipv6",
-+ "Rev": "cbad13bf000d0cbdbc71506b26e94bcc72bbe74d"
-+ },
-+ {
-+ "ImportPath": "github.com/hashicorp/logutils",
-+ "Rev": "23b0af5510a2d1442103ef83ffcf53eb82f3debc"
-+ },
-+ {
-+ "ImportPath": "github.com/hashicorp/mdns",
-+ "Rev": "eb98accb64ea232136b5344464ed1d66d40f6196"
-+ },
-+ {
-+ "ImportPath": "github.com/hashicorp/memberlist",
-+ "Rev": "9a1e242e454d2443df330bdd51a436d5a9058fc4"
-+ },
-+ {
-+ "ImportPath": "github.com/miekg/dns",
-+ "Rev": "b65f52f3f0dd1afa25cbbf63f8e7eb15fb5c0641"
-+ },
-+ {
-+ "ImportPath": "github.com/mitchellh/cli",
-+ "Rev": "e3c2e3d39391e9beb9660ccd6b4bd9a2f38dd8a0"
-+ },
-+ {
-+ "ImportPath": "github.com/mitchellh/mapstructure",
-+ "Rev": "442e588f213303bec7936deba67901f8fc8f18b1"
-+ },
-+ {
-+ "ImportPath": "github.com/ryanuber/columnize",
-+ "Comment": "v2.0.1-6-g44cb478",
-+ "Rev": "44cb4788b2ec3c3d158dd3d1b50aba7d66f4b59a"
-+ }
-+ ]
-+}