aboutsummaryrefslogtreecommitdiff
path: root/sysutils
diff options
context:
space:
mode:
authorJacques Vidrine <nectar@FreeBSD.org>1998-08-03 06:28:04 +0000
committerJacques Vidrine <nectar@FreeBSD.org>1998-08-03 06:28:04 +0000
commit5fc47fd0853f2d3edf8633cf05a0358081a81089 (patch)
tree5c938e7843d7a33ce29fdd1bd2562e5ceb3d3706 /sysutils
parentc9a53bc4e6924a1c1da5aeb19139b1a64471265d (diff)
downloadports-5fc47fd0853f2d3edf8633cf05a0358081a81089.tar.gz
ports-5fc47fd0853f2d3edf8633cf05a0358081a81089.zip
Kernel `config' wrapper ala Digital Unix's doconfig
PR: bin/3386 Submitted by: Brandon Gillespie <brandon@roguetrader.com>
Notes
Notes: svn path=/head/; revision=12260
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/doconfig/Makefile33
-rw-r--r--sysutils/doconfig/distinfo1
-rw-r--r--sysutils/doconfig/files/patch-aa20
-rw-r--r--sysutils/doconfig/pkg-comment1
-rw-r--r--sysutils/doconfig/pkg-descr12
-rw-r--r--sysutils/doconfig/pkg-plist4
6 files changed, 71 insertions, 0 deletions
diff --git a/sysutils/doconfig/Makefile b/sysutils/doconfig/Makefile
new file mode 100644
index 000000000000..20b8221d5c85
--- /dev/null
+++ b/sysutils/doconfig/Makefile
@@ -0,0 +1,33 @@
+# Ports collection Makefile for: doconfig
+# Version required: 1.1
+# Date created: 7/27/1998
+# Whom: nectar@FreeBSD.ORG
+#
+# $Id$
+#
+
+DISTNAME= doconfig-1.1
+CATEGORIES= sysutils
+MASTER_SITES= ftp://ftp.cold.org/pub/brandon/
+
+MAINTAINER= nectar@FreeBSD.ORG
+
+MAN8= autokernconf.8 doconfig.8
+
+WRKSRC= ${WRKDIR}/doconfig
+
+do-build:
+ @ ${MV} ${WRKSRC}/doconfig ${WRKSRC}/_doconfig
+ @ ${SED} 's#%%PREFIX%%#${PREFIX}#g' <${WRKSRC}/_doconfig \
+ >${WRKSRC}/doconfig
+ @ ${RM} ${WRKSRC}/_doconfig
+
+do-install:
+.for f in autokernconf doconfig
+ ${INSTALL_SCRIPT} ${WRKSRC}/${f} ${PREFIX}/sbin/${f}
+.endfor
+.for f in ${MAN8}
+ ${INSTALL_MAN} ${WRKSRC}/${f} ${PREFIX}/man/man8/${f}
+.endfor
+
+.include <bsd.port.mk>
diff --git a/sysutils/doconfig/distinfo b/sysutils/doconfig/distinfo
new file mode 100644
index 000000000000..92557c7c8da2
--- /dev/null
+++ b/sysutils/doconfig/distinfo
@@ -0,0 +1 @@
+MD5 (doconfig-1.1.tar.gz) = 3e7f6e43f480618e332eb5a6832bf734
diff --git a/sysutils/doconfig/files/patch-aa b/sysutils/doconfig/files/patch-aa
new file mode 100644
index 000000000000..e54e08c90787
--- /dev/null
+++ b/sysutils/doconfig/files/patch-aa
@@ -0,0 +1,20 @@
+--- doconfig.orig Tue Jul 28 02:35:51 1998
++++ doconfig Mon Aug 3 01:23:20 1998
+@@ -8,7 +8,7 @@
+ $log = "$sys_base/$sys_conf/kernelbuild.log";
+
+ ## we dont actually need anything here
+-$ENV{PATH} = "/bin:/sbin:/usr/bin:/usr/sbin";
++$ENV{PATH} = "/bin:/sbin:/usr/bin:/usr/sbin:%%PREFIX%%/bin";
+
+ # basic verification stuff
+ if ($< || $>) {
+@@ -44,7 +44,7 @@
+ }
+
+ $version = "1.1";
+-$autokernconf = "/usr/sbin/autokernconf";
++$autokernconf = "/usr/local/sbin/autokernconf";
+ $autokernconf_args = "";
+ $autoinstall = 0;
+ $autoreboot = 0;
diff --git a/sysutils/doconfig/pkg-comment b/sysutils/doconfig/pkg-comment
new file mode 100644
index 000000000000..0d65a04c894e
--- /dev/null
+++ b/sysutils/doconfig/pkg-comment
@@ -0,0 +1 @@
+Kernel `config' wrapper ala Digital Unix's doconfig
diff --git a/sysutils/doconfig/pkg-descr b/sysutils/doconfig/pkg-descr
new file mode 100644
index 000000000000..01ed182e6953
--- /dev/null
+++ b/sysutils/doconfig/pkg-descr
@@ -0,0 +1,12 @@
+The author wrote:
+
+ This is a kernel 'config' wrapper for the simple people, based off the
+ 'doconfig' command in Digital Unix. It is actually composed of two
+ commands written in perl4: doconfig and autokernconf. doconfig calls
+ autokernconf if no config file is specified--in the future it is intended
+ that autokernconf can be crufted up to chew on the output of dmesg and
+ other sources to give a somewhat intelligently defaulted kernel config
+ template, based off the GENERIC template. For now it just copies GENERIC
+ and changes ident as appropriate.
+
+Jacques Vidrine <nectar@FreeBSD.ORG>
diff --git a/sysutils/doconfig/pkg-plist b/sysutils/doconfig/pkg-plist
new file mode 100644
index 000000000000..9ecdca5e0ac8
--- /dev/null
+++ b/sysutils/doconfig/pkg-plist
@@ -0,0 +1,4 @@
+sbin/autokernconf
+sbin/doconfig
+man/man8/autokernconf.8.gz
+man/man8/doconfig.8.gz