aboutsummaryrefslogtreecommitdiff
path: root/sysutils
diff options
context:
space:
mode:
authorVolker Stolz <vs@FreeBSD.org>2004-07-21 12:21:16 +0000
committerVolker Stolz <vs@FreeBSD.org>2004-07-21 12:21:16 +0000
commit76fb6bb2b87bcf841b9b107133413158923464c5 (patch)
tree0363b1bcf9006c69698c0251219b7b62bd1b89bd /sysutils
parentb792ecdd80fe71b036f17a66dc017563947be028 (diff)
downloadports-76fb6bb2b87bcf841b9b107133413158923464c5.tar.gz
ports-76fb6bb2b87bcf841b9b107133413158923464c5.zip
Patch for libgtop2, unDEPRECATE.
Notes
Notes: svn path=/head/; revision=114338
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/slmon/Makefile10
-rw-r--r--sysutils/slmon/files/patch-defines.h14
2 files changed, 16 insertions, 8 deletions
diff --git a/sysutils/slmon/Makefile b/sysutils/slmon/Makefile
index e4a40cac836a..90f76bb3219c 100644
--- a/sysutils/slmon/Makefile
+++ b/sysutils/slmon/Makefile
@@ -19,6 +19,7 @@ COMMENT= S-Lang System Monitor
LIB_DEPENDS= gtop-2.0.2:${PORTSDIR}/devel/libgtop2 \
slang.1:${PORTSDIR}/devel/libslang
+USE_REINPLACE= yes
USE_GETOPT_LONG= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
@@ -28,11 +29,7 @@ MAN1= slmon.1
PLIST_FILES= bin/slmon
CPPFLAGS= -I${LOCALBASE}/include
-LDFLAGS= -L${LOCALBASE}/lib -lncurses
-
-IGNORE= Needs update for libgtop2
-EXPIRATION_DATE=2004-08-20
-DEPRECATED= ${IGNORE}
+LDFLAGS= -L${LOCALBASE}/lib -lncurses -lm
.include <bsd.port.pre.mk>
@@ -40,4 +37,7 @@ DEPRECATED= ${IGNORE}
LIB_DEPENDS+= ncurses:${PORTSDIR}/devel/ncurses
.endif
+post-patch:
+ @${REINPLACE_CMD} -e 's/glibtop_free/g_free/g' ${WRKSRC}/draw.c ${WRKSRC}/stat.c
+
.include <bsd.port.post.mk>
diff --git a/sysutils/slmon/files/patch-defines.h b/sysutils/slmon/files/patch-defines.h
index b48f5819d8d8..a7301c2b0f38 100644
--- a/sysutils/slmon/files/patch-defines.h
+++ b/sysutils/slmon/files/patch-defines.h
@@ -1,6 +1,6 @@
---- defines.h.orig Tue Nov 6 14:33:50 2001
-+++ defines.h Tue Nov 6 14:34:20 2001
-@@ -17,6 +17,7 @@
+--- defines.h.orig Wed Sep 11 19:44:03 2002
++++ defines.h Wed Jul 21 14:12:16 2004
+@@ -21,6 +21,7 @@
#ifndef SLMON_DEFINES_H
#define SLMON_DEFINES_H
@@ -8,3 +8,11 @@
#include <stdlib.h>
#include <time.h>
#include <string.h>
+@@ -47,7 +48,6 @@
+ #include <glibtop/procmap.h>
+ #include <glibtop/mountlist.h>
+ #include <glibtop/fsusage.h>
+-#include <glibtop/xmalloc.h>
+
+ #ifndef PROFILE_COUNT
+ #define PROFILE_COUNT 1000