aboutsummaryrefslogtreecommitdiff
path: root/sysutils
diff options
context:
space:
mode:
authorMatthew Seaman <matthew@FreeBSD.org>2021-02-27 13:03:47 +0000
committerMatthew Seaman <matthew@FreeBSD.org>2021-02-27 13:03:47 +0000
commit7b40004ef4b82c3028d699cc93c0d75e286dc452 (patch)
tree9807d787e87d973f27721c7b8b2e0775f7edda32 /sysutils
parentd5073c55289adfa47c642b9611178021d8d7d312 (diff)
downloadports-7b40004ef4b82c3028d699cc93c0d75e286dc452.tar.gz
ports-7b40004ef4b82c3028d699cc93c0d75e286dc452.zip
Add the missing RUN_DEPENDS on wcmatch (1)
Pet portlint Attempt to fix the do-test target: unfortunately this now requires a more modern verson of pytest than is currently available in ports. Reported by: freebsd-ports andre.rikkertdekoe.nl
Notes
Notes: svn path=/head/; revision=566700
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/py-ansible-lint/Makefile17
-rw-r--r--sysutils/py-ansible-lint/distinfo6
2 files changed, 12 insertions, 11 deletions
diff --git a/sysutils/py-ansible-lint/Makefile b/sysutils/py-ansible-lint/Makefile
index bef09fdfaedd..48b837ced998 100644
--- a/sysutils/py-ansible-lint/Makefile
+++ b/sysutils/py-ansible-lint/Makefile
@@ -1,7 +1,8 @@
# $FreeBSD$
PORTNAME= ansible-lint
-PORTVERSION= 5.0.1
+PORTVERSION= 5.0.2
+PORTREVISION= 1
CATEGORIES= sysutils python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -16,21 +17,21 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}ansible>=2.8:sysutils/ansible@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}ruamel.yaml>=0.15.37:devel/py-ruamel.yaml@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}typing-extensions>=0:devel/py-typing-extensions@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}rich>=9.5.1:textproc/py-rich@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}yaml>=0:devel/py-yaml@${PY_FLAVOR}
-
+ ${PYTHON_PKGNAMEPREFIX}yaml>=0:devel/py-yaml@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}wcmatch>=7.0:textproc/py-wcmatch@${PY_FLAVOR}
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools_scm>=1.15.0:devel/py-setuptools_scm@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}setuptools_scm_git_archive>=1.0:devel/py-setuptools_scm_git_archive@${PY_FLAVOR}
-
-TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools>=49.6.0:devel/py-setuptools@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}pytest>0:devel/py-pytest@${PY_FLAVOR} \
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>=4.6.6:devel/py-pytest@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pytest-cov>0:devel/py-pytest-cov@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pytest-xdist>0:devel/py-pytest-xdist@${PY_FLAVOR}
-NO_ARCH= yes
USES= python:3.6+
USE_PYTHON= autoplist concurrent distutils
+NO_ARCH= yes
+
+# Requires a newer version of pytest than is available in ports.
do-test:
- @(cd ${TEST_WRKSRC} && ${SETENV} ${TEST_ENV} ${PYTHON_CMD} -m tox)
+ @(cd ${TEST_WRKSRC} && ${SETENV} ${TEST_ENV} ${PYTHON_CMD} -m pytest)
.include <bsd.port.mk>
diff --git a/sysutils/py-ansible-lint/distinfo b/sysutils/py-ansible-lint/distinfo
index 38924be48d9d..7bd397c92213 100644
--- a/sysutils/py-ansible-lint/distinfo
+++ b/sysutils/py-ansible-lint/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1613826472
-SHA256 (ansible-lint-5.0.1.tar.gz) = 809655a72960754bf9afb286b7089a7cd4e0a10b80382a56ff7ad42bf056c895
-SIZE (ansible-lint-5.0.1.tar.gz) = 329284
+TIMESTAMP = 1613997391
+SHA256 (ansible-lint-5.0.2.tar.gz) = be0b7f2aa368cd33da38dfc8d7d4b26c166ea3b6db9770eeab97530533258f8e
+SIZE (ansible-lint-5.0.2.tar.gz) = 331359