aboutsummaryrefslogtreecommitdiff
path: root/sysutils
diff options
context:
space:
mode:
authorBen Woods <woodsb02@FreeBSD.org>2018-07-19 23:21:47 +0000
committerBen Woods <woodsb02@FreeBSD.org>2018-07-19 23:21:47 +0000
commita5243039179eb2f36a9fab3e76241fffa9acbc03 (patch)
tree9a429853a843f0499249933bdadd9067eb40f763 /sysutils
parentdde1d43867bed214fa25d3f97204d0c7384f67e9 (diff)
downloadports-a5243039179eb2f36a9fab3e76241fffa9acbc03.tar.gz
ports-a5243039179eb2f36a9fab3e76241fffa9acbc03.zip
Add new port sysutils/bvm
The BVM is a Bhyve virtual machine management tool based on FreeBSD that allows you to easily manage virtual machines. 1. The supported operating systems are: FreeBSD,OpenBSD,NetBSD,Debian,OpenSuse,Ubuntu Windows10 etc. 2. Supports multiple network cards and multiple hard disks. 3. There are two kinds of network modes: Bridged and NAT 4. Support grub and uefi boot 5. Support for ZFS PR: 229407 Submitted by: guoqiang_cn@126.com (maintainer) Reviewed by: ygy, yuri Differential Revision: https://reviews.freebsd.org/D16074
Notes
Notes: svn path=/head/; revision=474984
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/bvm/Makefile35
-rw-r--r--sysutils/bvm/distinfo3
-rw-r--r--sysutils/bvm/pkg-descr11
-rw-r--r--sysutils/bvm/pkg-plist6
5 files changed, 56 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index 1dd15d3767ed..fd75407b3a1c 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -129,6 +129,7 @@
SUBDIR += bulk_extractor
SUBDIR += burp
SUBDIR += busybox
+ SUBDIR += bvm
SUBDIR += byobu
SUBDIR += catfish
SUBDIR += cbsd
diff --git a/sysutils/bvm/Makefile b/sysutils/bvm/Makefile
new file mode 100644
index 000000000000..59f1ceafbd75
--- /dev/null
+++ b/sysutils/bvm/Makefile
@@ -0,0 +1,35 @@
+# Created by: Qiang Guo <guoqiang_cn@126.com>
+# $FreeBSD$
+
+PORTNAME= bvm
+PORTVERSION= 1.1.2
+CATEGORIES= sysutils
+
+MAINTAINER= guoqiang_cn@126.com
+COMMENT= Bhyve VM Manager
+
+LICENSE= BSD2CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+ONLY_FOR_ARCHS= amd64
+ONLY_FOR_ARCHS_REASON= Bhyve VM Manager is required to be built on a 64bit machine
+
+RUN_DEPENDS= bhyve-firmware>0:sysutils/bhyve-firmware \
+ grub-bhyve:sysutils/grub2-bhyve \
+ tmux:sysutils/tmux
+
+USE_GITHUB= yes
+GH_ACCOUNT= bigdragonsoft
+
+BUILD_WRKSRC= ${WRKSRC}/src
+
+do-install:
+ ${MKDIR} ${STAGEDIR}${PREFIX}/etc/bvm
+ ${INSTALL_DATA} ${WRKSRC}/conf/bvm.conf ${STAGEDIR}${PREFIX}/etc/bvm/bvm.conf.sample
+ ${INSTALL_DATA} ${WRKSRC}/conf/nat.conf ${STAGEDIR}${PREFIX}/etc/bvm/nat.conf.sample
+ ${INSTALL_DATA} ${WRKSRC}/conf/switch.conf ${STAGEDIR}${PREFIX}/etc/bvm/switch.conf.sample
+ ${INSTALL_SCRIPT} ${WRKSRC}/conf/bvmd ${STAGEDIR}${PREFIX}/etc/rc.d/
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/bvm ${STAGEDIR}${PREFIX}/bin/
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/bvmb ${STAGEDIR}${PREFIX}/bin/
+
+.include <bsd.port.mk>
diff --git a/sysutils/bvm/distinfo b/sysutils/bvm/distinfo
new file mode 100644
index 000000000000..c71f79e005a4
--- /dev/null
+++ b/sysutils/bvm/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1530316570
+SHA256 (bigdragonsoft-bvm-1.1.2_GH0.tar.gz) = f0dbbc7cafdb719593cf84bee3742c21267d97bf4cb094f71b9844d8cdc3f93d
+SIZE (bigdragonsoft-bvm-1.1.2_GH0.tar.gz) = 46858
diff --git a/sysutils/bvm/pkg-descr b/sysutils/bvm/pkg-descr
new file mode 100644
index 000000000000..0351da3d168e
--- /dev/null
+++ b/sysutils/bvm/pkg-descr
@@ -0,0 +1,11 @@
+The BVM is a Bhyve virtual machine management tool
+based on FreeBSD that allows you to easily manage virtual machines.
+
+1. The supported operating systems are:
+ FreeBSD,OpenBSD,NetBSD,Debian,OpenSuse,Ubuntu Windows10 etc.
+2. Supports multiple network cards and multiple hard disks.
+3. There are two kinds of network modes: Bridged and NAT
+4. Support grub and uefi boot
+5. Support for ZFS
+
+WWW: https://github.com/bigdragonsoft/bvm
diff --git a/sysutils/bvm/pkg-plist b/sysutils/bvm/pkg-plist
new file mode 100644
index 000000000000..dc004e8b28fa
--- /dev/null
+++ b/sysutils/bvm/pkg-plist
@@ -0,0 +1,6 @@
+bin/bvm
+bin/bvmb
+@sample %%ETCDIR%%/bvm.conf.sample
+@sample %%ETCDIR%%/nat.conf.sample
+@sample %%ETCDIR%%/switch.conf.sample
+etc/rc.d/bvmd